CCNA [Lab 9] Cấu hình inter vlan trên Router Cisco

Discussion in 'Lab' started by root, Feb 12, 2014.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    51
    Trophy Points:
    48

    Cấu hình inter vlan trên Router Cisco


    Lab cấu hình inter vlan trên Router Cisco. Chúng ta sẽ tạo VLAN trên các Switch, các PC trong cùng VLAN mới có thể truyền dữ liệu cho nhau.
    Vì vậy, chúng ta sẽ cấu hình định tuyến các vlan để các PC giữa các VLAN có thể giao tiếp với nhau. Bài lab này chúng ta sẽ cấu hình sub interface trên Router và định tuyến các VLAN trên Router.

    I. Sơ đồ và yêu cầu lab cấu hình inter vlan trên Router Cisco


    1. Sơ đồ
    - Mô hình bài lab cấu hình intervlan trên Router Cisco

    cau hinh inter vlan tren Router Cisco(1)

    2. Yêu cầu:
    - Thiết lập sơ đồ
    - Cấu hình cơ bản cho các thiết bị
    - Cấu hình VTP như sau:

    • SW1 là Server
    • SW2 là Transparent
    • SW3 là Client
    • Tạo VTP domain: SVUIT.COM
    • Tạo VTP password: 123
    - Cấu hình VLAN như sau
    • Trên Server Switch:
    cau hinh inter vlan tren Router Cisco(2)
    • Trên Transparent Switch
    cau hinh inter vlan tren Router Cisco(3)
    - Đảm bảo các Switch có đầy đủ các VLAN
    - Thực hiện gán port tùy chọn vào các VLAN tương ứng
    - Thực hiện định tuyến giữa các VLAN(default gateway là .254). Đảm bảo các VLAN có thể liên lạc được với nhau
    - Router làm DHCP Router cấp DHCP cho các VLAN
    - Đảm bảo mọi VLAN đi internet

    - tham khảo thêm các bài lab liên quan.

    1. [Lab 9.1] Cấu hình inter vlan switch layer 3
    2. [Lab 5] Cấu hình Static Route trên Cisco
    3. [Lab 6] Cấu hình định tuyến RIPv2 cho Router Cisco
    4. [Lab 7] Cấu hình định tuyến OSPF cho Router Cisco
    5. [Lab 8] cấu hình giao thức định tuyến EIGRP
    - Các bài lý thuyết tham khảo:
    1. [Bài 17] Cấu hình VLAN trunking và VTP Cisco
    2. [Bài 18] Cisco Multilayer Switch Network Diagram
    3. [Bài 11] Tìm hiểu các giao thức định truyến mạng
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Aug 4, 2016
  2. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    51
    Trophy Points:
    48

    II. Triển khai lab cấu hình inter vlan trên Router Cisco


    - Cấu hình VTP và VLAN trên Switch Cisco
    1. Switch 1:
    - Cấu hình VTP

    Code:
    SW1(config)#vtp mode server
    SW1(config)#vtp domain SVUIT.COM
    SW1(config)#vtp password 123

    - Cấu hình VLAN
    Code:
    SW1(config)#vlan 2
    SW1(config-vlan)#name CCNA
    SW1(config-vlan)#exit
    SW1(config)#vlan 3
    SW1(config-vlan)#name CCNP
    cau hinh inter vlan tren Router Cisco(4)

    - Gán port cho từng VLAN tương ứng

    Code:
    SW1(config)#interface f0/23
    SW1(config-if)#switchport mode trunk
    SW1(config-if)#interface f0/24
    SW1(config-if)#switchport mode trunk
    
    SW1(config)#interface range f0/1-6
    SW1(config-if-range)#switchport mode access
    SW1(config-if-range)#switchport access vlan 1
    
    SW1(config)#interface range f0/7-12
    SW1(config-if-range)#switchport mode access
    SW1(config-if-range)#switchport access vlan 2
    
    SW1(config)#interface range f0/13-16
    SW1(config-if-range)#switchport mode access
    SW1(config-if-range)#switchport access vlan 3
    cau hinh inter vlan tren Router Cisco(5)


    cau hinh inter vlan tren Router Cisco(6)


    2. Switch 2
    - Cấu hình tương tự như các bước của Switch 1

    Code:
    SW2(config)#vtp mode transparent
    SW3(config)#vtp password 123
    
    SW2(config)#vlan 2
    SW2(config-vlan)#name CCNA
    SW2(config-vlan)#vlan 3
    SW2(config-vlan)#name CCNP
    SW2(config-vlan)#vlan 4
    SW2(config-vlan)#name CCIE
    
    SW2(config)#interface f0/23
    SW2(config-if)#switchport mode trunk
    SW2(config)#interface f0/24
    SW2(config-if)#switchport mode trunk
    
    SW2(config)#interface range f0/1-6
    SW2(config-if-range)#switchport mode access
    SW2(config-if-range)#switchport access vlan 1
    SW2(config)#interface range f0/7-12
    SW2(config-if-range)#switchport mode access
    SW2(config-if-range)#switchport access vlan 2
    SW2(config)#interface range f0/13-16
    SW2(config-if-range)#switchport mode access
    SW2(config-if-range)#switchport access vlan 3
    SW2(config)#interface range f0/17-22
    SW2(config-if-range)#switchport mode access
    SW2(config-if-range)#switchport access vlan 4

    3. Switch 3
    - Cấu hình tương tự như các Switch trên

    Code:
    SW3(config)#vtp mode client
    SW3(config)#vtp password 123
    
    SW2(config)#interface range f0/1-6
    SW2(config-if-range)#switchport mode access
    SW2(config-if-range)#switchport access vlan 1
    SW2(config)#interface range f0/7-12
    SW2(config-if-range)#switchport mode access
    SW2(config-if-range)#switchport access vlan 2
    SW2(config)#interface range f0/13-16
    SW2(config-if-range)#switchport mode access
    SW2(config-if-range)#switchport access vlan 3

    4. Cấu hình Router ISP
    - Cấu hình IP và cấp DHCP cho mạng của Router R1

    Code:
    ISP(config)#interface f0/0
    ISP(config-if)#ip address 8.8.8.254 255.0.0.0
    ISP(config-if)#no shutdown
    
    ISP(config-if)#interface f0/1
    ISP(config-if)#ip address 123.123.123.254 255.255.0.0
    ISP(config-if)#no shutdown
    
    ISP(config)#ip dhcp pool ISP
    ISP(dhcp-config)#network 123.123.0.0 255.255.0.0
    ISP(dhcp-config)#default-router 123.123.123.254
    ISP(dhcp-config)#dns-server 8.8.8.8

    5. Cấu hình DHCP trên Router R1 cấp IP cho các VLAN
    - xin DHCP từ ISP

    Code:
    R1(config)#interface f0/1
    R1(config-if)#ip address dhcp
    R1(config-if)#no shutdown

    - Chia Sub interface cho các VLAN theo chuẩn của IEEE

    Code:
    R1(config)#interface f0/0.1
    R1(config-subif)#encapsulation dot1Q 1
    R1(config-subif)#ip address 192.168.1.254 255.255.255.0
    R1(config)#interface f0/0.2
    R1(config-subif)#encapsulation dot1Q 2
    R1(config-subif)#ip address 192.168.2.254 255.255.255.0
    R1(config)#interface f0/0.3
    R1(config-subif)#encapsulation dot1Q 3
    R1(config-subif)#ip address 192.168.3.254 255.255.255.0
    R1(config)#interface f0/0.4
    R1(config-subif)#encapsulation dot1Q 4
    R1(config-subif)#ip address 192.168.4.254 255.255.255.0
    R1(config)#interface f0/0
    R1(config-if)#no shutdown

    - Cấu hình DHCP cho các VLAN

    Code:
    R1(config)#ip dhcp pool VLAN1
    R1(dhcp-config)#network 192.168.1.0 255.255.255.0
    R1(dhcp-config)#default-router 192.168.1.254
    R1(dhcp-config)#dns-server 8.8.8.8
    R1(config)#ip dhcp pool VLAN2
    R1(dhcp-config)#network 192.168.2.0 255.255.255.0
    R1(dhcp-config)#default-router 192.168.2.254
    R1(dhcp-config)#dns-server 8.8.8.8
    R1(config)#ip dhcp pool VLAN3
    R1(dhcp-config)#network 192.168.3.0 255.255.255.0
    R1(dhcp-config)#default-router 192.168.3.254
    R1(dhcp-config)#dns-server 8.8.8.8
    R1(dhcp-config)#exit
    R1(config)#ip dhcp pool VLAN4
    R1(dhcp-config)#network 192.168.4.0 255.255.255.0
    R1(dhcp-config)#default-router 192.168.4.254
    R1(dhcp-config)#dns-server 8.8.8.8


    cau hinh inter vlan tren Router Cisco(7)


    - Cho phép các VLAN ra internet

    Code:
    R1(config)#access-list 1 permit any
    R1(config)#ip nat inside source list 1 interface f0/1 overload
    R1(config)#interface f0/1
    R1(config-if)#ip nat outside
    R1(config)#interface f0/0.1
    R1(config-subif)#ip nat inside
    R1(config-subif)#interface f0/0.2
    R1(config-subif)#ip nat inside
    R1(config-subif)#interface f0/0.3
    R1(config-subif)#ip nat inside
    R1(config-subif)#interface f0/0.4
    R1(config-subif)#ip nat inside

    6. Trên các PC
    - kiểm tra xem các PC đã được cấp DHCP và ra internet chưa

    cau hinh inter vlan tren Router Cisco(8)
     
    Last edited: Jul 24, 2016
  3. hardware245

    hardware245 New Member

    Joined:
    Jul 18, 2014
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Admin up lại ảnh giúp nhé. :)
     
  4. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    51
    Trophy Points:
    48
    hi bạn, mọi hình ảnh trong CCNA đã được upload lại hết nhé. Thanks mọi người.
     

Share This Page