CCNA [Lab 8] cấu hình giao thức định tuyến EIGRP

Discussion in 'Lab' started by root, Jan 13, 2014.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    52
    Trophy Points:
    48

    Cấu hình giao thức định tuyến EIGRP


    Giao thức định tuyến EIGRP do Cisco phát triển nên chỉ chạy được trên các sản phẩm của Cisco. Đây là điểm khác biệt so với các giao thức chuẩn RIP và OSPF (có thể chạy cho nhiều hãng khác nhau).
    Giao thức định tuyến EIGRP có tốc độ hội tụ nhanh và sử dụng băng thông hiệu quả.

    Bài lab cấu hình giao thức định tuyến EIGRP cho Router cisco sẽ hướng dẫn các bạn cấu hình giao thức định EIGRP cơ bản.

    I. Yêu cầu:

    1. Sơ đồ lab cấu hình định tuyến EIGRP

    - mô hình triển khai lab cấu hình giao thức định tuyến EIGRP.

    cau hinh giao thuc dinh tuyen EIGRP (1)

    2. yêu cầu lab cấu hình định tuyến giao thức EIGRP

    - các yêu cầu bài lab cấu hình định tuyến EIGRP cho Router Cisco

    • Thiết lập sơ đồ
    • Thực hiện định tuyến EIGRP. Đảm bảo mạng hội tụ
    • R3 cấp DHCP cho mạng LAN của R2
    • Xem bảng định tuyến topology của R2:
      • Kiểm tra FD và AD của R2 đến mạng 1.1.1.1/24 là bao nhiêu ?
      • Có bao nhiêu Successor và Feasible Successor ?
    • Kiểm tra bảng định tuyến trên R2 xem mạng đi Lookback đến R1
    • Đảm bảo R2 đến Loopback R1 qua 2 đường ( loadbalancing)
    • Chỉnh Bandwidth, delay sao cho
      • R2 --> R1 --> lo 0 : primary
      • R2 --> R3 --> R1 --> lo 0 : backup
    • Thực hiện xác thực MD5 giữa các neighbors
    • Đảm bảo tất cả đi internet

    II. Triển khai lab cấu hình định tuyến EIGRP cho Router Cisco


    1. Cấu hình IP cho các Router
    - Thực hiện cấu hình IP theo sơ đồ

    Cấu hình trên Router R1

    Code:
    R1(config)#int f0/1
    R1(config-if)#ip address dhcp
    R1(config-if)#no shutdown
    
    R1(config)#interface f0/0
    R1(config-if)#ip address 192.168.13.1 255.255.255.0
    R1(config-if)#no shutdown
    
    R1(config)#interface s0/0/0
    R1(config-if)#ip address 192.168.12.1 255.255.255.252
    R1(config-if)#no shutdown
    
    R1(config)#interface loopback 1
    R1(config-if)#ip address 1.1.1.1 255.255.255.0

    Cấu hình trên Router R2

    Code:
    R2(config)#interface s0/0/0
    R2(config-if)#ip address 192.168.12.2 255.255.255.252
    R2(config-if)#no shutdown
    
    R2(config)#interface f0/0
    R2(config-if)#ip address 192.168.23.1 255.255.255.0
    Bad mask /24 for address 192.168.23.0
    R2(config-if)#no shutdown
    
    R2(config)#interface f0/1
    R2(config-if)#ip address 172.16.2.254 255.255.255.0
    R2(config-if)#no shutdown

    Cấu hình trên Router R3

    Code:
    R3(config)#interface loopback 1
    R3(config-if)#ip address 192.168.1.1 255.255.255.0
    R3(config)#interface loopback 2
    R3(config-if)#ip address 192.168.2.1 255.255.255.0
    R3(config)#interface loopback 3
    R3(config-if)#ip address 192.168.3.1 255.255.255.0
    
    R3(config)#interface f0/0
    R3(config-if)#ip address 192.168.23.2 255.255.255.0
    R3(config-if)#no shutdown
    
    R3(config)#interface f0/1
    R3(config-if)#ip address 192.168.13.2 255.255.255.0
    R3(config-if)#no shutdown
    Cấu hình ISP ra internet. ISP là 1 router giả lập nối với Model ADSL
    Code:
    ISP(config-if)#int f0/0
    ISP(config-if)#ip address 8.8.8.254 255.0.0.0
    ISP(config-if)#no shutdown
    
    ISP(config)#interface f0/1
    ISP(config-if)#ip address 123.123.123.1 255.255.0.0
    ISP(config-if)#no shutdown

    // cấu hình DHCP cấp IP public cho R1

    Code:
    ISP(config)#ip dhcp pool ISP
    ISP(dhcp-config)#network 123.123.0.0 255.255.0.0
    ISP(dhcp-config)#default-router 123.123.123.1
    ISP(dhcp-config)#dns-server 8.8.8.8

    // cấu hình NAT cho IP private từ ISP đi qua model ra internet

    Code:
    ISP(config)#access-list 1 permit any
    ISP(config)#ip nat inside source list 1 interface f0/0 overload
    ISP(config)#exit
    ISP(config)#interface f0/0
    ISP(config-if)#ip nat outside
    ISP(config-if)#exit
    ISP(config)#interface f0/1
    R1(config-if)#ip nat inside

    2. Cấu hình định tuyến EIGRP


    - Cấu hình định tuyến EIGRP cho router R1
    Code:
    R1(config)#router eigrp 100
    R1(config-router)#network 1.1.1.1
    R1(config-router)#network 192.168.12.0
    R1(config-router)#network 192.168.13.0
    R1(config-router)#redistribute static
    R1(config-router)#no auto-summary
    R1(config-router)#passive-interface loopback 1
    

    - Cấu hình định tuyến EIGRP cho router R2
    Code:
    R2(config)#router eigrp 100
    R2(config-router)#network 192.168.12.0
    R2(config-router)#network 192.168.23.0
    R2(config-router)#network 172.16.2.0
    R2(config-router)#no auto-summary
    R2(config-router)#passive-interface f0/1

    - Cấu hình định tuyến EIGRP cho router R3

    Code:
    R3(config)#router eigrp 100
    R3(config-router)#network 192.168.1.0
    R3(config-router)#network 192.168.2.0
    R3(config-router)#network 192.168.3.0
    R3(config-router)#network 192.168.13.0
    R3(config-router)#network 192.168.23.0
    R3(config-router)#no auto-summary
    R3(config-router)#passive-interface loopback 1
    R3(config-router)#passive-interface loopback 2
    R3(config-router)#passive-interface loopback 3
    Bảng định tuyến trên R1

    cau hinh giao thuc dinh tuyen EIGRP (2)

    Bảng định tuyến trên R2

    cau hinh giao thuc dinh tuyen EIGRP (3)

    Bảng định tuyến trên R3

    cau hinh giao thuc dinh tuyen EIGRP (4)

    R2 và R3 đã cấp default route để các pc trong LAN ra internet. Tiếp theo ta sẽ cấp IP dynamic cho các pc LAN.


    3. R3 cấp DHCP cho LAN của R2
    Trên R3 tạo pool LAN2 cấp IP cho mạng LAN của R2

    Code:
    R3(config)#ip dhcp pool LAN2
    R3(dhcp-config)#network 172.16.2.0 255.255.255.0
    R3(dhcp-config)#default-router 172.16.2.254
    R3(dhcp-config)#dns-server 8.8.8.8
    - Trên interface f0/1 ta cấu hình cho các pc trong LAN nhận DHCP từ R3
    Code:
    R2(config)#interface f0/1
    R2(config-if)#ip helper-address 192.168.23.2
    - Trên PC ta kiểm tra xem đã được DHCP và ra internet được chưa

    cau hinh giao thuc dinh tuyen EIGRP (5)

    4. Xem bảng topology EIGRP của Router R2
    - sử dụng lệnh : #sh ip eigrp topology để xem bảng topology của R2


    cau hinh giao thuc dinh tuyen EIGRP (6)

    • Ta thấy có 1 đường Successor có FD và AD từ R2 đến mạng 1.1.1.1/24 là:
      • FD = 158720/ AD = 156160
    • Có 1 Đường Feasible Successor từ R2 đến mạng 1.1.1.1/24 là:
      • FD = 2297856/ AD = 128256
    5. Kiểm tra bảng định tuyến EIGRP của Router R2
    Kiểm tra bảng định tuyến R2 ta thấy R2 đi đến mạng 1.1.1.1/24 via 192.168.23.2 nghĩa là nó đi đến 1.1.1.1/24 bằng 1 đường : R2 --> R3 -->R1 -->loopback 0


    cau hinh giao thuc dinh tuyen EIGRP (7)

    6. Cấu hình Load balancing trên giao thức EIGRP

    • Để mạng R2 đến mạng loopback của R1 1.1.1.1/24 qua 2 đường thì ta cẩn chỉnh thông số variance sao cho:
    • n x FDsuccessor > FDFeasibleSuccessor
      => n > 2297856 : 158720
      => n ~ 14,47 ta lấy n = 15
    • Trên R2 ta thiết lập variance để loadbalancing
    Code:
    R2(config)#router eigrp 100
    R2(config-router)#variance 15
    • Ta #sh ip route thì thấy R2 đến 1.1.1.1/24 đã đi bằng 2 đường
    cau hinh giao thuc dinh tuyen EIGRP (8)

    7. Chỉnh Delay EIGRP
    - Để đường R2 --> R1 --> lo0FDprimary= 2297856 làm primary
    - R2 --> R3 --> R1 --> lo0 FDbk= 158720 làm backup thì ta cần chỉnh
    FDpr < FDbk
    => (10^7 : BandWidthmin + ∑delay) x 256 >= 2297856
    <=> [(10^7 : 10^5) + (x+100+5000)/10] x 256 >= 2297856
    => x >= 83660
    ta chọn x = 83661
    • Trên interface f0/0 của R2 ta chỉnh delay=83661

      Code:
      R2(config)#interface f0/0
      R2(config-if)#delay 83661
    • Lúc này ta #sh ip route thì bảng định tuyến chỉ còn lại 1 đường primary. Vì bảng định tuyến chỉ hiện đường đi tốt nhất không hiện đường phụ(backup)
    cau hinh giao thuc dinh tuyen EIGRP (9)

    • Ta #sh ip eigrp topology thì thấy đường primary và đường backup. Lúc này đường backup có chỉ số FD lớn hơn FD của backup

    cau hinh giao thuc dinh tuyen EIGRP (10)


    8. Cấu hình xác thực trên EIGRP

    • Bật xác thực EIGRP trên Router R1
      Code:
      R1(config)#key chain svuit
      R1(config-keychain)#key 1
      R1(config-keychain-key)#key-string cisco
    // bật xác thực trên từng interface
    Code:
    R1(config)#interface f0/0
    R1(config-if)#ip authentication mode eigrp 100 md5
    R1(config-if)#ip authentication key-chain eigrp 100 svuit
    
    R1(config)#interface s1/0
    R1(config-if)#ip authentication mode eigrp 100 md5
    R1(config-if)#ip authentication key-chain eigrp 100 svuit

    Bật xác thực EIGRP trên Router R2

    Code:
    R2(config)#key chain svuit
    R2(config-keychain)#key 1
    R2(config-keychain-key)#key-string cisco
    
    R2(config)#interface s1/0
    R2(config-if)#ip authentication mode eigrp 100 md5
    R2(config-if)#ip authentication key-chain eigrp 100 svuit
    
    R2(config)#interface f0/0
    R2(config-if)#ip authentication mode eigrp 100 md5
    R2(config-if)#ip authentication key-chain eigrp 100 svuit
    • Lúc này trên R3#show ip eigrp neighbors thì các neighbors đã bị mất hết vì R3 không bật xác thực trong khi R1,R2 bật xác thực MD5
    cau hinh giao thuc dinh tuyen EIGRP (11)

    • Tiến hành cấu hình xác thực MD5 trên R3
    Code:
    R3(config)#key chain svuit
    R3(config-keychain)#key 1
    R3(config-keychain-key)#key-string cisco
    
    R3(config)#interface f0/1
    R3(config-if)#ip authentication mode eigrp 100 md5
    R3(config-if)#ip authentication key-chain eigrp 100 svuit
    
    R3(config)#interface f0/0
    R3(config-if)#ip authentication mode eigrp 100 md5
    R3(config-if)#ip authentication key-chain eigrp 100 svuit
    • Lúc này R3#sh ip eigrp neighbors đã hiện lại các neighbors
    cau hinh giao thuc dinh tuyen EIGRP (12)
    - Các viết Lab tham khảo thêm
    1. [Lab 5] Cấu hình Static Route trên Cisco
    2. [Lab 6] Cấu hình định tuyến RIPv2 cho Router Cisco
    3. [Lab 7] Cấu hình định tuyến OSPF cho Router Cisco
    - Các bài lý thuyết tham khảo:
    1. [Bài 11] Tìm hiểu các giao thức định truyến mạng
    2. [Bài 13] Tìm hiểu về giao thức định tuyến RIP
    3. [Bài 14] Tìm hiểu giao thức định tuyến OSPF
    4. [Bài 15] Tìm hiểu giao thức định tuyến EIGRP
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Jul 28, 2016
  2. tranvoluong

    tranvoluong New Member

    Joined:
    Feb 2, 2016
    Messages:
    4
    Likes Received:
    3
    Trophy Points:
    3
    Cám ơn root, bài biết của root tâm huyết quá!
     
    root likes this.
  3. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    52
    Trophy Points:
    48
    Mong các bạn đóng góp thêm để cùng phát triển nhé
     
  4. vo duc trung

    vo duc trung New Member

    Joined:
    Feb 24, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Viet Nam
    trên R2 - R3 sao k có defaul route anh.em lam y chang anh , thi sau khi show ban định tuyến của R2 -R3 k có defaul route
     

Share This Page