CCNA Lab 8.1 Cấu hình HSRP và Etherchannel

Discussion in 'Lab' started by nessiggk, Oct 5, 2018.

  1. nessiggk

    nessiggk Member

    Joined:
    Feb 25, 2018
    Messages:
    31
    Likes Received:
    5
    Trophy Points:
    8
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 8.1 Cấu hình HSRP và Etherchannel




    Etherchannel được sử dụng để group các port vật lý dựa trên giao thức LACP(IEEE) và PAgP (cisco).

    Etherchannel là giao thức độc quyền của Cisco dùng để ghép nhiều đường link ethernet lại thành một đường truyền logical để tăng băng thông đường truyền lên.

    Trong bài lab của mình thì được sử dụng theo PagP. Ở bài lab này được kết hợp thêm HSRP như bài 7.0 cấu hình tuy có khác chút, và sự thêm cả 1 host Windows Server 2012r2 từ ESXi.


    I. Sơ đồ và yêu cầu của bài lab

    1. Sơ đồ


    config etherchannel and hsrp (1)

    • Bài lab sử dụng 2 Switch Layer 3

    • 1 Switch L2 cùng được tạo từ router c3745

    • 1 Windows 2012r2 từ ESXi, kết nối điều khiển monitor thông qua Remote Desktop

    • Đầu ra của internet là Wifi, thông qua card Vmnet8

    2. Yêu cầu của bài lab

    • Cấu hình Ehternetchannel giữa 2 Core Switch là L3-Sw1 và L3-Sw2, để khi đứt 1 đường giữa L3-Sw1 và L3-Sw2 thì đường còn lại vẫn hoạt động để kết nối Sw1 và Sw2

    • Cấu hình HSRP giữa 2 core Switch

    • Cấu hình Routing để các PC trong mạng ping ra internet thông qua Sw1

    • Khi Sw1 hư thì các PC vẫn đi internet được thông qua Sw2

    • Khi Sw1 phục hồi thì PC sẽ đi internet thông qua Sw1 lại như cũ

    II. Triển khai bài lab cấu hình HSRP với Ehternetchannel


    1. Cấu hình cơ bản

    • Router R1
    Code:
    R1(config)#interface f0/0
    
    R1(config-if)#ip address DHCP // xin cấp ip address từ ISP giả lập
    
    R1(config-if)#no shutdown
    
    R1(config-if)#int f0/1
    
    R1(config-if)#ip add 172.16.10.1 255.255.255.252
    
    R1(config-if)#no shutdown
    
    R1(config-if)#int f1/0
    
    R1(config-if)#ip add 172.16.11.1 255.255.255.252
    
    R1(config-if)#no shutdown
    • Routing R1
    Code:
    R1(config)#ip sla 1 // Kiểm tra Sw1
    
    R1(config-ip-sla)#icmp-echo 172.16.11.2
    
    R1(config-ip-sla-echo)#frequency 5
    
    R1(config-ip-sla-echo)#exit
    
    R1(config)#ip sla schedule 1 start-time now life forever
    
    R1(config)#track 10 rtr 1
    
    R1(config-track)#exit
    
    R1(config)#ip route 192.168.11.0 255.255.255.0 172.16.11.2 track 10
    
    R1(config)#ip route 192.168.10.0 255.255.255.0 172.16.11.2 track 10
    
    R1(config)#ip route 192.168.11.0 255.255.255.0 172.16.12.2 10
    
    R1(config)#ip route 192.168.10.0 255.255.255.0 172.16.12.2 10
    • NAT R1: Do bài lab này mình gắn vào card mạng Vmnet8 nên không cần phải cấu hình NAT nữa

    • L3-Sw1
    Code:
    L3-SW1#vlan database
    
    L3-SW1(vlan)#vlan 1
    
    VLAN 1 modified:
    
    L3-SW1(vlan)#vlan 2 name Host
    
    VLAN 2 modified:
    
    Name: Host
    
    L3-Sw1(config)#int f0/0
    
    L3-Sw1(config-if)#ip add 172.16.10.2 255.255.255.252
    
    L3-Sw1(config-if)#no shutdown
    
    L3-Sw1(config-if)#int f1/2
    
    L3-Sw1(config-if)#sw trunk encapsulation dot1q
    
    L3-Sw1(config-if)#sw mode trunk
    
    L3-Sw1(config-if)#exit
    
    L3-Sw1(config)#ip routing
    
    L3-Sw1(config)#ip route 0.0.0.0 0.0.0.0 172.16.10.1
    • L3-Sw2
    Code:
    L3-Sw2#vlan database
    
    L3-Sw2(vlan)#vlan 1
    
    VLAN 1 modified:
    
    L3-Sw2(vlan)#vlan 2 name Host
    
    VLAN 2 modified:
    
    Name: Host
    
    L3-Sw2(config)#int f0/0
    
    L3-Sw2(config-if)#ip add 172.16.11.2 255.255.255.0
    
    L3-Sw2(config-if)#no shutdown
    
    L3-Sw2(config-if)#int f1/2
    
    L3-Sw2(config-if)#sw trunk encapsulation dot1q
    
    L3-Sw2(config-if)#sw mode trunk
    
    L3-Sw2(config-if)#exit
    
    L3-Sw2(config)#ip routing
    
    L3-Sw2(config)#ip route 0.0.0.0 0.0.0.0 172.16.11.1
    • L2-Sw1
    Code:
    L2-SW1#vlan database
    
    % Warning: It is recommended to configure VLAN from config mode,
    
    as VLAN database mode is being deprecated. Please consult user
    
    documentation for configuring VTP/VLAN in config mode.
    
    
    L2-SW1(vlan)#vlan 1
    
    VLAN 1 modified:
    
    L2-SW1(vlan)#vlan 2 name Host
    
    VLAN 2 modified:
    
    Name: Host
    
    L2-SW1(vlan)#exit
    
    L2-SW1#conf t
    
    L2-SW1(config)#int f1/2
    
    L2-SW1(config-if)#sw access vlan 1
    
    L2-SW1(config-if)#int f1/3
    
    L2-SW1(config-if)#sw access vlan 2

    • Ethernetswitch-1: Để hiệu chỉnh như ban đầu tức là e0, e1 mode access vlan 1

    • PC:
    Code:
    PC-1> ip 192.168.20.131/24 192.168.20.250
    
    Checking for duplicate address...
    
    PC1: 192.168.11.1 255.255.255.0 gateway 192.168.11.250
    • WinSv: Windows2012r2
    config etherchannel and hsrp (2)


    2. Cấu hình Ethernetchannel cho L3-Sw1 và L3-Sw2


    Cấu hình bó 2 cổng f1/0 và f1/1 của cả 2 L3-Sw1 và 2, cấu hình phải đồng bộ từ 2 Sw. Sau khi đã cấu hình được Etherchannel thì đặt chúng ở mode trunk -> thực hiện nhiệm vụ

    • L3-Sw1
    Code:
    L3-Sw1(config)#interface range f 1/0 - 1
    
    L3-Sw1(config-if-range)#channel-group 1 mode on
    
    L3-Sw1(config)#interface port-channel 1
    
    L3-Sw1(config-if)#switchport mode trunk
    • L3-Sw2
    Code:
    L3-Sw2(config)#interface range f 1/0 - 1
    
    L3-Sw2(config-if-range)#channel-group 1 mode on
    
    L3-Sw2(config)#interface port-channel 1
    
    L3-Sw2(config-if)#switchport mode trunk
    • Kiểm tra lại
    Code:
    L3-SW1#show etherchannel summary
    
    Flags:  D - down  P - in port-channel
    
    I - stand-alone s - suspended
    
    R - Layer3  S - Layer2
    
    U - in use
    
    Group Port-channel  Ports
    
    -----+------------+-----------------------------------------------------------
    
    1  Po1(SU)  Fa1/0(P)  Fa1/1(P)
    
    Thông tin ở trên cho thấy ta đã cấu hình thành công

    3. Cấu hình HSRP cho L3-Sw1 và L3-Sw2


    • L3-Sw1
    Code:
    L3-Sw1(config)#interface vlan 1
    
    L3-Sw1(config-if)#ip add 192.168.19.100 255.255.255.0
    
    L3-Sw1(config-if)#no shutdown
    
    L3-Sw1(config-if)#exit
    
    L3-Sw1(config)#interface vlan 2
    
    L3-Sw1(config-if)#ip add 192.168.20.100 255.255.255.0
    
    L3-Sw1(config-if)#no shutdown
    
    L3-Sw1(config)#track 20 interface f0/0 line-protocol
    
    L3-Sw1(config)#interface vlan 1
    
    L3-Sw1(config-if)#standby 1 ip 10.123.10.250
    
    L3-Sw1(config-if)#standby 1 priority 200
    
    L3-Sw2(config-if)#standby 1 track 10 decrement 101
    
    L3-Sw1(config-if)#standby 1 preempt
    
    L3-Sw1(config)#interface vlan 2
    
    L3-Sw1(config-if)#standby 2 ip 10.123.10.250
    
    L3-Sw1(config-if)#standby 2 priority 200
    
    L3-Sw2(config-if)#standby 2 track 10 decrement 101
    
    L3-Sw1(config-if)#standby 2 preempt
    • L3-Sw2
    Code:
    L3-Sw1(config)#interface vlan 1
    
    L3-Sw1(config-if)#ip add 192.168.19.101 255.255.255.0
    
    L3-Sw1(config-if)#no shutdown
    
    L3-Sw1(config-if)#exit
    
    L3-Sw1(config)#interface vlan 2
    
    L3-Sw1(config-if)#ip add 192.168.20.101 255.255.255.0
    
    L3-Sw1(config-if)#no shutdown
    
    L3-Sw1(config)#interface vlan 1
    
    L3-Sw1(config-if)#standby 1 ip 192.168.19.250
    
    L3-Sw1(config-if)#standby 1 preempt
    
    L3-Sw1(config)#interface vlan 2
    
    L3-Sw1(config-if)#standby 2 ip 192.168.20.250
    
    L3-Sw1(config-if)#standby 2 preempt

    • Có thể kiểm tra lại qua lệnh
    Code:
    L3-SW1#show standby brief
    
    P indicates configured to preempt.
    
    |
    
    Interface  Grp Prio P State  Active          Standby  Virtual IP
    
    Vl1  1  200  P Active  local          192.168.19.101  192.168.19.250
    
    Vl2  2  200  P Active  local          192.168.20.101  192.168.20.250
    
    
    L3-SW2#show standby brief
    
    P indicates configured to preempt.
    
    |
    
    Interface  Grp Prio P State  Active          Standby  Virtual IP
    
    Vl1  1  100  P Standby  192.168.19.100  local  192.168.19.250
    
    Vl2  2  100  P Standby  192.168.20.100  local  192.168.20.250

    4. Kiểm tra các yêu của bài Lab


    • Test khi xảy ra sự cố đứt một đường trong port-channel 1 thì đường kia vẫn hoạt động

    • PC-1 và WinSv đi ra mạng thông qua L3-Sw1
    config etherchannel and hsrp (3)


    config etherchannel and hsrp (4)


    • Thử khi L3-Sw1 down
    config etherchannel and hsrp (5)


    • Sau khi L3-Sw1 phục hồi, nó sẽ lên nắm quyền Active lại
    config etherchannel and hsrp (6)
     
    Last edited: Oct 8, 2018

Share This Page