CCNA [Lab 7] Cấu hình định tuyến OSPF cho Router Cisco

Discussion in 'Lab' started by root, Jan 10, 2014.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    51
    Trophy Points:
    48

    Cấu hình OSPF cho Router Cisco


    Bài lab "Cấu hình OSPF cho Router Cisco" sẽ cấu hình các tính năng của giao thức định tuyến OSPF trên Router Cisco.
    OSPF là giao thức thuộc nhóm Link-state, thường được triển khai trong các hệ thống mạng phức tạp cho các Enterprise.

    Chúng ta sẽ kết hợp cấu hình DHCP với cấu hình định tuyến OSPF trên Router Cisco trong bài lab này.

    I. Chuẩn bị

    1. Mô hình lab cấu hình OSPF cho Router Cisco


    - Mô hình triển khai bài lab cấu hình OSPF cho Router Cisco.


    cau hinh dinh tuyen OSPF cho Router Cisco (1)
    2. Yêu cầu bài lab
    • Thiết lập sơ đồ
    • Định tuyến OSPF cho các router. Đảm bảo mạng hội tụ
    • Đảm bảo hệ thống đi internet
    • R1 cấp DHCP cho các LAN của R2 và R3
    - Hiệu chỉnh OSPF
    - Đảm bảo :

    • Router-id của R1 là 1.1.1.1
    • Router-id của R2 là 2.2.2.2
    • Router-id của R3 là 3.3.3.3
    - Đảm bảo môi trường Multiaccess
    • R1 là DR
    • R2 là BDR
    • R3 là DRother
    Đảm bảo R3 đi đến lo0 của R1 theo 2 đường:
    R3 --> R1 --> lo0
    R3 --> R2 --> R1 --> lo0

    II. Triển khai cấu hình định tuyến OSPF trên Router Cisco

    1. Cấu hình IP address cho các Router

    - Trên R1

    Code:
    R1(config)#interface f0/0
    R1(config-if)#ip address dhcp
    R1(config-if)#no shutdown
    
    R1(config)#interface f0/1
    R1(config-if)#ip address 192.168.123.1 255.255.255.0
    R1(config-if)#no shutdown
    
    R1(config)#int loopback 0
    R1(config-if)#ip address 192.168.1.1 255.255.255.0

    • Trên R2
    Code:
    R2(config-if)#interface f0/0
    R2(config-if)#ip address 192.168.2.254 255.255.255.0
    R2(config-if)#no shutdown
    
    R2(config)#interface f0/1
    R2(config-if)#ip address 192.168.123.2 255.255.255.0
    R2(config-if)#no shutdown
    
    R2(config)#interface s0/0/0
    R2(config-if)#ip address 192.168.23.2 255.255.255.248
    R2(config-if)#no shutdown

    • Trên R3
    Code:
    R3(config)#interface f0/0
    R3(config-if)#ip address 192.168.3.254 255.255.255.0
    R3(config-if)#no shutdown
    
    R3(config)#interface f0/1
    R3(config-if)#ip address 192.168.123.3 255.255.255.0
    R3(config-if)#no shutdown
    
    R3(config)#interface s0/0/0
    R3(config-if)#ip address 192.168.23.3 255.255.255.248
    R3(config-if)#no shutdown

    • Trên server Google: Ta dùng 1 server để giả lập server google trong mô hình này trên Packet tracert
    Code:
    Ipaddress : 8.8.8.8
    Subnet-mask: 255.0.0.0
    Default gateway : 8.8.8.1
    - Trên ISP: Ta dùng 1 router giả lập là nhà cung cấp dịch vụ ISP. Nhà ISP có nhiệm vụ cấp DHCP ip public cho mạng LAN

    - Thiết lập IP trên các interface cho ISP

    Code:
    ISP(config)#int f0/0
    ISP(config-if)#ip address 123.123.123.1 255.255.0.0
    
    ISP(config)#int f0/1
    ISP(config-if)#ip address 8.8.8.1 255.0.0.0

    - Cấu hình DHCP trên ISP để cấp IP publish động cho R1 để R1 ra internet

    Code:
    ISP(config)#ip dhcp pool WAN_ISP
    ISP(dhcp-config)#network 123.123.0.0 255.255.0.0
    ISP(dhcp-config)#default-router 123.123.123.1
    ISP(dhcp-config)#dns-server 8.8.8.8
    - Cấu hình Nat để cho mạng LAN bên R1 có thể ping được địa chỉ google 8.8.8.8
    Code:
    R1(config)#access-list 1 permit any
    R1(config)#ip nat inside source list 1 interface f0/0 overload
    R1(config)#int f0/0
    R1(config-if)#ip nat outside
    R1(config-if)#exit
    R1(config)#int f0/1
    R1(config-if)#ip nat inside
    R1(config-if)#do ping 8.8.8.8

    2. Cấu hình định tuyến OSPF cho Router cisco

    - Cấu hình định tuyến OSPF cho Router R1:
    R1(config)#router ospf 100
    R1(config-router)#network 192.168.123.1 0.0.0.0 area 0
    R1(config-router)#network 192.168.1.1 0.0.0.0 area 0
    R1(config-router)#default-information originate //cấp default route cho mạng LAN bên trong

    - Ta thấy R1 đển đến mạng 192.168.23.0/29 có thế đi theo 2 đường qua R2 hoặc qua R3 vì có chỉ số cost = 65


    cau hinh dinh tuyen OSPF cho Router Cisco (2)


    - Cấu hình định tuyến OSPF cho Router R2

    Code:
    R2(config)#router ospf 100
    R2(config-router)#network 192.168.123.2 0.0.0.0 area 0
    R2(config-router)#network 192.168.23.2 0.0.0.0 area 0
    R2(config-router)#network 192.168.2.254 0.0.0.0 area 0
    Default-route để R2 đi ra internet được cấp từ R1 gửi qua có dạng là O*

    cau hinh dinh tuyen OSPF cho Router Cisco (3)

    • Cấu hình định tuyến OSPF cho Router R3
    Code:
    R3(config)#router ospf 100
    R3(config-router)#network 192.168.3.254 0.0.0.0 area 0
    R3(config-router)#network 192.168.23.3 0.0.0.0 area 0
    R3(config-router)#network 192.168.123.3 0.0.0.0 area 0
    cau hinh dinh tuyen OSPF cho Router Cisco (4)

    3. Cấu hình DHCP trên Router Cisco
    - Trên R1: Cấu hình Cấp DHCP cho mạng LAN của R2
    Code:
    R1(config)#ip dhcp pool LAN2
    R1(dhcp-config)#network 192.168.2.0 255.255.255.0
    R1(dhcp-config)#default-router 192.168.2.254
    R1(dhcp-config)#dns-server 8.8.8.8

    - Cấu hình cấp DHCP cho mạng LAN của R3

    Code:
    R1(config)#ip dhcp pool LAN3
    R1(dhcp-config)#network 192.168.3.0 255.255.255.0
    R1(dhcp-config)#default-router 192.168.3.254
    R1(dhcp-config)#dns-server 8.8.8.8
    - Trên R2: cấu hình chuyển DHCP broadcast thành DHCP unicast
    Code:
    R2(config)#int f0/0
    R2(config-if)#ip helper-address 192.168.123.1
    - Trên R3: cấu hình chuyển DHCP broadcast thành DHCP unicast
    Code:
    R3(config)#int f0/0
    R3(config-if)#ip helper-address 192.168.123.1
    4. Kiểm tra hệ thống mạng ra internet
    - Trên PC1 của mạng LAN R2 ta kiểm tra xem pc đã nhận được IP từ DHCP và ping được ra google chưa


    cau hinh dinh tuyen OSPF cho Router Cisco (5)

    - Tương tự ta kiểm tra pc3 của mạng LAN của R3

    cau hinh dinh tuyen OSPF cho Router Cisco (6)


    III. Hiệu chỉnh OSPF
    1. Cấu hình Router-id OSPF cố định cho các Router
    - Trên R1
    Code:
    R1(config)#router ospf 100[/B][/B][/B]
    [B][B][B]R1(config-router)#router-id 1.1.1.1
    R1(config-router)#end
    R1#clear ip ospf process

    - Trên R2
    Code:
    R2(config)#router ospf 100[/B][/B][/B]
    [B][B][B]R2(config-router)#router-id 2.2.2.2
    R2(config-router)#end
    R2#clear ip ospf process


    - Trên R3
    Code:
    R3(config)#router ospf 100[/B][/B][/B]
    [B][B][B]R3(config-router)#router-id 3.3.3.3
    R3(config-router)#end
    R3#clear ip ospf process


    - Dùng lệnh Show ip ospf neighber để kiểm tra xem các router-id đã được thay đổi chưa

    • Trên R1

    cau hinh dinh tuyen OSPF cho Router Cisco (7)

    • Trên R2

    cau hinh dinh tuyen OSPF cho Router Cisco (8)

    • Trên R3

    cau hinh dinh tuyen OSPF cho Router Cisco (9)


    2. Đảm bảo môi trường Multiaccess

    • Để bầu chọn DR,BDR thì các router sẽ dựa vào 2 thông số: priority(càng cao thì làm DR) rồi sau đó nó xét tới chỉ số của Router-id.
    • Mặc định chỉ số Priority của các router = 1, mà ở trên chúng ta đã fix cố định chỉ số Router-id. Nên để bầu chọn DR,BDR chúng ta cần thay đổi chỉ số priority trên các interface của router.
    • Ở đây để R1 làm DR, R2 làm BDR, R3 làm BDR thì ta cần chỉnh priority của R1 > R2 > R3. Sau đây ta sẽ vào chỉnh priority trên:
    - Trên R1
    Code:
    R1(config)#int f0/1
    R1(config-if)#ip ospf priority 100
    - Trên R2
    Code:
    R2(config)#int f0/1
    R2(config-if)#ip ospf priority 10
    • Để các router bầu chọn lại DR,BDR thì chúng ta cần phải reset lại router hoặc shutdown cái interface. Vì cách reset router là lâu và không tốt nên ở đây chung ta có thể vào switch và shutdown hàng loạt các interface nối với router là nhanh nhất

    - Trên Switch 1:

    Code:
    SW1(config)#interface range f0/1-24
    SW1(config-if-range)#shutdown
    SW1(config-if-range)#no shutdown
    • Kiểm tra lại xem các router đã bầu chọn lại DR,BDR theo ý mình chưa bằng câu lệnh "show ip ospf neighber"

    cau hinh dinh tuyen OSPF cho Router Cisco (10)

    3. Load balancing OSPF configuration

    - cấu hình load balancing chạy giao thức OSPF cho 2 đường truyền

    • Để R3 đi đên Lo0 theo hai đường ta phải set giá trị cost của 2 đường này bằng nhau
    • R3 --> R1 --> lo0 có cost = 2
    • R3 --> R2 --> R1 --> lo0 có cost = 66
    • Vậy để loadbalancing được trong trường hợp này ta cần chỉnh cost ở interface f0/1 của R3 lên 65 để cost 2 đường trên = 66
    - Trên R3
    Code:
    R3(config)#int f0/1
    R3(config-if)#ip ospf cost 65
    - Ta thấy giá trị cost trên interface f0/1 của R3 đã thay đổi thành 65

    cau hinh dinh tuyen OSPF cho Router Cisco (11)

    **Lưu ý : khi thực hiện loadbalancing trên packet tracert 6.x thì hên xui lúc được lúc không nhé :(


    4. Cấu hình xác thực OSPF bằng thuật toán MD5

    - Hướng dẫn cấu hình xác thực OSPF bằng thuật toán MD5
    • Mã hóa MD5 giữa 2 router R2 và R3 trên kết nối Serial ta gõ lệnh sau trên cả 2 router(cả 2 router phải gõ giống hệt nhau)
    • Trên R2 ta gõ y chang như đã gõ ở trên R3 để chúng có thể xác thực với nhau
    Code:
    R2(config-if)#ip ospf authentication message-digest
    R2(config-if)#ip ospf message-digest-key 1 md5 cisco
    • Lúc này ta xem lại trên bangr neighber trên R2 thì thấy mạng neighber R3 đã bị mất vì trên s0/0/0 của R3 ta chưa cho xác thực bằng mã MD5
    cau hinh dinh tuyen OSPF cho Router Cisco (12)

    • Trên R3
    Code:
    R3(config-if)#ip ospf authentication message-digest
    R3(config-if)#ip ospf message-digest-key 1 md5 cisco
    - Sau khi đã cho xác thực trên R3 ta kiểm tra lại xem đã xuất hiện lại neighber serial R2 chưa

    cau hinh dinh tuyen OSPF cho Router Cisco (13)


    - Các viết Lab tham khảo thêm
    1. [Lab 5] Cấu hình Static Route trên Cisco
    2. [Lab 6] Cấu hình định tuyến RIPv2 cho Router Cisco
    3. [Lab 8] cấu hình giao thức định tuyến EIGRP
    - Các bài lý thuyết tham khảo:
    1. [Bài 11] Tìm hiểu các giao thức định truyến mạng
    2. [Bài 13] Tìm hiểu về giao thức định tuyến RIP
    3. [Bài 14] Tìm hiểu giao thức định tuyến OSPF
    4. [Bài 15] Tìm hiểu giao thức định tuyến EIGRP
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.


     
    Last edited: Jul 28, 2016
  2. ducbuii

    ducbuii New Member

    Joined:
    Apr 5, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Ha Noi
    tại sao cấu hình DHCP cho ISP mà nó không tự cấp ip public cho R1 vậy ad
     
  3. redhat

    redhat New Member

    Joined:
    Feb 13, 2018
    Messages:
    17
    Likes Received:
    4
    Trophy Points:
    3
    Gender:
    Male
    Ý bạn là sao nhỉ, bạn đang bị lỗi hay sao
     
  4. ducbuii

    ducbuii New Member

    Joined:
    Apr 5, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Ha Noi
    mình định tuyến theo lệnh
    R1(config)#router ospf 100
    R1(config-router)#network 192.168.123.0 0.0.0.255 area 0
    R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
    Mọi thứ trong mạng Lan chạy ok hết rồi.
    Mình đã Nat ra ngoài, nhưng PC trong mạng Lan không thể ping tới Router 0 hoặc Server. Vậy làm thế nào để sau khi gói tin đi ra môi trường Internet có thể tìm tới Server. trong khi k có lệnh nào định tuyến bên ngoài
     
  5. ducbuii

    ducbuii New Member

    Joined:
    Apr 5, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Ha Noi
    ad làm ơn trả lời giúp. mình làm mãi không ra. đợi ad lâu quá
     

Share This Page