CCNA Lab 7.0 Cấu hình HSRP Cisco

Discussion in 'Lab' started by nessiggk, Aug 2, 2018.

  1. nessiggk

    nessiggk New Member

    Joined:
    Feb 25, 2018
    Messages:
    23
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 7.0 Cấu hình HSRP Cisco




    HSRP – Hot Standby Router Protocol là một giao thức cung cấp tính năng dự phòng cho Router Cisco hay Switch Layer 3. Trong một hệ thống, khi một Router xảy ra các vấn đề như bị down, đứt đường hay cũng có thể là mất địa chỉ ip,.. ta cần hệ thống vẫn hoạt động bình thường qua các Router còn lại. Việc cấu hình HSRP sẽ giúp chúng ta cấu hình dự phòng cho trường hợp trên.


    Cấu hình HSRP để tạo ra một Router có gateway ảo cho mạng Lan để dự phòng gateway cho hệ thống. Ngoài ra trong bài lab ta cũng sử dụng track cho giao thức HSRP.


    I. Sơ đồ và yêu cầu của bài lab cấu hình HSRP


    1. Sơ đồ


    • Sơ đồ của bài lab cấu hình HSRP
    Cau hinh hsrp (1)

    2. Yêu cầu


    • Cấu hình cơ bản như sơ đồ
      • Sw Layer 2

      • Giả lập Sw Layer 3 dùng c3725
    • Cấu hình SPT
      • PC1 thuộc vlan 10 đi internet qua L3-Sw1 (đường Sw1 với L3-Sw2 bị block)

      • PC2 thuộc vlan 20 đi internet qua L3-Sw2 (đường Sw2 với L3-Sw1 bị block)

      • Nếu đường Sw1 với L3-Sw1 bị đứt thì PC1 vẫn đi internet được

      • Nếu đường Sw2 với L3-Sw2 bị đứt thì PC1 vẫn đi internet được
    • Cấu hình HSRP giữa Sw1 và Sw2 để
      • L3-Sw 1 bị chết thì PC1 vẫn đi internet bình thường

      • L3-Sw 2 bị chết thì PC2 vẫn đi internet bình thường
    • Khi đường R1 với L3-Sw1 bị đứt thì PC1 vẫn đi Internet được

    • Khi đường R1 với L3-Sw2 bị đứt thì PC2 vẫn đi Internet được

    II. Cấu hình cơ bản


    1. Router R1 và PC


    • Router R1
    Code:
    R1(config)#int f0/0
    
    R1(config-if)#ip add 192.168.10.147 255.255.255.0
    
    R1(config-if)#no shutdown
    
    R1(config-if)#int f0/1
    
    R1(config-if)#ip add 172.16.11.1 255.255.255.252
    
    R1(config-if)#no shutdown
    
    R1(config-if)#int f1/0
    
    R1(config-if)#ip add 172.16.12.1 255.255.255.252
    
    R1(config-if)#no shutdown
    • Routing R1
    Code:
    R1(config)#ip sla 10
    
    R1(config-ip-sla)#icmp-echo 172.16.11.2
    
    R1(config-ip-sla-echo)#frequency 5
    
    R1(config)#ip sla schedule 10 life forever start-time now
    
    R1(config)#track 10 rtr 10
    
    R1(config)#ip sla 20
    
    R1(config-ip-sla)#icmp-echo 172.16.12.2
    
    R1(config-ip-sla-echo)#frequency 5
    
    R1(config)#ip sla schedule 20 life forever start-time now
    
    R1(config)#track 20 rtr 20
    
    R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.2 254
    
    R1(config)#ip route 10.123.10.0 255.255.255.0 172.16.11.2 track 10
    
    R1(config)#ip route 10.123.10.0 255.255.255.0 172.16.12.2 10
    
    R1(config)#ip route 10.123.20.0 255.255.255.0 172.16.12.2 track 20
    
    R1(config)#ip route 10.123.20.0 255.255.255.0 172.16.11.2 10
    • Ở bài lab này sử dụng card mạng ảo Vmnet1 đã cấu hình NAT rồi lên không cấu hình trên R1 nữa vẫn có thể đi internet

    • Cấu hình IP SLA để đề phòng đường đi từ R1 -> L3-Sw1 hoặc R1 -> L3-Sw2 bị đứt thì vẫn có thể đi internet thông qua đường còn lại

    • PC (GW ở đây là GW ảo)
    Code:
    PC-1> ip 10.123.10.10/24 10.123.10.250
    
    PC-2> ip 10.123.20.20/24 10.123.20.250
    III. Cấu hình Switch


    • L3-Sw1
    Code:
    L3-Sw1(config)#interface range f1/0 - 2
    
    L3-Sw1(config-if-range)#sw trunk encapsulation dot1q
    
    L3-Sw1(config-if-range)#sw mode trunk
    
    L3-Sw1(config-if-range)#sw trunk allowed vlan 10,20
    
    L3-Sw1(config)#int f0/0
    
    L3-Sw1(config-if)#ip add 172.16.11.2 255.255.255.252
    
    L3-Sw1(config-if)#no shut
    
    L3-Sw1(config)#ip route 0.0.0.0 0.0.0.0 172.16.11.1
    • L3-Sw2
    Code:
    L3-Sw2(config)#interface range f1/0 - 2
    
    L3-Sw2(config-if-range)#sw trunk encapsulation dot1q
    
    L3-Sw2(config-if-range)#sw mode trunk
    
    L3-Sw2(config-if-range)#sw trunk allowed vlan 10,20
    
    L3-Sw2(config)#int f0/0
    
    L3-Sw2(config-if)#ip address 172.16.12.2 255.255.255.252
    
    L3-Sw2(config-if)#no shut
    
    L3-Sw2(config)#ip route 0.0.0.0 0.0.0.0 172.16.12.1
    • Sw1
    Code:
    Sw1(config)#int range e0/0 - 1
    
    Sw1(config-if-range)#sw trunk encapsulation dot1q
    
    Sw1(config-if-range)#sw mode trunk
    
    Sw1(config-if-range)#sw trunk allowed vlan 10,20
    
    Sw1(config-if-range)#exit
    
    Sw1(config)#vlan 10
    
    Sw1(config-vlan)#name 10
    
    Sw1(config)#vlan 20
    
    Sw1(config-vlan)#name 20
    
    Sw1(config)#int e0/2
    
    Sw1(config-if)#sw access vlan 10
    • Sw2
    Code:
    Sw2(config)#int range e0/0 - 1
    
    Sw2(config-if-range)#sw trunk encapsulation dot1q
    
    Sw2(config-if-range)#sw mode trunk
    
    Sw1(config-if-range)#sw trunk allowed vlan 10,20
    
    Sw2(config)#vlan 10
    
    Sw2(config-vlan)#name 10
    
    Sw2(config)#vlan 20
    
    Sw2(config-vlan)#name 20
    
    Sw2(config-vlan)#int e0/2
    
    Sw2(config-if)#sw access vlan 20

    IV. Cấu hình SPT


    • Cần chỉnh sửa lại cho L3-Sw1 làm Root Sw của Vlan 10 và làm Root Sw dự phòng của Vlan 20
    Code:
    L3-Sw1(config)#spanning-tree vlan 10 root primary
    
    L3-Sw1(config)#spanning-tree vlan 20 root secondary
    • Tương tự L3-Sw2 làm Root Sw Vlan 20 và Root Sw dự phòng của Vlan 10
    Code:
    L3-Sw2(config)#spanning-tree vlan 10 root secondary
    
    L3-Sw2(config)#spanning-tree vlan 20 root primary
    • Kiểm tra xem đường Sw1 với L3-Sw2 có bị khoá không,để PC1 đi internet theo đường L3-Sw1, ở đây E0/1 đã bị khoá
    Cau hinh hsrp (2)

    • Kiểm tra đường Sw2 với L3-Sw1 có bị khoá không, PC2 đi internet theo đường L3-Sw2, E0/1 đã bị khoá
    Cau hinh hsrp (3)


    V. Cấu hình HSRP cho Switch Layer 3


    • L3-Sw1
    Code:
    L3-Sw1(config)#interface vlan 10
    
    L3-Sw1(config-if)#ip add 10.123.10.1 255.255.255.0
    
    L3-Sw1(config-if)#no shutdown
    
    L3-Sw1(config-if)#exit
    
    L3-Sw1(config)#interface vlan 20
    
    L3-Sw1(config-if)#ip add 10.123.20.1 255.255.255.0
    
    L3-Sw1(config-if)#no shutdown
    
    L3-Sw1(config)#track 10 interface f0/0 line-protocol // cấu hình track theo dõi cổng f0/0
    
    L3-Sw1(config)#ip routing // Bật chế độ định tuyến trên Layer3
    
    L3-Sw1(config)#interface vlan 10
    
    L3-Sw1(config-if)#standby 10 ip 10.123.10.250
    
    L3-Sw1(config-if)#standby 10 priority 200
    
    L3-Sw2(config-if)#standby 10 track 10 decrement 101 // Khi cổng f0/0 down, priority sẽ bị trừ đi 101 tức là 200 – 101 = 99 < 100 default của L3-Sw2 → Set L3–Sw2 làm Active cho Group 10
    
    L3-Sw1(config-if)#standby 10 preempt
    
    L3-Sw1(config)#interface vlan 20
    
    L3-Sw1(config-if)#standby 20 ip 10.123.20.250
    
    L3-Sw1(config-if)#standby 20 preempt
    • L3-Sw2
    Code:
    L3-Sw2(config)#interface vlan 10
    
    L3-Sw2(config-if)#ip address 10.123.10.2 255.255.255.0
    
    L3-Sw2(config-if)#no shutdown
    
    L3-Sw2(config-if)#exit
    
    L3-Sw2(config)#interface vlan 20
    
    L3-Sw2(config-if)#ip address 10.123.20.2 255.255.25
    
    L3-Sw2(config-if)#ip address 10.123.20.2 255.255.255.0
    
    L3-Sw2(config-if)#no shutdown
    
    L3-Sw2(config)#track 20 interface f0/0 line-protocol
    
    L3-Sw2(config)#ip routing
    
    L3-Sw2(config)#interface vlan 10
    
    L3-Sw2(config-if)#standby 10 ip 10.123.10.250
    
    L3-Sw2(config-if)#standby 10 preempt
    
    L3-Sw2(config)#interface vlan 20
    
    L3-Sw2(config-if)#standby 20 ip 10.123.20.250
    
    L3-Sw2(config-if)#standby 20 priority 200
    
    L3-Sw2(config-if)#standby 20 track 20 decrement 101
    
    L3-Sw2(config-if)#standby 20 preempt

    • Giờ ta sẽ kiểm thử lại những gì cấu hình đã theo đúng yêu cầu chưa:
      • Đầu tiên là việc đi ra ngoài Internet của PC1 đi qua L3-Sw1: Do bị block đoạn Sw1 với L3-Sw2 nên đường đi sẽ đúng như trên
    Cau hinh hsrp (4)

    • Tương tự PC2 ra Internet qua L3-Sw2
    Cau hinh hsrp (5)

    • Khi đường Sw1 với L3-Sw1 bị đứt, PC1 vẫn đi Internet được. Khi này Trong đoạn Sw1 – L3-Sw1 – Sw2 – L3-Sw2 vẫn còn SPT, và sẽ mở khoá đoạn Sw1 – L3-Sw2 để đi Internet theo đường PC1 -> Sw1 -> L3-Sw2 -> L3-Sw1 -> R1 -> Internet
    Cau hinh hsrp (6)

    //PC1 ping 8.8.8.8

    Cau hinh hsrp (7)

    • Tương tự trường hợp trên đối với đoạn Sw2 – L3-Sw2 bị đứt

    • Khi L3-Sw1 bị chết, không gửi được gói tin Helo, ở L3-Sw2 không nhận gói tin Active Group 10 thì nó sẽ đứng lên làm Active cho Group 10 cho đến khi L3-Sw1 sống lại, bởi mình đã cấu hình Preempt.
    Cau hinh hsrp (8)

    Cau hinh hsrp (9)

    Cau hinh hsrp (10)

    • Tương tự tiếp cho trường hợp L3-Sw2 bị chết

    • Khi đoạn đường R1 -> L3-Sw1 bị đứt: Khi đó như mình đã cấu hình track interface f0/0 cho L3-Sw1, sau khi down cổng sẽ track down priority sẽ bị trừ đi 101 tức là số priority khi này là 99 và nhỏ hơn số default là 100 của L3-Sw2, và L3-Sw2 sẽ đứng lên làm Active cho Group 10 cho đến khi đoạn đường đó lên lại.

    • Tuy nhiên còn một điểm nữa đó làm do đã cấu hình IP SLA cho R1 lên việc ping đến f0/0 của L3-Sw1 không thành công và sẽ bật định tuyến phụ lên, từ đó sẽ đẩy gói tin theo đường đó.
    Cau hinh hsrp (11)

    Cau hinh hsrp (12)

    Tất nhiên trường hợp này sẽ tương tự khi đoạn R1 L3-Sw2 bị đứt


    Vậy là mình đã hoàn thành bài lab cấu hình HSRP.
     
    Last edited: Aug 2, 2018

Share This Page