CCNA [Lab 6] Cấu hình định tuyến RIPv2 cho Router Cisco

Discussion in 'Lab' started by root, Dec 28, 2013.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    51
    Trophy Points:
    48

    Cấu hình định tuyến RIPv2 cho Router Cisco

    Ở phần lý thuyết "tìm hiểu giao thức định tuyến RIP" chúng ta đã tìm hiểu về các khái niệm và cách thức hoạt động của giao thức RIP.
    Phần này chúng ta sẽ làm bài Lab về định tuyến RIPv2 để kiểm tra lại các khai niệm lý thuyết về giao thức RIP mà chúng ta đã đọc trong phần lý thuyết.
    I. Mô hình :

    - Với mô hình này packet từ pc A -> pc B sẽ đi qua 2 đường là qua R2 hoặc qua R3
    - Chúng ta sẽ triển khai định tuyến Rip trên sơ đồ này.
    - Vì Rip lựa chọn đường đi dựa trên chỉ số Metric= hop-count. Nên trong mô hình này packet sẽ đi cả 2 đường.
    - Để kiểm tra tính dự phòng của sơ đồ ta tắt R2 xem packet có tự động chuyển đường đi qua R3 không

    cau hinh dinh tuyen RIP tren Router Cisco (1)

    II. Chuẩn bị :
    - Cáp đấu nối theo sơ đồ
    - Đặt IP và tên cho các thiết bị

    Trên R1

    Code:
    R1(config)#interface f0/0
    R1(config-if)#ip address 192.168.13.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    
    R1(config)#interface f0/1
    R1(config-if)#ip address 192.168.1.254 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    
    R1(config)#interface s0/0/0
    R1(config-if)#ip address 192.168.12.1 255.255.255.252
    R1(config-if)#no shutdown

    Trên R2

    Code:
    R2(config)#interface s0/0/0
    R2(config-if)#ip address 192.168.12.2 255.255.255.252
    R2(config-if)#no shutdown
    R2(config-if)#exit
    
    R2(config)#interface f0/0
    R2(config-if)#ip address 192.168.24.1 255.255.255.0
    R2(config-if)#no shutdown
    R2(config-if)#exit

    - Trên R3

    Code:
    R3(config)#interface f0/0
    R3(config-if)#ip address 192.168.13.2 255.255.255.0
    R3(config-if)#no shutdown
    
    R3(config)#interface s0/0/0
    R3(config-if)#ip address 192.168.34.1 255.255.255.252
    R3(config-if)#no shutdown

    Trên R4

    Code:
    R4(config)#interface f0/0
    R4(config-if)#ip address 192.168.24.2 255.255.255.0
    R4(config-if)#no shutdown
    R4(config-if)#exit
    
    R4(config)#interface f0/1
    R4(config-if)#ip address 192.168.4.254 255.255.255.0
    R4(config-if)#no shutdown
    R4(config-if)#exit
    
    R4(config)#interface s0/0/0
    R4(config-if)#ip address 192.168.34.2 255.255.255.252
    R4(config-if)#no shutdown

    Trên Pc A


    Trên Pc B

    Sau khi triển khai xong ta có thể thấy các thiết bị có định tuyến connected đã thông với nhau

    cau hinh dinh tuyen RIP tren Router Cisco (2)

    III. Triển khai định tuyến RIPv2 trên Router Cisco

    1. Cấu hình Ripv2 trên Router R1

    - Cấu hình định tuyến RIPv2 trên Router R1


    R1(config)#router rip
    R1(config-router)#version 2
    R1(config-router)#network 192.168.12.0
    R1(config-router)#network 192.168.13.0
    R1(config-router)#no auto-summary
    R1(config-router)#passive-interface f0/1

    - Kiểm tra Routing Table của R1 ta phát hiện. Nó không còn Summary về thành major-network 192.168.34.0/24 mà nó summary về VLSM 192.168.34.0/30.

    cau hinh dinh tuyen RIP tren Router Cisco (3)

    2. Cấu hình Ripv2 trên Router cisco R2

    - Lệnh cấu hình định tuyến Ripv2 trên Router Cisco R2

    R2(config)#router rip
    R2(config-router)#version 2
    R2(config-router)#network 192.168.12.0
    R2(config-router)#network 192.168.24.0
    R2(config-router)#no auto-summary
    - Tương tự ta kiểm tra Routing Table của R2


    cau hinh dinh tuyen RIP tren Router Cisco (4)

    3. Cấu hình Ripv2 cho Router R3

    - Các lệnh cấu hình định tuyến Ripv2 cho Router Cisco R3

    R3(config)#router rip
    R3(config-router)#version 2
    R3(config-router)#network 192.168.13.0
    R3(config-router)#network 192.168.34.0
    R3(config-router)#no auto-summary
    - Tương tự ta kiểm tra Routing Table của R3

    cau hinh dinh tuyen RIP tren Router Cisco (5)

    4. Cấu hình Ripv2 cho Router Cisco R4

    -
    các lệnh cấu hình Ripv2 trên Router Cisco R4

    R4(config)#router rip
    R4(config-router)#version 2
    R4(config-router)#network 192.168.4.0
    R4(config-router)#network 192.168.24.0
    R4(config-router)#network 192.168.34.0
    R4(config-router)#no auto-summary
    R4(config-router)#passive-interface f0/1
    - Tương tự ta kiểm tra Routing Table của R4

    cau hinh dinh tuyen RIP tren Router Cisco (6)


    5. kiểm tra kết quả :
    - có thể thấy mỗi lần packet đi mỗi đường khác nhau vì chỉ sô Metric của 2 đường là = nhau


    cau hinh dinh tuyen RIP tren Router Cisco (7)


    6. kiểm tra tính dự phòng
    - Shutdown 1 interface trên R2 or cho R2 chết. Ở đây mình shutdown S0/0/0 của R2

    cau hinh dinh tuyen RIP tren Router Cisco (8)


    - kiếm tra xem pcA còn ping được pc B không. Thì thấy gói tin nó không còn đi qua R2 nữa vì đường R2 đã bị đứt

    cau hinh dinh tuyen RIP tren Router Cisco (9)

    - Các viết Lab tham khảo thêm
    1. [Lab 5] Cấu hình Static Route trên Cisco
    2. [Lab 6.1] Config RIPv2 and DHCP relay agent
    3. [Lab 7] Cấu hình định tuyến OSPF cho Router Cisco
    4. [Lab 8] cấu hình giao thức định tuyến EIGRP
    - Các bài lý thuyết tham khảo:
    1. [Bài 11] Tìm hiểu các giao thức định truyến mạng
    2. [Bài 13] Tìm hiểu về giao thức định tuyến RIP
    3. [Bài 14] Tìm hiểu giao thức định tuyến OSPF
    4. [Bài 15] Tìm hiểu giao thức định tuyến EIGRP
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Jul 28, 2016
  2. khoa.ntk01

    khoa.ntk01 New Member

    Joined:
    Jan 4, 2015
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    Tình hình là file ảnh bị mất rồi root ạ.
     
  3. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    51
    Trophy Points:
    48
    Hi bạn,

    Đã upload lại hình bài lab

    THanks bạn,
     

Share This Page