CCNA [Lab 6.1] Config RIPv2 and DHCP relay agent

Discussion in 'Lab' started by root, Jan 8, 2014.

  1. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38

    Config RIPv2 and DHCP relay agent


    Lab config RIPv2 and DHCP relay agent là bài hướng dẫn kết hợp cấu hình định tuyến động RIP version 2 và cấu hình tính năng DHCP relay trên Router Cisco.

    Chúng ta sẽ cấu hình định tuyến RIPv2 trong hệ thống mạng để các PC trong mạng LAN có thể thông với nhau. Ngoài ra, các bạn phải cấu hình DHCP relay agent để Router DHCP server ở subnet khác có thể cấp được IP cho các PC thuộc subnet khác.

    Dưới đây là mô hình và hướng dẫn cấu hình bài lab này

    I. Chuẩn bị

    1. Sơ đồ lab Config RIPv2 and DHCP relay agent


    - Dưới đây là sơ đồ bài lab Config RIPv2 and DHCP relay agent. Gồm 4 Router trong mạng LAN kết nối ra ngoài internet (vùng server của ISP) thông qua Router R4

    config RIPv2 and DHCP relay agent (1)

    2. yêu cầu lab Config RIPv2 and DHCP relay agent
    • Đấu nối thiết bị theo sơ đồ.
    • Định tuyến RIPv2 đảm bảo mạng hội tụ.
    • Các Router không gửi routing update ra các cổng không cần thiết
    • Kiểm tra bảng định tuyến các Router.
    • Cấu hình DHCP trên các Server như sau :
      • R1 cấp DHCP với mạng 192.168.2.0
      • R2 cấp DHCP với mạng 192.168.1.0
      • R3 cấp DHCP với mạng 192.168.3.0
    • Đảm bảo hệ thống ra internet
    II. Triển khai lab Config RIPv2 and DHCP relay agent
    1. Đặt IP theo sơ đồ
    - Sử dụng cáp chéo cho các thiết bị cùng loại và cáp thẳng cho các thiết bị khác loại

    • Trên R1
      Code:
      Router(config)#hostname R1
      R1(config)#interface loopback 0
      R1(config-if)#ip address 1.1.1.1 255.255.255.0
      R1(config)#interface loopback 1
      R1(config-if)#ip address 1.2.2.2 255.255.255.0
      R1(config)#interface loopback 2
      R1(config-if)#ip address 1.3.3.3 255.255.255.0
      R1(config)#interface loopback 3
      R1(config-if)#ip address 1.4.4.4 255.255.255.0
      
      R1(config)#interface f0/0
      R1(config-if)#ip address 192.168.12.1 255.255.255.252
      R1(config-if)#no shutdown
      R1(config)#interface f0/1
      R1(config-if)#ip address 192.168.1.254 255.255.255.0 
      R1(config-if)#no shutdown
    • Trên R2
      Code:
      Router(config)#hostname R2
      R2(config)#interface loopback 0
      R2(config-if)#ip address 2.1.1.1 255.255.255.0
      R2(config)#interface loopback 1
      R2(config-if)#ip address 2.2.2.2 255.255.255.0
      R2(config)#interface loopback 2
      R2(config-if)#ip address 2.3.3.3 255.255.255.0
      R2(config)#interface loopback 3
      R2(config-if)#ip address 2.4.4.4 255.255.255.0
      
      R2(config)#interface f0/0
      R2(config-if)#ip address 192.168.12.2 255.255.255.252
      R2(config-if)#no shutdown
      R2(config)#interface f0/1
      R2(config-if)#ip address 192.168.2.254 255.255.255.0
      R2(config-if)#no shutdown
      R2(config)#interface s0/0/0
      R2(config-if)#ip address 192.168.23.1 255.255.255.252
      R2(config-if)#no shutdown


    • Trên R3
      Code:
      Router(config)#hostname R3
      R3(config)#interface loopback 0
      R3(config-if)#ip address 3.1.1.1 255.255.255.0
      R3(config)#interface loopback 1
      R3(config-if)#ip address 3.2.2.2 255.255.255.0
      R3(config)#interface loopback 2
      R3(config-if)#ip address 3.3.3.3 255.255.255.0
      R3(config)#interface loopback 3
      R3(config-if)#ip address 3.4.4.4 255.255.255.0
      
      R3(config)#interface s0/0/0
      R3(config-if)#ip address 192.168.23.2 255.255.255.252
      R3(config-if)#no shutdown
      R3(config)#interface s0/1/0
      R3(config-if)#ip address 192.168.34.1 255.255.255.252
      R3(config-if)#no shutdown
      R3(config)#interface f0/1
      R3(config-if)#ip address 192.168.3.254 255.255.255.0
      R3(config-if)#no shutdown
    • Trên R4
      Code:
      Router(config)#hostname R4
      R4(config)#interface loopback 0
      R4(config-if)#ip address 4.1.1.1 255.255.255.0
      R4(config)#interface loopback 1
      R4(config-if)#ip address 4.2.2.2 255.255.255.0
      R4(config)#interface loopback 2
      R4(config-if)#ip address 4.3.3.3 255.255.255.0
      R4(config)#interface loopback 3
      R4(config-if)#ip address 4.4.4.4 255.255.255.0
      
      R4(config)#interface s0/0/0
      R4(config-if)#ip address 192.168.34.2 255.255.255.252
      R4(config-if)#no shutdown
      
      R4(config)#interface f0/1
      R4(config-if)#ip address dhcp
      R4(config-if)#no shutdown

    2. Định tuyến RIPv2
    • Trên R1
      Code:
      R1(config)#route rip
      R1(config-router)#version 2
      R1(config-router)#network 1.1.1.1
      R1(config-router)#network 1.1.1.0
      R1(config-router)#network 1.2.2.0
      R1(config-router)#network 1.3.3.0
      R1(config-router)#network 1.4.4.0
      R1(config-router)#network 192.168.1.0
      R1(config-router)#network 192.168.12.0
      R1(config-router)#no auto-summary
      
      R1(config-router)#passive-interface loopback 0
      R1(config-router)#passive-interface loopback 1
      R1(config-router)#passive-interface loopback 2
      R1(config-router)#passive-interface loopback 3
      R1(config-router)#passive-interface f0/1
    • Trên R2
      Code:
      R2(config)#router rip
      R2(config-router)#version 2
      R2(config-router)#network 2.1.1.0
      R2(config-router)#network 2.2.2.0
      R2(config-router)#network 2.3.3.0
      R2(config-router)#network 2.4.4.0
      R2(config-router)#network 192.168.2.0
      R2(config-router)#network 192.168.12.0
      R2(config-router)#network 192.168.23.0
      R2(config-router)#no auto-summary
      
      R2(config-router)#passive-interface loopback 0
      R2(config-router)#passive-interface loopback 1
      R2(config-router)#passive-interface loopback 2
      R2(config-router)#passive-interface loopback 3
      R2(config-router)#passive-interface f0/1
    • Trên R3
      Code:
      R3(config)#router rip
      R3(config-router)#version 2
      R3(config-router)#network 192.168.2.0
      R3(config-router)#network 192.168.23.0
      R3(config-router)#network 192.168.34.0
      R3(config-router)#no auto-summary
      
      R3(config-router)#passive-interface f0/1
      R3(config-router)#passive-interface loopback 0
      R3(config-router)#passive-interface loopback 2
      R3(config-router)#passive-interface loopback 1
      R3(config-router)#passive-interface loopback 3
    • Trên R4
    Code:
    R4(config)#router rip
    R4(config-router)#version 2
    R4(config-router)#network 4.1.1.1
    R4(config-router)#network 4.1.1.0
    R4(config-router)#network 4.2.2.0
    R4(config-router)#network 4.3.3.0
    R4(config-router)#network 4.4.4.0
    R4(config-router)#network 192.168.34.0
    R4(config-router)#default-information originate //default route để LAn ra net
    
    R4(config-router)#no auto-summary
    R4(config-router)#passive-interface loopback 0
    R4(config-router)#passive-interface loopback 1
    R4(config-router)#passive-interface loopback 2
    R4(config-router)#passive-interface loopback 3
    3. Cấu hình DHCP
    • Trên R1
      Code:
      R1(config)#ip dhcp pool LAN2
      R1(dhcp-config)#network 192.168.2.0 255.255.255.0
      R1(dhcp-config)#default-router 192.168.2.254
      R1(dhcp-config)#dns-server 8.8.8.8
      R1(dhcp-config)#exit
      R1(config)#ip dhcp excluded-address 192.168.2.1 192.168.2.10
    • Trên R2
      Code:
      R2(config)#ip dhcp pool LAN1
      R2(dhcp-config)#network 192.168.1.0 255.255.255.0
      R2(dhcp-config)#default-router 192.168.1.254
      R2(dhcp-config)#dns-server 8.8.8.8
      R2(dhcp-config)#exit
      R2(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10
    • Trên R3
    Code:
    R3(config)#ip dhcp pool LAN3
    R3(dhcp-config)#network 192.168.3.0 255.255.255.0
    R3(dhcp-config)#default-router 192.168.3.254
    R3(dhcp-config)#dns-server 8.8.8.8
    R3(dhcp-config)#exit
    R3(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10

    4. Cho phép LAN xin DHCP từ DHCP Agent Relay
    • Trên R1
      Code:
      R1(config)#interface f0/1
      R1(config-if)#ip helper-address 192.168.12.2
    • Trên R2
    Code:
    R2(config)#interface f0/1
    R2(config-if)#ip helper-address 192.168.12.1
    III. Kiểm tra
    1. kiểm tra bảng định tuyến các Router

    • Trên R1

    config RIPv2 and DHCP relay agent (2)
    • Trên R2
    config RIPv2 and DHCP relay agent (3)
    • Trên R3
    config RIPv2 and DHCP relay agent (4)
    • Trên R4
    config RIPv2 and DHCP relay agent (5)


    2. Kiểm tra xem các PC đã xin DHCP và xem ra net được chưa

    • Trên Pc0

    config RIPv2 and DHCP relay agent (6)
    • Trên Pc2
    config RIPv2 and DHCP relay agent (7)
    • Trên PC4
    config RIPv2 and DHCP relay agent (8)

    - Các viết Lab tham khảo thêm
    1. [Lab 5.3] Config DHCP relay agent and static routes
    2. [Lab 6] Cấu hình định tuyến RIPv2 cho Router Cisco
    3. [Lab 7] Cấu hình định tuyến OSPF cho Router Cisco
    4. [Lab 8] cấu hình giao thức định tuyến EIGRP
    - Các bài lý thuyết tham khảo:
    1. [Bài 11] Tìm hiểu các giao thức định truyến mạng
    2. [Bài 13] Tìm hiểu về giao thức định tuyến RIP
    3. [Bài 14] Tìm hiểu giao thức định tuyến OSPF
    4. [Bài 15] Tìm hiểu giao thức định tuyến EIGRP
    5. [Bài 16] Tìm hiểu và cấu hình DHCP trên Cisco
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Jul 28, 2016
  2. khoa.ntk01

    khoa.ntk01 New Member

    Joined:
    Jan 4, 2015
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    mất ảnh rồi, root ơi
     
  3. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38
    hi bạn,

    Đã upload lại hình ảnh cho bài lab này rồi nhé!

    Thanks bạn,
     

Share This Page