CCNA [Lab 5] Cấu hình Static Route trên Cisco

Discussion in 'Lab' started by root, Dec 18, 2013.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,132
    Likes Received:
    59
    Trophy Points:
    48

    Định tuyến tĩnh - Static Route


    Ở phần lý thuyết tìm hiểu cấu hình định tuyến tĩnh Static Router
    Static Routing là phương thức định tuyến tĩnh do người quản trị nhập thông tin về đường đi cho Router. Vì vậy, khi cấu trúc định tuyến của hệ thống thay đổi thì người quản trị cũng phải cập nhập bằng tay các đường đi mới (xóa, thêm mới...) cho Router.
    Đây là bài lab về cấu hình Static router để các bạn có thể hiểu rõ hơn về Static router trên Rotuer Cisco
    .

    I. Mô hình lab Static Route

    - Mô hình bài lab cấu hinh Static route trên Cisco

    cau hinh static route tren Cisco(1)

    II. cấu hình Router Cisco

    1. Đấu nối thiết bị theo sơ đồ trên

    • Router A nối với Router B bằng cáp chéo
    • Router A nối với Router C bằng cáp Serial.
      • Đầu Router A là đầu DTE
      • Đầu Router C là đầu DCE
    2. cấu hình cơ bản cho Router A
    - Đặt Hostname và IP cho cổng Fast Ethernet F0/0 trên Router A

    Code:
    Router(config)#hostname Router-A
    Router-A(config)#interface f0/0
    Router-A(config-if)#ip address 192.168.1.1 255.255.255.0
    Router-A(config-if)#no shutdown
    - Để xem cổng S0/3/0 của Router A sử dụng DTE hay DCE ta dùng lệnh
    Code:
    Router-A(config)#show controllers s0/3/0
    cau hinh static route tren Cisco(2)

    - Đặt IP cho cổng serial S0/3/0. Ở trên ta thấy Serial s0/3/0 là DTE nên không cần cấu hình thêm clock rate
    Code:
    Router-A(config)#interface s0/3/0
    Router-A(config-if)#ip address 192.168.2.1 255.255.255.0
    Router-A(config-if)#no shutdown
    3. Cấu hình cơ bản cho Router B
    - Đặt Hostname và IP cho Router B

    Code:
    Router(config)#hostname Router-B
    Router-B(config)#interface f0/0
    Router-B(config-if)#ip address 192.168.1.2 255.255.255.0
    Router-B(config-if)#no shutdown
    4. Cấu hình cơ bản cho Router C
    • Để xem cổng S0/3/0 của Router A sử dụng DTE hay DCE ta dùng lệnh
    Code:
    Router-C(config)#show controllers s0/3/0
    cau hinh static route tren Cisco(3)

    - Đặt Hostname và IP cho Router C. Vì cổng s0/3/0 là DCE nên ta cấu hình thêm clock rate cho Router C
    Code:
    Router-C(config)#interface s0/3/0
    Router-C(config-if)#ip address 192.168.2.2 255.255.255.0
    Router-C(config-if)#clock rate 64000
    Router-C(config-if)#no shutdown

    III. Cấu hình Static route trên Cisco

    1. Cấu hình Static route trên Router B

    -
    ping đến Router C để kiểm tra kết nối. Vì trên Router B chưa có bảng định tuyến của lớp mạng 192.168.2.0/24 nên Router B sẽ không ping được Router C và cổng S0/3/0 của Router A.


    cau hinh static route tren Cisco(4)

    - Cấu hình static Router cho Router B để kết nối được với lớp mạng 192.168.2.0/24
    Code:
    Router-B(config)#ip route 192.168.2.0 255.255.255.0 s0/3/0
    - Kiểm tra bảng định tuyến của Router B xem có lớp mạng ta mới cấu hình route chưa
    Code:
    Router-B#show ip route

    cau hinh static route tren Cisco(5)

    • Lúc này chúng ta đã ping thành công cổng S0/3/0(192.168.2.1/24) trên Router A. Nhưng vẫn chưa ping được Router C mặc dù chúng ta đã cấu hình static Route cho Router B vì
      • khi gói tin đi từ B --> C là (source IP : B , Des IP : C) theo bảng định tuyến trên Router B nó sẽ chuyển gói tin ra cổng f0/0 --> Router A --> Router C.
      • Khi Router C nhận được gói tin nó sẽ gửi trả lại cho Router B gói tin có Source IP: C(192.168.2.2) , Des IP: B(192.168.1.2)
      • Nhưng lúc này bảng định tuyến của Router C chưa có định tuyến cho lớp mạng của Router B là 192.168.1.2/24. Nên nó sẽ không trả lời được cho Router B.
      • Lúc này nếu có PC kết nối Router B ping Router C sẽ nhận được thông điệp ping trả lời : Destination host unreachable.

    cau hinh static route tren Cisco(6)

    - Để Router B ping được Router C ta cần cấu hình Static Route cho Route C nữa.

    2. Cấu hình Static Router trên Router C

    -
    Cấu hình Static Route cho lớp mạng 192.168.1.0/24

    Code:
    Router-C(config)#ip route 192.168.1.0 255.255.255.0 s0/3/0
    - Kiểm tra bảng định tuyến

    cau hinh static route tren Cisco(7)

    - Dùng Router C ping Router B và thành công

    cau hinh static route tren Cisco(8)

    - Các viết Lab tham khảo thêm
    1. [Lab 5.2] Configure floating static route redundancy
    2. [Lab 5.3] Config DHCP relay agent and static routes
    3. [Lab 6] Cấu hình định tuyến RIPv2 cho Router Cisco
    4. [Lab 7] Cấu hình định tuyến OSPF cho Router Cisco
    5. [Lab 8] cấu hình giao thức định tuyến EIGRP
    - Các bài lý thuyết tham khảo:
    1. [Bài 11] Tìm hiểu các giao thức định truyến mạng
    2. [Bài 13] Tìm hiểu về giao thức định tuyến RIP
    3. [Bài 14] Tìm hiểu giao thức định tuyến OSPF
    4. [Bài 15] Tìm hiểu giao thức định tuyến EIGRP
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Jul 28, 2016
  2. hardware245

    hardware245 New Member

    Joined:
    Jul 18, 2014
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Admin update lai ảnh bài này giúp nhé. ;)
     
  3. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,132
    Likes Received:
    59
    Trophy Points:
    48
    hi hardware245,
    done
     

Share This Page