CCNA [Lab 5.3] Config DHCP relay agent and static routes

Discussion in 'Lab' started by root, Jan 1, 2014.

  1. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38

    DHCP relay agent and static routes


    Hướng dẫn cấu hình DHCP relay agent kết hợp với đinh tuyến tĩnh - Static Route.
    Ở các bài lab trước chúng ta đã cấu hình được một DHCP để cấp IP cho các CP trong mạng LAN và cấu hình Static Router để định tuyến đường đi cho hệ thống mạng LAN.
    Bài lab này chúng ta sẽ kết hợp cả cấu hình DHCP relay agent và cấu hình Static Router trên hệ thống Router Cisco để các PC trong LAN có thể nhận IP từ DHCP server và đi được ra ngoài internet thông qua cấu hình giao thức định tuyến tĩnh trên các Router.

    I. Sơ đồ lab DHCP relay agent and static routes

    1. Mô tả lab:

    • Cấu hình R3 làm DHCP cấp IP động cho mạng LAN 192.168.1.0/24
    • Sử dụng router protocol : Static Route để định tuyến cho mạng thông với nhau
    • Cấu hình hệ thống mạng ra net thông qua Router R3 kết nối với DHCP của ISP. ISP sẽ cấp IP public cho interface f0/1 cho Router R3

    DHCP relay agent and static routes (1)

    II. Triển khai lab DHCP relay agent and static routes

    1. Cấu hình cơ bản

    • Đấu nối thiết bị theo sơ đồ : router nối với nhau bằng cáp chéo. Router, máy tính nối với switch bằng cáp thẳng.
    • Đặt Hostname theo sơ đồ
    • Cấu hình không trôi dòng lệnh, đặt password enable, console, telnet...và mã hóa
    Code:
    R1(config)#line console 0
    R1(config-line)#logging synchronous
    
    R1(config)#line vty 0 4
    R1(config-line)#privilege level 15
    R1(config-line)#no login     // telnet không passworld
    • Đặt Ip theo sơ đồ
    + Trên R1 :
    Code:
    R1(config)#interface f0/0
    R1(config-if)#ip address 192.168.12.1 255.255.255.0
    R1(config-if)#no shutdown
    
    R1(config)#interface f0/1
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    R1(config-if)#no shutdown
    + Trên R2 :
    Code:
    R2(config)#interface f0/0
    R2(config-if)#ip address 192.168.12.2 255.255.255.0
    R2(config-if)#no shutdown
    
    R2(config)#interface s1/0
    R2(config-if)#ip address 192.168.34.1 255.255.255.252
    R2(config-if)#no shutdown
    + Trên R3 :
    Code:
    R3(config)#interface s1/0
    R3(config-if)#ip address 192.168.34.2 255.255.255.252
    R3(config-if)#no shutdown
    
    R3(config)#interface f0/1
    R3(config-if)#ip address dhcp
    R3(config-if)#no shutdown
    + Trên R4 : R4 dùng làm ISP như DHCP của ISP sẽ cấp IP động xuống cho Interface f0/1 cho R3.
    R4 được nối với cloud(cloud nối với card LAN máy tính được đấu với model ADSL ra net)

    Code:
    R4(config)#interface f0/0
    R4(config-if)#ip address 123.123.123.123 255.255.255.0
    R4(config-if)#no shutdown
    
    R4(config)#interface f0/1
    R4(config-if)#ip address dhcp
    R4(config-if)#no shutdown
    2. Cấu hình R4 thành ISP kết nối internet và cấp IP publish cho Router R3

    Interface f0/0 R4 đấu với cloud xin DHCP từ model ADSL. Nên R4 ra được internet, đứng trên R4 ta ping kiểm tra

    DHCP relay agent and static routes (2)

    - Cấu hình Nat IP public <---> IP Private
    Code:
    R4(config)#access-list 1 permit any
    R4(config)#ip nat inside source list 1 interface f0/1 overload
    
    R4(config)#interface f0/0
    R4(config-if)#ip nat outside
    
    R4(config-if)#interface f0/1
    R4(config-if)#ip nat inside
    - Cấu hình R4 làm DHCP cấp IP publish động cho R3
    Code:
    R4(config)#ip dhcp pool ISP
    R4(dhcp-config)#network 123.123.123.0 255.255.255.0
    R4(dhcp-config)#default-router 123.123.123.254
    R4(dhcp-config)#dns-server 8.8.8.8 8.8.4.4
    R4(dhcp-config)#lease 1 10 30   //day hours minutes
    3. Trên R3 cấu hình LAN ra internet
    Kiểm tra xem R3 đã được cấp DHCP chưa và ra được internet chưa

    DHCP relay agent and static routes (3)

    • Cấu hình NAT để cho mạng bên trong ra được internet
    Code:
    R3(config)#access-list 1 permit any
    R3(config)#ip nat inside source list 1 interface f0/1 overload
    
    R3(config)#interface f0/0
    R3(config-if)#ip nat outside
    
    R3(config-if)#interface f0/1
    R3(config-if)#ip nat inside
    • Định tuyến cho R3
    Code:
    R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.34.1
    R3(config)#ip route 192.168.12.0 255.255.255.0 192.168.34.1
    Mặc định khi xin IP từ ISP nó sẽ cấp default route S* cho Router

    DHCP relay agent and static routes (4)

    • Cấu hình R3 làm DHCP relay agent cấp DHCP cho mạng 192.168.1.1
    Code:
    R3(config)#ip dhcp pool LAN1
    R3(dhcp-config)#network 192.168.1.0 255.255.255.0
    R3(dhcp-config)#default-router 192.168.1.254
    R3(dhcp-config)#dns-server 8.8.8.8 8.8.4.4
    R3(dhcp-config)#lease 1 0 2
    R3(dhcp-config)#exit
    R3(config)#ip dhcp excluded-address 192.168.1.100 192.168.1.200
    • Cấu hình R3 cấp IP tĩnh cho PC có địa chỉ MAC = 00-50-56-3D-7A-3C --> 0100.5056.3D7A.3C
    Code:
    R3(config)#ip dhcp pool VLAN1
    R3(dhcp-config)#host 192.168.1.100 255.255.255.0
    R3(dhcp-config)#client-identifier 0100.5056.3D7A.3C
    R3(config)#ip dhcp excluded-address 192.168.1.100 192.168.1.200
    4. Đinh tuyến trên R2
    • thực hiện định tuyến trên R3
    Code:
    R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.12.1
    R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.34.2
    5. Định tuyến và cho phép xin DHCP từ DHCP relay agent trên R1
    • Định tuyến trên R1
    Code:
    R1(config)#ip route 192.168.34.0 255.255.255.252 192.168.12.2
    R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.12.2
    • Để client trong LAN f0/1 có thể xin DHCP thì ta cần chuyển gói tin xin DHCP của client từ broadcast --> unicast. Vì gói tin broadcast thì bị router chặn
    Code:
    R1(config)#interface f0/1
    R1(config-if)#ip helper-address 192.168.34.2
    III. Kiểm tra kết quả
    1. Trên pc 1

    • trên pc 1 ta kiểm tra xem nó đã xin DHCP chưa
    DHCP relay agent and static routes (5)

    • ping google xem pc 1 ra được net chưa

    DHCP relay agent and static routes (6)


    2. Trên pc
    PC 2 có MAC = 0100.5056.3D7A.3C nên được cấp Ip tĩnh 192.168.1.100/24

    DHCP relay agent and static routes (7)


    - Các viết Lab tham khảo thêm
    1. [Lab 5] Cấu hình Static Route trên Cisco
    2. [Lab 5.2] Configure floating static route redundancy
    3. [Lab 6] Cấu hình định tuyến RIPv2 cho Router Cisco
    4. [Lab 7] Cấu hình định tuyến OSPF cho Router Cisco
    5. [Lab 8] cấu hình giao thức định tuyến EIGRP
    - Các bài lý thuyết tham khảo:
    1. [Bài 11] Tìm hiểu các giao thức định truyến mạng
    2. [Bài 13] Tìm hiểu về giao thức định tuyến RIP
    3. [Bài 14] Tìm hiểu giao thức định tuyến OSPF
    4. [Bài 15] Tìm hiểu giao thức định tuyến EIGRP
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Jul 28, 2016
  2. khoa.ntk01

    khoa.ntk01 New Member

    Joined:
    Jan 4, 2015
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    bài hay, nhưng mất ảnh rồi root ơi, up lại ảnh nha root:rolleyes:
     
  3. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38
    hi bạn,

    Đã upload lại hình cho bài lab. Chúc bạn làm lab vui vẻ
    Thanks,
     

Share This Page