CCNA [Lab 5.2] Configure floating static route redundancy

Discussion in 'Lab' started by root, Dec 23, 2013.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    51
    Trophy Points:
    48

    Configure floating static route redundancy


    Floating static route thường được dùng trong các giải pháp dial-backup. Khi đường primary route bị mất khỏi routing table (bảng định tuyến của Router) thì floating static route (đường static route được cấu hình dự phòng với chỉ số AD lớn hơn chỉ số AD của primary static route) sẽ được đưa vào bảng routing table của Router.

    Thông thường bạn sẽ sử dụng giải pháp này khi công ty bạn có 2 đường truyền (1 đường FTTH tốc độ cao và 1 đường dial với tốc độ chậm). Các bạn sẽ cấu hình primary static route để hệ thống đi qua đường FTTH là đường chính. Còn đường dial làm đường Floating static route (là đường dự phòng cho đường primary static route).

    I. Mô hình lab Configure floating static route redundancy


    - Mô hình lab cấu hình floating static route redundancy

    configure floating static route redundancy(1)

    II. Chuẩn bị :
    - Cáp đấu nối theo sơ đồ
    - Đặt IP và tên cho các thiết bị
    - Trên R1

    Code:
    R1(config)#interface f0/0
    R1(config-if)#ip address 192.168.13.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    
    R1(config)#interface f0/1
    R1(config-if)#ip address 192.168.1.254 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    
    R1(config)#interface s0/0/0
    R1(config-if)#ip address 192.168.12.1 255.255.255.252
    R1(config-if)#no shutdown

    - Trên R2

    Code:
    R2(config)#interface s0/0/0
    R2(config-if)#ip address 192.168.12.2 255.255.255.252
    R2(config-if)#no shutdown
    R2(config-if)#exit
    R2(config)#interface f0/0
    R2(config-if)#ip address 192.168.24.1 255.255.255.0
    R2(config-if)#no shutdown
    R2(config-if)#exit
    - Trên R3
    Code:
    R3(config)#interface f0/0
    R3(config-if)#ip address 192.168.13.2 255.255.255.0
    R3(config-if)#no shutdown
    R3(config)#interface s0/0/0
    R3(config-if)#ip address 192.168.34.1 255.255.255.252
    R3(config-if)#no shutdown
    - Trên R4
    Code:
    R4(config)#interface f0/0
    R4(config-if)#ip address 192.168.24.2 255.255.255.0
    R4(config-if)#no shutdown
    R4(config-if)#exit
    
    R4(config)#interface f0/1
    R4(config-if)#ip address 192.168.4.254 255.255.255.0
    R4(config-if)#no shutdown
    R4(config-if)#exit
    
    R4(config)#interface s0/0/0
    R4(config-if)#ip address 192.168.34.2 255.255.255.252
    R4(config-if)#no shutdown

    - Trên Pc A

    - Trên Pc B

    - Sau khi triển khai xong ta có thể thấy các thiết bị có định tuyến connected đã thông với nhau.

    configure floating static route redundancy(2)


    III. Cấu hình floating static route cho các Router


    - Trên R1

    Code:
    R1(config)#ip route 192.168.24.0 255.255.255.0 192.168.12.2
    R1(config)#ip route 192.168.34.0 255.255.255.0 192.168.13.2
    R1(config)#ip route 192.168.4.0 255.255.255.0 192.168.12.2
    R1(config)#ip route 192.168.4.0 255.255.255.0 192.168.13.2 254

    - Trên Router R2
    Code:
    R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.12.1
    R2(config)#ip route 192.168.13.0 255.255.255.0 192.168.12.1
    R2(config)#ip route 192.168.4.0 255.255.255.0 192.168.22.2
    R2(config)#ip route 192.168.34.0 255.255.255.252 192.168.22.2
    - Trên Router R3
    Code:
    R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.13.1
    R3(config)#ip route 192.168.12.0 255.255.255.252 192.168.13.1
    R3(config)#ip route 192.168.4.0 255.255.255.0 192.168.34.2
    R3(config)#ip route 192.168.24.0 255.255.255.0 192.168.34.2
    - Trên Router R4
    Code:
    R4(config)#ip route 192.168.12.0 255.255.255.252 192.168.24.1
    R4(config)#ip route 192.168.13.0 255.255.255.0 192.168.34.1
    R4(config)#ip route 192.168.1.0 255.255.255.0 192.168.24.1
    R4(config)#ip route 192.168.1.0 255.255.255.0 192.168.34.1 254

    IV. Kiểm tra kết quả
    - Pc A ping Pc B thành công và ngược lại. Packet sẽ đi từ pcA -> R1 -> R2 -> R4 -> pcB là đường chính. Vì chúng ta đã định tuyến cho đường nào có chỉ số AD = 1. Để kiểm tra ta dùng Tracert để xem packet đi đúng đường không

    - Bảng định tuyến của R1


    configure floating static route redundancy(3)


    - Pc A ping pc B

    configure floating static route redundancy(4)

    - Khi Router 2 chết thì Pc A ping pc B theo đường dự phòng là pcA -> R1 -> R3 -> R4 -> pcB. Lúc này bảng định tuyến của R1 sẽ mất dòng định tuyến :

    192.168.4.0 [1/0]via 192.168.12.2 //sẽ mất đi vì R2 chết thay bằng dòng
    192.168.4.0 [254/0] via 192.168.13.2 // đường dự phòng được bật lên

    configure floating static route redundancy(5)


    - PC A ping pc B thành công. Từ pc A ta tracert xem packet có đi theo đường đi phòng như chúng ta đã định tuyến không.

    configure floating static route redundancy(6)
    - Các viết Lab tham khảo thêm
    1. [Lab 5] Cấu hình Static Route trên Cisco
    2. [Lab 5.3] Config DHCP relay agent and static routes
    3. [Lab 6] Cấu hình định tuyến RIPv2 cho Router Cisco
    4. [Lab 7] Cấu hình định tuyến OSPF cho Router Cisco
    5. [Lab 8] cấu hình giao thức định tuyến EIGRP
    - Các bài lý thuyết tham khảo:
    1. [Bài 11] Tìm hiểu các giao thức định truyến mạng
    2. [Bài 13] Tìm hiểu về giao thức định tuyến RIP
    3. [Bài 14] Tìm hiểu giao thức định tuyến OSPF
    4. [Bài 15] Tìm hiểu giao thức định tuyến EIGRP
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Jul 28, 2016
  2. hardware245

    hardware245 New Member

    Joined:
    Jul 18, 2014
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Admin up lại ảnh giúp bài lab này nhé. :)
     
  3. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    51
    Trophy Points:
    48
    xong nhé :)
     
  4. phanphong

    phanphong Super Moderator

    Joined:
    Jun 24, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Cung de nay nhung cau hoi khac.
    khi trace route tu pcA den pcB thay route di qua R1>R2>R4 va di ve R4>R3>R1
    dung static vua du khong dc du.
     

Share This Page