CCNA Lab 5.1 Cấu hình PBR với IP SLA và route-map

Discussion in 'Lab' started by nessiggk, Jul 20, 2018.

  1. nessiggk

    nessiggk New Member

    Joined:
    Feb 25, 2018
    Messages:
    29
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 5.1 Cấu hình PBR với IP SLA và route-map




    Ở bài này, tiếp tục sử dụng route-map trong Policy Based Routing để cấu hình trong các trường hợp định tuyến thông thường không thể làm được những chỉ thị khác với đích đến của gói tin. Và kèm theo đó sử dụng Track cho route-map.


    I. Sơ đồ và yêu cầu của bài lab


    1. Sơ đồ của bài lab


    • Sơ đồ của bài lab Sử dụng PBR và route-map để cấu hình
    Cau hinh pbr p2 (1)

    2. Yêu cầu của bài lab


    • Cấu hình cơ bản như sơ đồ

    • Cấu hình default route cho R1, R2, R3

    • Cấu hình NAT trên R2 và R3, R2 và R3 được static route về R1

    • Các PC ping thấy nhau

    • PC1 PC3 đi ra Internet qua đường R2 -> ISP-Viettel và PC2 PC4 đi ra Internet bằng đường R3 -> ISP-VNPT

    • Khi R2 ISP-Viettel đứt PC1 PC3 đi Internet bằng đường R3 -> ISP-VNPT, khi phục hồi, sẽ đi như cũ

    • Khi R3 ISP-VNPT đứt PC2 PC4 đi Internet bằng đường R2 -> ISP-Viettel, khi phục hồi, sẽ đi như cũ

    II. Triển khai bài Lab


    1. Cấu hình cơ bản


    • Ethernetswitch-1 (thay cho switch)
    Cau hinh pbr p2 (2)

    • Router R1
    Code:
    R1(config)#int f0/1
    
    R1(config-if)#no shutdown
    
    R1(config-if)#int f0/1.1
    
    R1(config-subif)#encapsulation dot1q 10
    
    R1(config-subif)#ip address 10.123.10.250 255.255.255.0
    
    R1(config-subif)#exit
    
    R1(config)#int f0/1
    
    R1(config-if)#int f0/1.2
    
    R1(config-subif)#encapsulation dot1q 20
    
    R1(config-subif)#ip address 10.123.20.250 255.255.255.0
    
    R1(config-subif)#exit
    
    R1(config)#int f0/0
    
    R1(config-if)#ip address 172.16.16.1 255.255.255.252
    
    R1(config-if)#no shutdown
    
    R1(config)#exit
    
    R1(config)#int f1/0
    
    R1(config-if)#ip address 172.16.17.1 255.255.255.252
    
    R1(config-if)#no shutdown
    • R2
    Code:
    R2(config)#int f0/0
    
    R2(config-if)#mac-address 9453.3025.0357
    
    R2(config-if)#ip address 192.168.43.147 255.255.255.0
    
    R2(config-if)#no shutdown
    
    R2(config)#exit
    
    R2(config)#int f1/0
    
    R2(config-if)#ip address 172.16.16.2 255.255.255.252
    
    R2(config-if)#no shutdown
    • R3
    Code:
    R3(config)#int f0/0
    
    R3(config-if)#ip address 192.168.10.123 255.255.255.0
    
    R3(config-if)#no shutdown
    
    R3(config-if)#exit
    
    R3(config)#int f1/0
    
    R3(config-if)#ip addres 172.16.17.2 255.255.255.252
    
    R3(config-if)#no shutdown
    
    R3(config-if)#exit
    • PC1
    Code:
    PC-1> ip 10.123.10.11/24 10.123.10.250
    
    Checking for duplicate address...
    
    PC1 : 10.123.10.1 255.255.255.0 gateway 10.123.10.250
    • PC2
    Code:
    PC-2> ip 10.123.10.12/24 10.123.20.250
    
    Checking for duplicate address...
    
    PC1 : 10.123.20.1 255.255.255.0 gateway 10.123.20.250
    • PC3
    Code:
    PC-3> ip 10.123.20.13/24 10.123.20.250
    
    Checking for duplicate address...
    
    PC1 : 10.123.20.13 255.255.255.0 gateway 10.123.20.250
    • PC4
    Code:
    PC-4> ip 10.123.20.14/24 10.123.20.250
    
    Checking for duplicate address...
    
    PC1 : 10.123.20.14 255.255.255.0 gateway 10.123.20.250
    • Cấu hình route R1, R2 ,R3
    Code:
    R1(config)#ip route 0.0.0.0 0.0.0.0 172.16.16.2 250
    
    R1(config)#ip route 0.0.0.0 0.0.0.0 172.16.17.2 254
    
    R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.43.1 254
    
    R2(config)#ip route 10.123.10.0 255.255.255.0 172.16.16.1
    
    R2(config)#ip route 10.123.20.0 255.255.255.0 172.16.16.1
    
    R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.2 254
    
    R3(config)#ip route 10.123.10.0 255.255.255.0 172.16.17.1
    
    R3(config)#ip route 10.123.20.0 255.255.255.0 172.16.17.1

    2. Cấu hình NAT trên R2 và R3


    • Router R2
    Code:
    R2(config)#int f0/0
    
    R2(config-if)#ip nat outside
    
    R2(config-if)#exit
    
    R2(config)#int f0/1
    
    R2(config-if)#ip nat inside
    
    R2(config-if)#exit
    
    R2(config)#access-list 1 permit any
    
    R2(config)#ip nat inside source list 1 interface f0/0 overload
    • Router R3
    Code:
    R3(config)#int f0/0
    
    R3(config-if)#ip nat outside
    
    R3(config-if)#exit
    
    R3(config)#int f0/1
    
    R3(config-if)#ip nat inside
    
    R3(config-if)#exit
    
    R3(config)#access-list 1 permit any
    
    R3(config)#ip nat inside source list 1 interface f0/0 overload

    3. Cấu hình Policy Based Routing


    • Cấu hình PBR để PC2 PC4 đi Internet theo ISP-VNPT
    Code:
    R1(config)#access-list 24 permit host 10.123.10.12
    
    R1(config)#access-list 24 permit host 10.123.20.14
    
    R1(config)#route-map R1R3 permit 10
    
    R1(config-route-map)#match ip address 24
    
    R1(config-route-map)#set ip default next-hop 172.16.17.2
    
    R1(config-route-map)#exit
    
    R1(config)#int f0/1.1
    
    R1(config-subif)#ip policy route-map R1R3
    
    R1(config-subif)#exit
    
    R1(config)#int f0/1.2
    
    R1(config-subif)#ip policy route-map R1R3
    • Trường hợp khi R1 -> R2 hoặc R1 -> R3 bị đứt, các cổng kết nối sẽ down protocol cho đến khi mở lại

    • Do đó khi R1 R2 chưa đứt PC1 PC3 sẽ đi theo default route còn PC2 PC4 sẽ đi theo route-map, còn khi bị đứt ở R1 R2 thì dĩ nhiên sẽ đi theo default route dự phòng mà ta đã cấu hình

    • Còn trường hợp R1 R3 bị đứt thì theo cấu hình đường đi route-map đến next-hop không xác định được thì sẽ đi theo đường định tuyến cơ bản

    • Giờ chúng ta sẽ thử xem PC1 PC3 và PC2 PC4 đã đi đúng đường chỉ định chưa
    PC1 PC3

    Cau hinh pbr p2 (3)

    PC2 PC4

    Cau hinh pbr p2 (4)


    4. Sử dụng Tracking cho route-map


    • Trong bài lab này, khi đường R2 -> ISP-Viettel hoặc R3 -> ISP-VNPT bị đứt thì chúng ta phải sử dụng phương pháp IP SLA hay là Tracking

    • Đương nhiên việc tracking sẽ được gắn vào route-map, để cấu hình được track cho route-map thì chúng ta cần no lệnh set ip defualt next-hop cũ đi và thay vào đó là
    Code:
    R1(config-route-map)#set ip next-hop verify-availability 172.16.17.2 1 track 10
    • Câu lệnh cũng khá tương tự với “set ip default next-hop” như bài trước mình đã giải thích, tuy nhiên câu lệnh này thêm điều kiện xác minh khả năng có cho gói tin đi theo next-hop đã cấu hình hay không khi Track -> Up thì đi theo như cấu hình còn Track -> Down sẽ đi theo mặc định

    • Cấu hình IP SLA
    Code:
    R1(config)#ip sla 1
    
    R1(config-ip-sla)#icmp-echo 192.168.10.2 source-interface f1/0
    
    R1(config-ip-sla-echo)#frequency 5
    
    R1(config-ip-sla-echo)#exit
    
    R1(config)#ip sla schedule 1 start-time now life forever
    
    R1(config)#track 10 rtr 1
    • Tuy nhiên trong trường hợp R3 -> ISP-VNPT bị đứt ta cần thêm một static route để định hướng đi từ R1 check đến R3
    Code:
    R1(config)#ip route 192.168.10.0 255.255.255.0 172.16.17.2
    • Giờ ta thử down đường R3 -> ISP-VNPT, check trên PC2
    *Mar 1 00:39:15.399: %TRACKING-5-STATE: 10 rtr 1 state Up->Down

    Cau hinh pbr p2 (5)

    • Trường hợp R2 -> ISP-Viettel đứt thì chỉ cần gắn Track vào default route đến R2 là được (bởi trong mạng Vmnet1 của mình thì được nối với mạng Wifi nên có thể đi tới được nó và thực hiện Track-Up và từ đó gói tin luôn đi theo đường R2 ->> Không thể ra mạng theo ISP-Viettel)


    Vậy là bài lab đã hoàn thành.
     
    Last edited: Jul 20, 2018
    petpkcui likes this.
  2. petpkcui

    petpkcui New Member

    Joined:
    Oct 1, 2016
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    Bài viết rất chi tiết và hữu ích. Tks tác giả.
    Tuy nhiên, thông thường 2 cổng của R1 sẽ nối đến 2 ISP luôn chứ không qua R2 với R3. Vậy trong trường hợp này có cách nào để cấu hình vẫn đạt được theo yêu cầu của bài lab không vậy?
     

Share This Page