CCNA Lab 4.1 Cấu hình NAT trên router Cisco phần 2

Discussion in 'Lab' started by nessiggk, Jul 14, 2018 at 12:17 PM.

  1. nessiggk

    nessiggk New Member

    Joined:
    Feb 25, 2018
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 4.1 Cấu hình NAT trên router Cisco phần 2





    Như bài lab 4.0 thì ta đã biết tác dụng của NAT và cấu hình NAT, bài này cũng tương tự nhưng là bài NAT mở rộng kèm trường hợp dự phòng


    I. Sơ đồ và yêu cầu của bài Lab

    1. Sơ đồ

    • Sơ đồ bài lab cấu hình NAT mở rộng
    Cau hinh nat p2


    2. Yêu cầu của bài lab


    • Cấu hình cơ bản như sơ đồ

    • PC1 ping được PC2

    • PC1 ra được Internet qua ISP-Viettel

    • Khi đường giữa Wifi 2 và Router R1 bị đứt thì đi theo đường R2 -> ISP-VNPT, R2 chỉ được cấu hình default route

    • PC2 không đi được Internet nhưng PC1 ping được PC2

    II. Triển khai cấu hình bài lab


    1. Cấu hình cơ bản

    • Ethernetswitch-1 (thay cho switch)
    Cau hinh nat p2 2

    • Router R1
    Code:
    R1(config)#int f0/1
    
    R1(config-if)#no shutdown
    
    R1(config-if)#int f0/1.1
    
    R1(config-subif)#encapsulation dot1q 10
    
    R1(config-subif)#ip address 10.123.10.250 255.255.255.0
    
    R1(config-subif)#exit
    
    R1(config)#int f0/1
    
    R1(config-if)#int f0/1.2
    
    R1(config-subif)#encapsulation dot1q 20
    
    R1(config-subif)#ip address 10.123.20.250 255.255.255.0
    
    R1(config-subif)#exit
    
    R1(config)#int f0/0
    
    R1(config-if)#mac-address 9453.3025.0357
    
    R1(config-if)#ip address 192.168.43.147 255.255.255.0
    
    R1(config-if)#no shutdown
    
    R1(config)#exit
    
    R1(config)#int f1/0
    
    R1(config-if)#ip address 172.16.16.2 255.255.255.252
    
    R1(config-if)#no shutdown
    • Router R2
    Code:
    R2(config)#int f0/0
    
    R2(config-if)#ip address 192.168.10.123 255.255.255.0
    
    R2(config-if)#no shutdown
    
    R2(config-if)#exit
    
    R2(config)#int f1/0
    
    R2(config-if)#ip addres 172.16.16.1 255.255.255.252
    
    R2(config-if)#no shutdown
    
    R2(config-if)#exit
    
    R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.2 254 // Defualt route ra ISP-VNPT
    • PC1
    Code:
    PC-1> ip 10.123.10.1/24 10.123.10.250
    
    Checking for duplicate address...
    
    PC1 : 10.123.10.1 255.255.255.0 gateway 10.123.10.250
    • PC2
    Code:
    PC-2> ip 10.123.20.1/24 10.123.20.250
    
    Checking for duplicate address...
    
    PC1 : 10.123.20.1 255.255.255.0 gateway 10.123.20.250
    2. Cấu hình NAT trên R1


    • Ở bài trước mình đã xin cấp DHCP nên tự cập nhật cả default route nhưng bài này thì không do vậy phải cấu hình.

    • Default route R1
    Code:
    R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.43.1 250 // Đường chính qua ISP-Viettel
    
    R1(config)#ip route 0.0.0.0 0.0.0.0 172.16.16.1 254 // Đường phụ qua R2
    • Đầu tiên mình cần một địa chỉ IP được NAT overload ra ngoài là địa chỉ của interface f0/0 IP 192.168.43.221 để ip inside ra được internet với source IP là vậy.

    • Tuy nhiên khi ta cấu hình interface nat outside sẽ bị lỗi, do router không biết sẽ lấy địa chỉ source ip là của interface nào. Do đó khi cấu hình NAT ta cần thêm “oer”
    Code:
    ip nat inside source list n interface fastEthernet overload oer
    Code:
    R1(config)#access-list 1 permit 10.123.10.0 0.0.0.255 // Không cho dải địa chỉ mạng của PC2 qua
    
    R1(config)#access-list 2 permit 10.123.10.0 0.0.0.255
    
    R1(config)#ip nat inside source list 1 interface f0/0 overload oer
    
    R1(config)#ip nat inside source list 2 interface f1/0 overload oer
    
    R1(config)#int f0/0
    
    R1(config-if)#ip nat outside
    
    R1(config-if)#exit
    
    R1(config)#int f1/0
    
    R1(config-if)#ip nat outside
    
    R1(config-if)#exit
    
    R1(config)#int f0/1.1
    
    R1(config-subif)#ip nat inside
    
    R1(config-subif)#exit
    
    R1(config)#int f0/1.2
    
    R1(config-subif)#ip nat inside
    • Thử ping và trace PC1 đến 8.8.8.8 khi đường R1->ISP-Viettel chưa đứt => thành công và đã đi theo đường R1 -> ISP-Viettel
    Cau hinh nat p2 4

    • Sau khi đứt đường R1->ISP-Viettel
    Cau hinh nat p2 5

    • Và cuối cùng là PC1 -> PC2 nhưng PC2 không ra được Internet
    Cau hinh nat p2 6


    Vậy là mình đã cấu hình cho bài Lab thành công !!!
     
    Last edited: Jul 14, 2018 at 7:27 PM

Share This Page