CCNA Lab 4.0: Cấu hình NAT đơn giản trên Router Cisco

Discussion in 'Lab' started by nessiggk, Jul 11, 2018.

  1. nessiggk

    nessiggk New Member

    Joined:
    Feb 25, 2018
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 4.0: Cấu hình NAT trên Router Cisco




    Như chúng ta đã biết, thì nguyên tắc không thể nào mà địa chỉ IP private ra được môi trường Internet, không truy nhập được vào vùng địa chỉ IP public, do đó mà người ta cần phải sử dụng kĩ thuật NAT ( Network Address Translation).


    Trong bài lab này chúng ta sẽ cấu hình cho phép các thiết bị hệ thống mạng LAN có thể truy nhập được Internet. Cấu hình NAT overload trên Router Cisco và được thực hiện trên phần mềm giả lập GNS3.


    I. Sơ đồ và yêu cầu

    1. Sơ đồ của bài lab cấu hình NAT trên Router


    • Sơ đồ
    Lab nat (1)

    2. Yêu cầu của bài lab


    • Cấu hình NAT cho router R1 để PC1 kết nối được mạng bên ngoài

    • NAT overload, PAT

    II. Triển khai bài lab và cấu hình NAT trên Router


    Trong GNS3, để router ra được Internet bên ngoài thì cần trỏ đến card mạng vật lý hoặc card mạng ảo được sử dụng trên PC. Trong bài này mình sử dụng card Wifi, khuyên dùng Ethernet bởi sẽ để cấp địa chỉ ip cho router bằng DHCP hơn là Wifi. Hoặc còn một số cách làm nữa để mạng trong GNS3 đi ra được mạng thực tế mà mình không đề cập đến.


    1. Cấu hình cơ bản cho PC1, router R1

    • PC1
    Code:
    PC-1> ip 10.123.10.1/24 10.123.10.250
    
    Checking for duplicate address...
    
    PC1 : 10.123.10.1 255.255.255.0 gateway 10.123.10.250
    • Router R1
    Code:
    R1(config)#int f0/1
    
    R1(config-if)#ip address 10.123.10.250 255.255.255.0
    
    R1(config-if)#no shutdown
    
    R1(config-if)#int f0/0
    
    R1(config-if)#mac-address 9453.3025.0357 // mac-address của card Wifi
    
    R1(config-if)#ip address dhcp
    
    R1(config-if)#no shutdown
    
    FastEthernet0/0 assigned DHCP address 192.168.43.221, mask 255.255.255.0, hostname R1
    
    R1(config)#do show ip int b
    
    Interface               IP-Address        OK? Method  Status  Protocol
    
    FastEthernet0/0  192.168.43.221   YES DHCP    up        up
    
    FastEthernet0/1  10.123.10.250     YES manual   up        up
    • Để cấp được địa chỉ ip cho cổng f0/0 của router R1 thì cần sử dụng lệnh DHCP, trong bài lab này mình sử dụng đến card Wifi do đó tại sao chúng ta thay đổi MAC (giống card wifi) là tạo giao diện router R1 GNS3 giống như giao diện máy vật lý và cấp được DHCP.

    2. Cấu hình NAT trên R1


    • Cấu hình NAT
    Bước 1: Tạo ACL để permit dải IP Private được NAT ra ngoài Internet.
    Code:
    R1(config)#access-list 1 permit any
    Bước 2: Cấu hình NAT overload ra interface.(Địa chỉ IP được NAT overload ra ngoài là địa chỉ IP của Interface f0/0 IP 192.168.43.221)
    Code:
    R1(config)#ip nat inside source list 1 interface f0/0 overload
    Bước 3: Cấu hình NAT outside, inside cho Interfaces. (xác định chiều NAT inside, outside ra ngoài Internet).
    Code:
    R1(config)#interface f0/0
    
    R1(config-if)#ip nat outside
    
    R1(config-if)#interface f0/1
    
    R1(config-subif)#ip nat inside
    • Ping PC1 ra ngoài Internet => Thành công, lệnh trace không tới 8.8.8.8 do PC trong GNS3 chỉ hiển thị tối đa 8 hops.
    Lab nat (2)



    Vậy là mình đã hoàn thành bài Lab cấu hình NAT cho Router Cisco ,các bạn cần chú ý việc cấu hình NAT cho từng trường hợp cụ thể.
     

Share This Page