CCNA Lab 3.3: Cấu hình dự phòng Static route với IP SLA

Discussion in 'Lab' started by nessiggk, Jul 3, 2018.

  1. nessiggk

    nessiggk Member

    Joined:
    Feb 25, 2018
    Messages:
    31
    Likes Received:
    5
    Trophy Points:
    8
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 3.3: Cấu hình dự phòng Static route với IP SLA




    Khi việc cấu hình floating static route không còn đơn giản, mà phức tạp hơn thì việc chỉ cấu hình AD thôi sẽ không hiệu quả trong việc tìm giải pháp back-up đường đi. Bởi vậy hôm nay bài lab sẽ nâng cao hơn với việc cấu hình IP SLA.


    Ở bài lab này mình sẽ chuyển qua sử dụng phần mềm GNS3, bởi câu lệnh cấu hình IP SLA thì sẽ không có trên các IOS Router của Cisco Packet Tracer.


    I. Sơ đồ và yêu cầu của bài lab


    1. Sơ đồ
    • Sơ đồ của bài lab cấu hình dự phòng static route với IP SLA
    Cau hinh ip sla(1)


    2. Yêu cầu


    • Cấu hình như sơ đồ trên

    • Cấu hình default route trên Router HN – HCM – ISP Viettel

    • Đảm bảo PC1 ping thấy Server Google theo đường PC1 -> Router-DN -> HN -> ISP Viettel -> Server Google

    • Nếu đường Router-DN -> HN bị đứt thì đường đi sẽ là PC10 -> Router-HCM -> ISP Viettel -> Server Google

    • Khi đường Router HN với ISP Viettel đứt thì PC1 không ping được Server Google

    • Cấu hình IP SLA để khi HN với ISP đứt thì đường đi sẽ là PC1 -> Router-DN -> HCM -> ISP Viettel -> Server Google

    II. Triển khai cấu hình

    1. Cấu hình Sw và PC bên mạng DN

    • Cấu hình PC-1
    Code:
    PC-1> ip 172.16.10.1/24 172.16.10.250
    
    PC1 : 172.16.10.1 255.255.255.0 gateway 172.16.10.250
    • PC-2
    Code:
    PC-2> ip 172.16.20.1/24 172.16.20.250
    
    PC2 : 172.16.20.1 255.255.255.0 gateway 172.16.20.250
    • Cấu hình Sw
    Code:
    SW-DN(config)#vlan 10
    
    SW-DN(config-vlan)#name KINHDOANH
    
    SW-DN(config-vlan)#exit
    
    SW-DN(config)#vlan 20
    
    SW-DN(config-vlan)#name KETOAN
    
    SW-DN(config-if)#exit
    
    SW-DN(config)#int e0/1
    
    SW-DN(config-if)#sw access vlan 10
    
    SW-DN(config-if)#exit
    
    SW-DN(config)#int e0/2
    
    SW-DN(config-if)#sw access vlan 20
    
    SW-DN(config-if)#exit
    
    SW-DN(config)#int e0/0
    
    SW-DN(config-if)#sw trunk encapsulation dot1q
    
    SW-DN(config-if)#sw mode trunk
    2. Cấu hình Router-DN

    • Cấu hình IP và mở cổng
    Code:
    R2(config)#int f0/0
    
    R2(config-if)#no shutdown
    
    R2(config)#int f0/1
    
    R2(config-if)#ip address 10.123.10.1 255.255.255.252
    
    R2(config-if)#no shudown
    
    R2(config-if)#exit
    
    R2(config)#int f1/0
    
    R2(config-if)#ip address 10.123.10.5 255.255.255.252
    
    R2(config-if)#no shutdown
    
    R2(config-if)#exit
    • Cấu hình inter vlan cổng f0/0
    Code:
    R2(config)#int f0/0
    
    R2(config-if)#int f0/0.1
    
    R2(config-subif)#encapsulation dot1q 10
    
    R2(config-subif)#ip address 172.16.10.250 255.255.255.0
    
    R2(config-subif)#exit
    
    R2(config)#int f0/0
    
    R2(config-if)#int f0/0.2
    
    R2(config-subif)#encapsulation dot1q 20
    
    R2(config-subif)#ip address 172.16.20.250 255.255.255.0
    3. Cấu hình cho Router - HN - HCM - ISP Viettel và Server Google

    • Router – HN
    Code:
    R3(config)#hostname HN
    HN(config)#int f0/1
    HN(config-if)#ip address 10.123.10.6 255.255.255.252
    HN(config-if)#no shutdown
    HN(config-if)#exit
    HN(config)#int f0/0
    HN(config-if)#ip address 12.12.12.1 255.255.255.252
    HN(config-if)#no shutdown
    • Router – HCM
    Code:
    R4(config)#hostname HCM
    HCM(config)#int f0/0
    HCM(config-if)#ip address 10.123.10.2 255.255.255.252
    HCM(config-if)#no shutdown
    HCM(config-if)#exit
    HCM(config)#int f0/1
    HCM(config-if)#ip address 11.11.11.1 255.255.255.252
    HCM(config-if)#no shutdown
    • ISP Viettel . Nhà cung cấp dịch vụ mạng
    Code:
    R1(config)#hostname ISP-Viettel
    ISP-Viettel(config)#int f0/0
    ISP-Viettel(config-if)#ip address 11.11.11.2 255.255.255.252
    ISP-Viettel(config-if)#no shutdown
    ISP-Viettel(config-if)#exit
    ISP-Viettel(config)#int f0/1
    ISP-Viettel(config-if)#ip address 12.12.12.2 255.255.255.252
    ISP-Viettel(config-if)#no shutdown
    ISP-Viettel(config-if)#exit
    ISP-Viettel(config)#int f1/0
    ISP-Viettel(config-if)#ip address 8.8.8.1 255.255.255.0
    ISP-Viettel(config-if)#no shutdown
    • Server Google
    Code:
    VPCS> ip 8.8.8.8/24 8.8.8.1
    PC1 : 8.8.8.8 255.255.255.0 gateway 8.8.8.1
    III. Cấu hình dự phòng static route và static route cho các router


    1. Cấu hình default route, static route cho Router – DN – HN – HCM – ISP Viettel

    • Router – HN
    Code:
    Router-HN(config)#ip route 0.0.0.0 0.0.0.0 12.12.12.2
    Router-HN(config)#ip route 172.16.10.0 255.255.255.0 10.123.10.5
    Router-HN(config)#ip route 172.16.20.0 255.255.255.0 10.123.10.5
    • Router – HCM
    Code:
    Router-HCM(config)#ip route 0.0.0.0 0.0.0.0 11.11.11.2
    Router-HCM(config)#ip route 172.16.10.0 255.255.255.0 10.123.10.1
    Router-HCM(config)#ip route 172.16.20.0 255.255.255.0 10.123.10.1
    • Router – ISP Viettel, Set AD=10 cho đường đi chính và AD =15 với đường dự phòng
    Code:
    ISP-Viettel(config)#ip route 0.0.0.0 0.0.0.0 11.11.11.1 10
    ISP-Viettel(config)#ip route 0.0.0.0 0.0.0.0 12.12.12.1 15
    • Router – DN, set AD=10 đối với đường đi chính, AD = 15 đối với trường hợp dự phòng
    Code:
    DN(config)#ip route 11.11.11.0 255.255.255.252 10.123.10.2
    DN(config)#ip route 12.12.12.0 255.255.255.252 10.123.10.6
    DN(config)#ip route 8.8.8.0 255.255.255.0 10.123.10.6 10
    DN(config)#ip route 8.8.8.0 255.255.255.0 10.123.10.2 15
    • Test đường đi và ping từ PC1 đến Sv GG theo yêu cầu bài lab đối với trường hợp đường đi chính up
    Ping 8.8.8.8
    Trace 8.8.8.8

    Cau hinh ip sla(2)

    • Sau khi sử dụng lệnh trace thì ta thấy cái next hop nhảy sẽ ứng với đường đi PC1 -> DN -> HN -> ISP Viettel -> Sv GG

    IV. Cấu hình IP SLA
    • Giờ ta sẽ thử trường hợp cáp giữa DN với HN (khi đứt cáp ở đoạn DN – HN thì trong thực tế sẽ bị down hai cổng f1/0 của DN và f0/1 của HN, nhưng GNS3 không thực hiện như vậy nên mình sẽ down bằng tay – tương tự yêu cầu tiếp theo)
    Cau hinh ip sla(3)

    Ping 8.8.8.8
    Trace 8.8.8.8

    Cau hinh ip sla(4)

    • Vậy là việc kết nối mạng từ PC1 đến Server Google không thành công.

    • Nguyên nhân: Sau khi down được cổng f1/0 của DN thì việc bật định tuyến phụ lên đã được thực hiện nhưng sau khi gói tin đi đến Sv GG và được trả về, qua ISP- Viettel thì theo cấu hình định tuyến nó sẽ đi theo default route có số AD=10, và đi tiếp đến HN nhưng đến đây HN đã bị down cổng f0/1, cổng outgoing đã bị down thì định tuyến này cũng bị gỡ bỏ khỏi bảng định tuyến, thêm một cái nữa là HN không có đường đi phụ, hay gói tin có thể đi ngược lại đến ISP-Viettel đi chăng nữa thì việc này không khả thi.

    • Do đó ta cần đặt một bộ máy kiểm tra việc kết nối liên tục từ ISP-Viettel. Việc thực hiện cấu hình như vậy gọi là cấu hình IP SLA

    • Để giải quyết được vấn đề trên ta sẽ sử dụng phương pháp cấu hình IP SLA (IP Service Layer Aggrement)
    //////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
    Bước 1: Tạo ra bộ máy giám sát SLA số tuỳ ý

    R1(config)#ip sla 1

    Bước 2: Bộ máy ping đến ip 10.123.10.6 có thể dùng thêm sau câu lệnh là source IP hoặc source ip interface

    R1(config-ip-sla)#icmp-echo 10.123.10.6
    R1(config-ip-sla)#icmp-echo 10.123.10.6 source f0/1 | source 12.12.12.2

    Đặt tần số ping đến địa chỉ trên 5s/1 lần

    R1(config-ip-sla-echo)#frequency 5

    Bước 3: khởi động bộ máy số 1

    R1(config)#ip sla schedule 1 start-time now life forever

    Tạo track 10 tham chiếu đến IP SLA 1

    R1(config)#track 10 rtr 1

    Bước 4: Xoá câu lệnh ip route trước đó, hoặc thêm track sau câu lệnh đó

    R1(config)#no ip route 0.0.0.0 0.0.0.0 10.123.10.6 10

    Bước 5: Bổ sung điều kiện vào câu lệnh static route

    R1(config)#ip route 0.0.0.0 0.0.0.0 10.123.10.6 10 track 10
    //////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
    • Khi ping thành công, IP SLA sẽ trả về kết quả thành công, track Up, static route tham chiếu đến track được đưa vào bảng định tuyến -> đường chính được sử dụng. Ngược lại, ping không thành công IP SLA sẽ trả về kết quả Time Out, track Down, static route được tham chiếu đến track sẽ bị gỡ bỏ khỏi bảng định tuyến -> được dự phòng nếu được cấu hình sẽ bật lên.
    Ping 8.8.8.8
    Trace 8.8.8.8 => thành công

    Cau hinh ip sla(5)

    • Theo yêu cầu cuối thì đường giữa HN với ISP-Viettel đã bị đứt, tương tự như đường giữa DN – HN bị đứt. Nhưng khi việc chuyển kết nối của ISP-Viettel vẫn được tiếp tục, còn DN thì lại đi vẫn đi theo còn đường DN – HN đó ta cần phải cấu hình IP SLA cho DN
    Cau hinh ip sla(6)


    Code:
    DN(config)#ip sla 1
    DN(config-ip-sla)#icmp-echo 12.12.12.1 source-ip
    DN(config-ip-sla)#icmp-echo 12.12.12.1 source-ip 10.123.10.5
    DN(config-ip-sla-echo)#frequency 5
    DN(config-ip-sla-echo)#exit
    DN(config)#ip sla schedule 1 start-time now life forever
    DN(config)#track 5 rtr 1
    DN(config-track)#exit
    DN(config)#no ip route 8.8.8.0 255.255.255.0 10.123.10.6 10
    DN(config)#ip route 8.8.8.0 255.255.255.0 10.123.10.6 10 track 5
    • Sau khi cấu hình thành công ta sẽ kiểm tra lại
    Cau hinh ip sla(7)



    Vậy là việc cấu hình IP SLA đã thành công !

     
    Last edited: Jul 11, 2018

Share This Page