CCNA Lab 3.1: Kết hợp Static Route và Inter Vlan trên Router Cisco

Discussion in 'Lab' started by nessiggk, Jun 27, 2018.

  1. nessiggk

    nessiggk New Member

    Joined:
    Feb 25, 2018
    Messages:
    27
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 3.1: Kết hợp Static Route và Inter Vlan trên Router Cisco




    Sau khi đã cấu hình inter vlan trên router cisco, việc giao tiếp với nhau đã thành công. Ở bài lab này chúng ta hướng đến một kết nối rộng hơn giữa mạng Router HN và Router HCM, từ đó để kết nối được chúng ta cần sử dụng phương pháp Static Route ở bài lab trước.


    I. Sơ đồ và yêu của bài lab


    1. Sơ đồ

    • Mô hình bài lab kết hợp giữa static route và inter vlan trên router cisco
    cau hinh inter vlan va static route(1)

    2. Yêu cầu

    - Thiết lập và cấu hình như sơ đồ

    - Cấu hình cho vlan 10 và vlan 20 ở Router HCM ping thấy các vlan ở Router HN

    - Cấu hình cho vlan 10 và vlan 20 ở Router HCM không ping thấy vlan 30 ở Router HN


    II. Thực hiện bài lab


    1. Cấu hình cho Router, Switch bên HN

    • Sử dụng cấu hình vlan, intervlan, trunk, router,pc ở bài Lab 3.0

    • Đặt hostname, mở cổng g0/1 và đặt ip cho nó => chúng ta hướng đến static route nên cần đặt ip cho cổng g0/1
    Code:
    Router(config)#hostname Router-HN
    
    Router-HN(config)#interface g0/1
    
    Router-HN(config-if)#ip address 10.123.10.1 255.255.255.252 (subnet mask tương ứng /30)
    
    Router-HN(config-if)#no shutdown

    2. Cấu hình cho Router, Switch bên HCM

    • Cấu hình vlan và bật trunk trên Sw HCM
    Code:
    Switch(config)#vlan 10
    
    Switch(config-vlan)#name KINHDOANH
    
    Switch(config-vlan)#exit
    
    Switch(config)#vlan 20
    
    Switch(config-vlan)#name KETOAN
    
    Switch(config-vlan)#exit
    
    Switch(config)#interface f0/2
    
    Switch(config-if)#switchport access vlan 10
    
    Switch(config-if)#exit
    
    Switch(config)#interface f0/3
    
    Switch(config-if)#switchport access vlan 20
    
    Switch(config-if)#exit
    
    Switch(config)#interface f0/1
    
    Switch(config-if)#switchport mode trunk
    
    Switch(config-if)#^Z
    • Cấu hình bật cổng g0/0 và g0/1, đặt hostname và ip cho cổng g0/1
    Code:
    Router(config)#hostname Router-HCM
    
    Router-HCM(config)#int g0/0
    
    Router-HCM(config-if)#ip address 10.123.10.2 255.255.255.252
    
    Router-HCM(config-if)#no shutdown
    
    Router-HCM(config-if)#exit
    
    Router-HCM(config)#int g0/1
    
    Router-HCM(config-if)#no shutdown
    • Cấu hình inter vlan cho Router-HCM: Chia sub-interface cho các vlan
    Code:
    Router-HCM(config)#int g0/1
    
    Router-HCM(config-if)#int g0/1.1
    
    Router-HCM(config-subif)#encapsulation dot1q 10
    
    Router-HCM(config-subif)#ip address 172.16.1.250 255.255.255.0
    
    Router-HCM(config-subif)#exit
    
    Router-HCM(config)#int g0/1
    
    Router-HCM(config-if)#int g0/1.2
    
    Router-HCM(config-subif)#encapsulation dot1q 20
    
    Router-HCM(config-subif)#ip address 172.16.2.250 255.255.255.0
    • Tiếp theo đặt Default Gateway cho PC10 là 172.16.1.250 và PC20 là 172.16.2.250, cách đặt thì IP Configuration như trước

    • Việc cấu hình cơ bản đến đây hoàn tất, nhưng còn cho vlan 10 và vlan 20 ở Router HCM ping thấy các vlan ở Router HN -> Ta cần phải cấu hình static route cho Router-HCM và Router-HN

    3. Cấu hình static route Router-HCM và Router-HN


    • Cấu hình static route Router-HN:
      • Ở đây ta thấy mạng cần đến là 172.16.1.0 và 172.16.2.0 và next hop sẽ là 10.123.10.2 do đó ta sẽ cấu hình như sau
    Code:
    Router-HN(config)#ip route 172.16.1.0 255.255.255.0 10.123.10.2
    
    Router-HN(config)#ip route 172.16.2.0 255.255.255.0 10.123.10.2
    • Cấu hình static route Router-HCM:
      • Để việc cấu hình thành công thì ta luôn cần cấu hình đầy đủ trên các router, ở Router-HN cần đến mạng 192.168.1.0, 192.168.2.0, 192.168.3.0 và next hop là 10.123.10.1
    Code:
    Router-HCM(config)#ip route 192.168.1.0 255.255.255.0 10.123.10.1
    
    Router-HCM(config)#ip route 192.168.2.0 255.255.255.0 10.123.10.1
    
    Router-HCM(config)#ip route 192.168.3.0 255.255.255.0 10.123.10.1
    • Sau khi đã cấu hình static route thành công, ta sẽ test ping từ PC vlan 10 ở HCM thấy pc vlan 20, 30 ở HN và tương tự PC vlan 20 ở HCM ping thấy PC vlan 10,30 ở HN

    • PC10 -> PC1 vlan 10: Thành công
    Code:
    Ping 192.168.1.1
    cau hinh inter vlan va static route(2)

    • PC10 -> PC2 vlan 20: Thành công
    Code:
    Ping 192.168.2.1
    cau hinh inter vlan va static route(3)

    • PC10 -> PC4 vlan 30: Thành công
    Code:
    Ping 192.168.3.1
    cau hinh inter vlan va static route(4)


    4. Cấu hình cho vlan 10 và vlan 20 ở Router HCM không ping thấy vlan 30 ở Router HN


    • Giải pháp ưu tiên ở đây xoá mạng 192.168.3.0 của vlan 30 ra khỏi bảng định tuyến của Router-HCM hoặc Router-HN

    • Nhưng việc xoá mạng 192.168.3.0 của vlan 30 ra khỏi bảng định tuyến của router-HN thì không được, do việc truyền dữ liệu giữa các vlan trong Router-HN vẫn phải đảm bảo

    • Do đó ta sẽ xoá mạng 192.168.3.0 của vlan 30 ra khỏi bảng định tuyến của Router-HCM
    Code:
    Router-HCM(config)#no ip route 192.168.3.0 255.255.255.0 10.123.10.1
    • Kiểm tra lại bảng định tuyến
    Code:
    Router-HCM#show ip route static
    
    S 192.168.1.0/24 [1/0] via 10.123.10.1
    
    S 192.168.2.0/24 [1/0] via 10.123.10.1
    
    Router-HCM#
    • Test ping từ PC10 vlan 10 ở HCM tới PC4 vlan 30 ở HN
      Code:
      Ping 192.168.3.1
    cau hinh inter vlan va static route(5)


    • Vậy là bài lab 3.1 đã hoàn tất
     
    chickenbaby likes this.

Share This Page