CCNA Lab 3.0: Cấu hình Inter Vlan Routing trên Router Cisco

Discussion in 'Lab' started by nessiggk, Jun 25, 2018.

  1. nessiggk

    nessiggk New Member

    Joined:
    Feb 25, 2018
    Messages:
    27
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 3.0: Cấu hình Inter Vlan Routing trên Router Cisco




    Nhưng chúng ta đã biết khi cấu hình vlan thì các thiết bị khác vlan thì không thể truyền dữ liệu được với nhau do đó cần phải định tuyến Layer 3 tức là cần đến 1 con SW Layer 3 hoặc Router.


    Bài viết cũng tiếp tục thực hiện trên phần mềm Cisco Packet Tracer ( từ nay về sau cũng như vậy).


    I. Sơ đồ và yêu cầu của bài lab cấu hình Inter Vlan Routing trên Router Cisco

    1. Sơ đồ

    • Mô hình bài lab cấu hình inter vlan trên router cisco
    cau hinh inter vlan trên router cisco(1)

    2. Yêu cầu

    • Thiết lập sơ đồ

    • Cấu hình cơ bản cho các thiết bị

    • Cấu hình Trunking giữa Router và Switch

    • Cấu hình Sub-interface trên Router

    • Cấu hình cho các pc giữa các vlan ping được tới nhau

    II. Triển khai lab cấu hình inter vlan trên router cisco

    1. Cấu hình Switch và các PC

    • Ở bài lab trước ta đã cấu hình các vlan, địa chỉ ip của pc, và các thứ liên quan

    • Bây giờ ta tiếp tục cấu hình đường trunk cho Switch trước
    Code:
    Switch>ena
    
    Switch#conf t
    
    Switch(config)#interface f0/7
    
    Switch(config-if)#switchport mode trunk
    
    Switch(config-if)#
    • Kiểm tra các vlan đã lên đường trunk chưa
    cau hinh inter vlan trên router cisco(2)

    2. Cấu hình Router cấp IP cho các Vlan

    • Đầu tiên ta phải bật cổng G0/0: ở đây đã mình đã bật sẵn rồi
    Code:
    Router>ena
    
    Router#conf t
    
    Router(config)#interface g0/0
    
    Router(config-if)#no shutdown
    • Chia Sub-interface cho các vlan theo chuẩn IEEE

    • Việc tạo Sub-interface cho các vlan như là tạo các default-gateway cho chúng.
    Code:
    Router(config)#interface g0/0
    
    Router(config-if)#inetrface g0/0.10 – Tạo cổng logic g0/0.10 trên cổng vật lí g0/0
    
    Router(config-subif)#encapsulation dot1Q 10 – Gắn vlan 10 trên cổng logic g0/0.10
    
    Router(config-subif)#ip address 192.168.1.250 255.255.255.0
    
    Router(config-subif)#exit
    
    Router(config)#interface g0/0.20
    
    Router(config-subif)#encapsulation dot1Q 20
    
    Router(config-subif)#ip address 192.168.2.250 255.255.255.0
    
    Router(config-subif)#exit
    
    Router(config-if)#interface g0/0.30
    
    Router(config-subif)#encapsulation dot1Q 30
    
    Router(config-subif)#ip address 192.168.3.250 255.255.255.0
    
    Router(config-subif)#exit
    • Kiểm tra lại các sub-interface ta đã tạo => Thành công
    Code:
    Router#show ip route connected
    
    C 192.168.1.0/24 is directly connected, GigabitEthernet0/0.10
    
    C 192.168.2.0/24 is directly connected, GigabitEthernet0/0.20
    
    C 192.168.3.0/24 is directly connected, GigabitEthernet0/0.30
    • Hoặc
    cau hinh inter vlan trên router cisco(3)

    • Đến đây việc ping giữa các pc khác vlan vẫn chưa thành công -> Ta cần phải khai báo Default Gateway cho chúng nữa

    • Việc khai Default Gateway có nhiều cách nhưng thông thường vào ip configuration của pc khai báo là cách đơn giản
    cau hinh inter vlan trên router cisco(4)

    • Tương tự ta làm với các pc còn lại. Lưu ý khai báo default gateway phải tương ứng với sub-interface ta đã chia cho từng vlan ở router.
    3. Kiểm tra các pc khác vlan đã ping thấy nhau chưa

    • PC0 -> PC2 => thành công
    Code:
    Ping 192.168.2.1
    cau hinh inter vlan trên router cisco(5)


    • PC3 -> PC4 => Thành công
    Code:
    Ping 192.168.3.1
    cau hinh inter vlan trên router cisco(6)



    • Vậy việc cấu hình cho các vlan khác nhau ping thấy nhau bằng các sử dụng router đã thành công. Kỹ thuật chia sub-interface trên được gọi là kỹ thuật InterVLAN routing (kỹ thuật định tuyến giữa các vlan)
     
  2. daohai.ict

    daohai.ict New Member

    Joined:
    Aug 7, 2018
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    viet nam
    Home Page:
    Mình xin phép bổ sung 1 chút là phải cấu hình mode access từng dãy port cho từng vlan mới ping thấy được.
     

Share This Page