Lab 2.3 Cấu hình Load balancing Gateway trên Pfsense

Discussion in 'Security' started by root, Jul 13, 2014.

  1. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38
    I. Mô hình
    1. Mô hình

    [​IMG]

    2. Yêu cầu
    - PC trong LAN khi truy cập interface thì pfsense sẽ thực hiện load banlancing gateway trên 2 interface WAN
    - Sơ đô IP

    [TABLE="class: grid, width: 800"]

    Pfsense
    em0: WAN 1, IP: 192.168.10.10/24, gateway 192.168.10.254
    em1: WAN 2, IP: 192.168.20.10/24, gateway 192.168.20.254
    em2: LAN, IP: 10.1.1.10/24

    Router R1
    f0/0: DHCP
    f0/1: IP 192.168.10.254/24

    Router R2
    f0/0: DHCP
    f0/1: IP 192.168.20.254/24

    PC
    dhcp
    [/TABLE]


    II. Triển khai

    1. Cấu hình IP, Gateway
    - Pfsense: về cấu hình IP và DHCP trên pfsense các bạn xem ở bài lab 2.2 tai đây http://svuit.com/showthread.php?614-Lab-2-2-Cấu-hình-IP-và-DHCP-pfsense-bằng-web
    - Router R1: Cấu hình IP và NAT để mạng bên trong ra internet
    [TABLE="class: outer_border, width: 500"]

    R1(config)#interface f0/0
    R1(config-if)#ip address dhcp
    R1(config-if)#no shutdown
    R1(config-if)#int f0/1
    R1(config-if)#ip address 192.168.10.254 255.255.255.0
    R1(config-if)#no shutdown


    R1(config)#access-list 1 permit any
    R1(config)#ip nat inside source list 1 interface f0/0 overload
    R1(config)#int f0/0
    R1(config-if)#ip nat outside
    R1(config-if)#int f0/1
    R1(config-if)#ip nat inside
    [/TABLE]


    - Router R2: Cấu hình tương tự Router R1

    [TABLE="class: outer_border, width: 500"]

    R2(config)#interface f0/0
    R2(config-if)#ip address dhcp
    R2(config-if)#no shutdown
    R2(config-if)#int f0/1
    R2(config-if)#ip address 192.168.20.254 255.255.255.0
    R2(config-if)#no shutdown

    R2(config)#access-list 1 permit any
    R2(config)#ip nat inside source list 1 interface f0/0 overload
    R2(config)#int f0/0
    R2(config-if)#ip nat outside
    R2(config-if)#int f0/1
    R2(config-if)#ip nat inside
    [/TABLE]

    2. Cấu hình load balancing
    - chọn system routing để bạn có thể thấy pfsense hiện đang có 2 đường kết nối WAN
    [​IMG]

    [​IMG]

    - Group 2 interface WAN đó thành 1 interface WAN ảo.

    [​IMG]

    - Đặt tên interface WAN ảo này (loadBalancing) và chú ý Tier của 2 interface WAN vật lý phải giống nhau
    [​IMG]

    [​IMG]

    - Cấu hình Rule để các PC trong LAN ra interface bằng interface WAN ảo vừa tạo ở trên

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    - Vầy là cấu hình xong, bây giờ bạn có thể xem trang thái của gateway

    [​IMG]

    [​IMG]

    [​IMG]
     
  2. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38
    3. Kiểm tra
    - Trên PC bạn thử xem film trên ytube, hoặc download ... để xem traffic trên pfsense xử lý như thế nào

    [​IMG]


    - Trên pfsense bạn có thể xem traffic của PC được load balancing trên cả 2 interface WAN

    [​IMG]

    - Như bạn thấy traffic của PC được load balancing trên cả 2 interface WAN

    [​IMG]

    [​IMG]

    - Bây giờ trên Router R1 mình sẽ shutdown f0/1 bạn sẽ thấy 1 đường kết nối WAN đã bị down

    [​IMG]
    - Nhưng PC vẫn ra internet bình thường thông qua WAN 2

    [​IMG]

    - Bây giờ mình thử shutdown f0/0 của R1 và no shutdown f0/1. Bạn thấy 2 WAN đã hiện online

    [​IMG]

    - Tuy nhiên đường kết nối WAN qua R1 đã bị down vì f0/0 của R1 down, nhưng PC trong LAn vẫn ra internet được thông qua đường WAN 2 qua Router R2

    [​IMG]
     

Share This Page