Lab 2.2 Stub OSPF (Stub - Totally Stubby - Not so Stubby area)

Discussion in 'Lab' started by root, Dec 3, 2014.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48
    I. Mô hình và yêu cầu
    - Mô hình

    [​IMG]


    - Giới thiệu: Các bạn có thể tìm hiểu lý thuyết của bài Lab này tại đây: http://svuit.vn/showthread.php/206-Chapter-4-part-2-Dynamic-Routing

    - Yêu cầu:
    • Cấu hình IP như mô hình trên
    • Cấu hình Route OSPF cho các Router như sau
      • Area 0 gồm: loopback1, f0/0 trên R1 và loopback2, f0/0 trên R2
      • Area 23 gồm: f0/1 trên R2 và loopback3, f0/0 trên R3
    - Cấu hình EIGRP trên f1/0 R2 và f0/0, loopback4 trên R4
    - Đảm bảo hệ thống mạng hội tụ
    - Cấu hình Stub OSPF đặc biệt
    • Stub
    • Totally Stubby
    • Not so Stubby area
    II. Triển khai
    1. Cấu hình IP trên các router R1,R2,R3 và R4

    [TABLE="class: outer_border, width: 500"]

    // Cấu hình IP trên Router R1
    R1(config)#int f0/0
    R1(config-if)#ip add 10.1.1.1 255.255.255.0
    R1(config-if)#no shutdown

    R1(config-if)#int loopback1
    R1(config-if)#ip add 1.1.1.1 255.255.255.0

    // Cấu hình IP trên Router R2
    R2(config)#int f0/0
    R2(config-if)#ip add 10.1.1.2 255.255.255.0
    R2(config-if)#no shut

    R2(config-if)#int f0/1
    R2(config-if)#ip add 10.2.2.2 255.255.255.0
    R2(config-if)#no shut

    R2(config)#int f1/0
    R2(config-if)#ip add 10.4.4.2 255.255.255.0
    R2(config-if)#no shut


    R2(config-if)#int loopback2
    R2(config-if)#ip add 2.2.2.2 255.255.255.0
    R2(config-if)#no shut

    // Cấu hình IP trên Router R3
    R3(config)#int f0/0
    R3(config-if)#ip add 10.2.2.3 255.255.255.0
    R3(config-if)#no shut

    R3(config-if)#int loopback3
    R3(config-if)#ip add 3.3.3.3 255.255.255.0

    R3(config-if)#int loopback33
    R3(config-if)#ip add 33.33.33.33 255.255.255.0

    // Cấu hình IP trên Router R4
    R4(config)#int f0/0
    R4(config-if)#ip add 10.4.4.4 255.255.255.0
    R4(config-if)#no shut


    R4(config)#interface f0/0
    R4(config-if)#int loopback4
    R4(config-if)#ip add 4.4.4.4 255.255.255.0
    [/TABLE]

    2. Cấu hình OSPF trên các Router
    - Cấu hình OSPF cho các interface của Router thuộc Area 0
    • R1: f0/0 và loopback1
    • R2: f0/0 và loopback2
    [TABLE="class: outer_border, width: 500"]

    // Cấu hình OSPF trên Router R1
    R1(config)#router ospf 1
    R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
    R1(config-router)#network 10.1.1.1 0.0.0.0 area 0

    // Cấu hình OSPF trên Router R2
    R2(config)#router ospf 1
    R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
    R2(config-router)#network 10.1.1.2 0.0.0.0 area 0
    [/TABLE]

    - Kiểm tra bảng định tuyến của 2 Router R1 và R2

    Code:
    R1#[COLOR=#ff0000][B]sh ip route[/B][/COLOR]
    
    Gateway of last resort is not set
    
         1.0.0.0/24 is subnetted, 1 subnets
    C       1.1.1.0 is directly connected, Loopback1
         2.0.0.0/32 is subnetted, 1 subnets
    [COLOR=#ff0000]O       2.2.2.2 [110/11] via 10.1.1.2[/COLOR], 00:06:27, FastEthernet0/0
         10.0.0.0/24 is subnetted, 1 subnets
    C       10.1.1.0 is directly connected, FastEthernet0/0
    
    
    - Như bài lab trước các bạn cũng biết rằng, các subnet trên interface loopback được OSPF quảng bá đi với prefix-length là /32 bất kể prefix-length của nó là bao nhiêu đi nữa. Nếu các bạn không muốn nhìn thấy prefix-length /32 như vầy thì các bạn có thể sử dụng thêm lệnh sau

    [TABLE="class: outer_border, width: 500"]

    // Trên Router R1
    R1(config)#int loopback1
    R1(config-if)#ip ospf network point-to-point

    // Trên Router R2
    R2(config)#int loopback2
    R2(config-if)#ip ospf network point-to-point
    [/TABLE]

    - Kiểm tra lại bảng đinh tuyến của Router R1 và R2

    Code:
    R1#[COLOR=#ff0000][B]sh ip route[/B][/COLOR]
    
    Gateway of last resort is not set
    
         1.0.0.0/24 is subnetted, 1 subnets
    C       1.1.1.0 is directly connected, Loopback1
         2.0.0.0/24 is subnetted, 1 subnets
    [COLOR=#ff0000]O       2.2.2.0 [/COLOR][110/11] [COLOR=#ff0000]via 10.1.1.2[/COLOR], 00:00:06, FastEthernet0/0
         10.0.0.0/24 is subnetted, 1 subnets
    C       10.1.1.0 is directly connected, FastEthernet0/0
    
    

    - Tiếp theo các bạ thực hiện cấu hình OSPF trên các interface R2 và R3 thuộc Area 23
    • R2: f0/1
    • R3: f0/0, loopback3
    [TABLE="class: outer_border, width: 500"]

    // Cấu hình OSPF trên R2
    R2(config)#router ospf 1
    R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
    R2(config-router)#network 10.1.1.2 0.0.0.0 area 0

    R2(config-router)#int loopback2
    R2(config-if)#ip ospf network point-to-point

    // Cấu hình OSPF trên R3
    R3(config)#router ospf 1
    R3(config-router)#network 3.3.3.3 0.0.0.0 area 23
    R3(config-router)#network 10.2.2.3 0.0.0.0 area 23

    R3(config-router)#int loopback3
    R3(config-if)#ip ospf network point-to-point

    R3(config-if)#int loopback33
    R3(config-if)#ip ospf network point-to-point
    [/TABLE]

    - Kiểm tra bảng định tuyến R3 các bạn sẽ thấy các route O IA như
    • OIA 1.1.1.0
    • OIA 2.2.2.0
    • OIA 10.1.1.0
    Đây là các route ngoại vùng vì nó học được từ vùng khác

    Code:
    R3#[COLOR=#ff0000][B]sh ip route[/B][/COLOR]
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, [COLOR=#00ff00]O - OSPF, IA - OSPF inter area[/COLOR]
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         1.0.0.0/24 is subnetted, 1 subnets
    [COLOR=#ff0000]O IA    1.1.1.0[/COLOR] [110/21] via 10.2.2.2, 00:00:39, FastEthernet0/0
         2.0.0.0/24 is subnetted, 1 subnets
    [COLOR=#ff0000]O IA    2.2.2.0[/COLOR] [110/11] via 10.2.2.2, 00:00:39, FastEthernet0/0
         33.0.0.0/24 is subnetted, 1 subnets
    C       33.33.33.0 is directly connected, Loopback33
         3.0.0.0/24 is subnetted, 1 subnets
    C       3.3.3.0 is directly connected, Loopback3
         10.0.0.0/24 is subnetted, 2 subnets
    C       10.2.2.0 is directly connected, FastEthernet0/0
    [COLOR=#ff0000]O IA    10.1.1.0[/COLOR] [110/20] via 10.2.2.2, 00:00:41, FastEthernet0/0
    
    
    
    - Các bạn lên Router R2 kiểm tra lại thì thấy trên bảng đinh tuyến của R2 không có route nào bị đánh dấu là O IA. Vì Router R2 là Router biên, nó nằm giữa 2 vùng (Area 0 và Area 23). Nó còn được gọi là ABR - Area Border Router

    Code:
    R2#sh ip route
    
    
    Gateway of last resort is not set
    
    
         1.0.0.0/24 is subnetted, 1 subnets
    O       1.1.1.0 [110/11] via 10.1.1.1, 00:08:03, FastEthernet0/0
         2.0.0.0/24 is subnetted, 1 subnets
    C       2.2.2.0 is directly connected, Loopback2
         3.0.0.0/24 is subnetted, 1 subnets
    O       3.3.3.0 [110/11] via 10.2.2.3, 00:06:38, FastEthernet0/1
         10.0.0.0/24 is subnetted, 2 subnets
    C       10.2.2.0 is directly connected, FastEthernet0/1
    C       10.1.1.0 is directly connected, FastEthernet0/0
    
    
    3. Cấu hình EIGRP và Redistribute
    - Tiếp theo chúng ta sẽ thực hiện cấu hình EIGRP giữa 2 Router R2 và R4

    [TABLE="class: outer_border, width: 500"]

    // Cấu hình EIGRP trên R2
    R2(config)#router eigrp 1
    R2(config-router)#network 10.4.4.2 0.0.0.0

    // Cấu hình EIGRP trên R4
    R4(config)#router eigrp 1
    R4(config-router)#network 10.4.4.4 0.0.0.0
    R4(config-router)#network 4.4.4.4 0.0.0.0
    [/TABLE]

    - Tiếp theo các bạn thực hiện Redistribute giữa 2 vùng định tuyến OSPF và EIGPR với nhau. Chúng ta sẽ đứng trên Router biên giới giữa 2 vùng định tuyến trên là R2 để thực hiện quăng các vùng định tuyến qua lại lẫn nhau

    [TABLE="class: outer_border, width: 500"]

    R2(config)#router eigrp 1
    R2(config-router)#redistribute ospf 1 metric 100000 100 255 1 1500

    R2(config-router)#router ospf 1
    R2(config-router)#redistribute eigrp 1 subnets
    [/TABLE]

    - Các bạn thực hiện kiểm tra bảng đinh tuyến các Router R4 sẽ thấy các route có ký hiệu D EX. Nó chính là các route đinh tuyến ngoại vùng của EIGRP.

    Code:
    R4#sh ip route
    
    
    Gateway of last resort is not set
    
    
         1.0.0.0/24 is subnetted, 1 subnets
    [COLOR=#ff0000]D EX    1.1.1.0 [170/307200] via 10.4.4.2[/COLOR], 00:07:21, FastEthernet0/0
         2.0.0.0/24 is subnetted, 1 subnets
    [COLOR=#ff0000]D EX    2.2.2.0 [170/307200] via 10.4.4.2[/COLOR], 00:07:21, FastEthernet0/0
         3.0.0.0/24 is subnetted, 1 subnets
    [COLOR=#ff0000]D EX    3.3.3.0 [170/307200] via 10.4.4.2[/COLOR], 00:06:12, FastEthernet0/0
         4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       4.4.4.0/24 is directly connected, Loopback4
    D       4.0.0.0/8 is a summary, 00:09:49, Null0
         10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C       10.4.4.0/24 is directly connected, FastEthernet0/0
    D EX    10.2.2.0/24 [170/307200] via 10.4.4.2, 00:07:25, FastEthernet0/0
    D EX    10.1.1.0/24 [170/307200] via 10.4.4.2, 00:07:25, FastEthernet0/0
    D       10.0.0.0/8 is a summary, 00:09:50, Null0
    
    
    - Tương tự các bạn kiểm tra bảng định tuyến của R3, các bạn sẽ thấy các route có ký hiệu O E2, nó chính là các route định tuyến ngoại vùng của OSPF

    Code:
    R3#[COLOR=#ff0000][B]sh ip route[/B][/COLOR]
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, [COLOR=#00ff00]EX - EIGRP external[/COLOR], O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
          [COLOR=#00ff00] E1 - OSPF external type 1[/COLOR], [COLOR=#00ff00]E2 - OSPF external type 2[/COLOR]
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    
    Gateway of last resort is not set
    
    
         1.0.0.0/24 is subnetted, 1 subnets
    O IA    1.1.1.0 [110/21] via 10.2.2.2, 00:09:39, FastEthernet0/0
         2.0.0.0/24 is subnetted, 1 subnets
    O IA    2.2.2.0 [110/11] via 10.2.2.2, 00:09:39, FastEthernet0/0
         33.0.0.0/24 is subnetted, 1 subnets
    C       33.33.33.0 is directly connected, Loopback33
         3.0.0.0/24 is subnetted, 1 subnets
    C       3.3.3.0 is directly connected, Loopback3
    [COLOR=#ff0000]O E2 4.0.0.0/8 [110/20] via 10.2.2.2, 00:09:39, FastEthernet0/0[/COLOR]
         10.0.0.0/24 is subnetted, 3 subnets
    [COLOR=#ff0000]O E2    10.4.4.0 [110/20] via 10.2.2.2, 00:09:41, FastEthernet0/0[/COLOR]
    C       10.2.2.0 is directly connected, FastEthernet0/0
    O IA    10.1.1.0 [110/20] via 10.2.2.2, 00:09:41, FastEthernet0/0
    
    
    
     
  2. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48
    4. Cấu hình vùng Stub
    - Cấu hình Stub trên Area 23

    [TABLE="class: outer_border, width: 500"]

    // Cấu hình Stub trên R2
    R2(config)#router ospf 1
    R2(config-router)#area 23 stub

    // Cấu hình Stub trên R3
    R3(config)#router ospf 1
    R3(config-router)#area 23 stub
    [/TABLE]

    - Lúc này trên bảng định tuyến của R3 sẽ được Router ABR truyền vào 1 default-route thay thế cho các route ngoài AS khác (các Router loại O E1 or O E2).
    - R3 thuộc vùng Stub và nó không tiếp nhận LSP type 5. Bạn có thể thấy trên bảng định tuyến của R3 không có đường route ngoại vùng O E2 như ở trên

    Code:
    R3#[COLOR=#ff0000][B]sh ip route[/B][/COLOR]
    
    
    Gateway of last resort is 10.2.2.2 to network 0.0.0.0
    
         1.0.0.0/24 is subnetted, 1 subnets
    O IA    1.1.1.0 [110/21] via 10.2.2.2, 00:01:28, FastEthernet0/0
         2.0.0.0/24 is subnetted, 1 subnets
    O IA    2.2.2.0 [110/11] via 10.2.2.2, 00:01:28, FastEthernet0/0
         33.0.0.0/24 is subnetted, 1 subnets
    C       33.33.33.0 is directly connected, Loopback33
         3.0.0.0/24 is subnetted, 1 subnets
    C       3.3.3.0 is directly connected, Loopback3
         10.0.0.0/24 is subnetted, 2 subnets
    C       10.2.2.0 is directly connected, FastEthernet0/0
    O IA    10.1.1.0 [110/20] via 10.2.2.2, 00:01:29, FastEthernet0/0
    [COLOR=#ff0000]O*IA 0.0.0.0/0 [110/11] via 10.2.2.2, 00:01:29, FastEthernet0/0[/COLOR]
    
    
    - Nhưng nhờ Router ABR truyền vào 1 default-route thay thế cho các route ngoài AS khác mà R3 vẫn liên lạc được với R4

    Code:
    R3#ping 4.4.4.4
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 60/73/92 ms
    
    
    
    - Để kiểm tra các Area thuộc loại Area nào dùng lệnh sau

    Code:
    [B][COLOR=#ff0000]R3#sh ip ospf[/COLOR][/B]
     Routing Process "ospf 1" with ID 3.3.3.3
     Start time: 00:23:31.532, Time elapsed: 01:12:40.172
     Supports only single TOS(TOS0) routes
     Supports opaque LSA
     Supports Link-local Signaling (LLS)
     Supports area transit capability
     Router is not originating router-LSAs with maximum metric
     Initial SPF schedule delay 5000 msecs
     Minimum hold time between two consecutive SPFs 10000 msecs
     Maximum wait time between two consecutive SPFs 10000 msecs
     Incremental-SPF disabled
     Minimum LSA interval 5 secs
     Minimum LSA arrival 1000 msecs
     LSA group pacing timer 240 secs
     Interface flood pacing timer 33 msecs
     Retransmission pacing timer 66 msecs
     Number of external LSA 0. Checksum Sum 0x000000
     Number of opaque AS LSA 0. Checksum Sum 0x000000
     Number of DCbitless external and opaque AS LSA 0
     Number of DoNotAge external and opaque AS LSA 0
     Number of areas in this router is 1. 0 normal 1 stub 0 nssa
     Number of areas transit capable is 0
     External flood list length 0
     IETF NSF helper support enabled
     Cisco NSF helper support enabled
    [B][COLOR=#ff0000]   Area 23[/COLOR][/B]
            Number of interfaces in this area is 2 (1 loopback)
    [COLOR=#ff0000]       It is a stub area[/COLOR]
            Area has no authentication
            SPF algorithm last executed 00:04:52.020 ago
            SPF algorithm executed 16 times
            Area ranges are
            Number of LSA 7. Checksum Sum 0x02C545
            Number of opaque link LSA 0. Checksum Sum 0x000000
            Number of DCbitless LSA 0
            Number of indication LSA 0
            Number of DoNotAge LSA 0
            Flood list length 0
    
    
    

    5. Cấu hình vùng Totally Stubby
    - Việc cấu hình totally stubby sẽ làm Router vùng Totally Stubby không nhận được LSA type 5 và LSA type 3. Việc này sẽ làm các route O IA không xuất hiện trên bảng định tuyến của các Router trong vùng totally Stubby.
    - Các route O IA và các route ngoại vùng O E1 hoặc O E2 sẽ được thay thế bằng 1 default-route do ABR đưa vào
    - Việc cấu hình Totally Stubby sẽ được cấu hình trên Router ABR với 1 câu lệnh rất đơn giản như sau

    [TABLE="class: outer_border, width: 500"]

    R2(config)#router ospf 1
    R2(config-router)#area 23 stub no-summary
    [/TABLE]

    - Kiểm tra bảng đinh tuyến trên R3 các bạn sẽ thấy đã không còn các route có ký hiệu O IA, O E1 hay O E2

    Code:
    
    
    [COLOR=#ff0000][B]R3# sh ip route[/B][/COLOR]
    
    
    Gateway of last resort is 10.2.2.2 to network 0.0.0.0
    
    
         33.0.0.0/24 is subnetted, 1 subnets
    C       33.33.33.0 is directly connected, Loopback33
         3.0.0.0/24 is subnetted, 1 subnets
    C       3.3.3.0 is directly connected, Loopback3
         10.0.0.0/24 is subnetted, 1 subnets
    C       10.2.2.0 is directly connected, FastEthernet0/0
    [COLOR=#ff0000]O*IA 0.0.0.0/0 [110/11] via 10.2.2.2, 00:06:11, FastEthernet0/0[/COLOR]
    
    
    
    - Nhưng R3 và R4 vẫn ping được với nhau nhờ vào Default-route mà ABR cấp cho R3

    Code:
    R3#ping 4.4.4.4
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 52/74/112 ms
    
    
    
    - Kiểm tra bảng định tuyến R4

    Code:
    [COLOR=#ff0000][B]R4#sh ip route[/B][/COLOR]
    
    Gateway of last resort is not set
    
         1.0.0.0/24 is subnetted, 1 subnets
    D EX    1.1.1.0 [170/307200] via 10.4.4.2, 00:22:35, FastEthernet0/0
         2.0.0.0/24 is subnetted, 1 subnets
    D EX    2.2.2.0 [170/307200] via 10.4.4.2, 00:22:35, FastEthernet0/0
         3.0.0.0/24 is subnetted, 1 subnets
    [COLOR=#ff0000]D EX    3.3.3.0 [170/307200] via 10.4.4.2, 00:10:41, FastEthernet0/0[/COLOR]
         4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       4.4.4.0/24 is directly connected, Loopback4
    D       4.0.0.0/8 is a summary, 00:25:03, Null0
         10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C       10.4.4.0/24 is directly connected, FastEthernet0/0
    D EX    10.2.2.0/24 [170/307200] via 10.4.4.2, 00:22:39, FastEthernet0/0
    D EX    10.1.1.0/24 [170/307200] via 10.4.4.2, 00:22:39, FastEthernet0/0
    D       10.0.0.0/8 is a summary, 00:25:05, Null0
    
    
     
  3. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48
    6. Cấu hình vùng NSSA (Not So Stubby Area)
    - Vùng NSSA có tính chất hoàn toàn giống với Stub bình thườngngoại trừ cho phép những route ngoại vùng được phân phối từ ASBR Router được đi vào trong vùng NSSA. Nó thực hiện điều này bằng cách sử dụng 1 loại LSA đặc biệt là LSA type 7
    - Các LSA type 7 khi di chuyển đến ABR sẽ được ABR chuyển đổi thành LSA type 5, từ đó được vận chuyển đi đến toàn mạng
    - Chúng ta sẽ thực hiện cấu hình NSSA cho Area 23. Vì NSSA không tương thích với Stub nên chúng ta cần bỏ các cấu hình Stub trước đó mà chúng ta đã cấu hình

    [TABLE="class: outer_border, width: 500"]

    // Cấu hình NSSA trên R2
    R2(config)#router ospf 1
    R2(config-router)#no area 23 stub
    R2(config-router)#area 23 nssa

    // Cấu hình NSSA trên R3
    R3(config)#router ospf 1
    R3(config-router)#no area 23 stub
    R3(config-router)#area 23 nssa
    [/TABLE]

    - Kiểm tra bảng định tuyến của R3

    Code:
    R3(config-router)#do sh ip route
    
    Gateway of last resort is not set
    
         1.0.0.0/24 is subnetted, 1 subnets
    O IA    1.1.1.0 [110/21] via 10.2.2.2, 00:09:42, FastEthernet0/0
         2.0.0.0/24 is subnetted, 1 subnets
    O IA    2.2.2.0 [110/11] via 10.2.2.2, 00:09:42, FastEthernet0/0
         33.0.0.0/24 is subnetted, 1 subnets
    C       33.33.33.0 is directly connected, Loopback33
         3.0.0.0/24 is subnetted, 1 subnets
    C       3.3.3.0 is directly connected, Loopback3
    [COLOR=#ff0000]O N2 4.0.0.0/8 [110/20] via 10.2.2.2, 00:09:42, FastEthernet0/0[/COLOR]
         10.0.0.0/24 is subnetted, 3 subnets
    [COLOR=#ff0000]O N2    10.4.4.0 [110/20] via 10.2.2.2, 00:09:44, FastEthernet0/0[/COLOR]
    C       10.2.2.0 is directly connected, FastEthernet0/0
    O IA    10.1.1.0 [110/20] via 10.2.2.2, 00:09:44, FastEthernet0/0
    
    
    - Bảng định tuyến của Router R2

    Code:
    R2#sh ip route
    
    Gateway of last resort is not set
    
         1.0.0.0/24 is subnetted, 1 subnets
    O       1.1.1.0 [110/11] via 10.1.1.1, 00:08:57, FastEthernet0/0
         2.0.0.0/24 is subnetted, 1 subnets
    C       2.2.2.0 is directly connected, Loopback2
         3.0.0.0/24 is subnetted, 1 subnets
    O       3.3.3.0 [110/11] via 10.2.2.3, 00:08:57, FastEthernet0/1
    D    4.0.0.0/8 [90/156160] via 10.4.4.4, 00:08:57, FastEthernet1/0
         10.0.0.0/24 is subnetted, 3 subnets
    C       10.4.4.0 is directly connected, FastEthernet1/0
    C       10.2.2.0 is directly connected, FastEthernet0/1
    C       10.1.1.0 is directly connected, FastEthernet0/0
    
    - Để sinh ra các route bên ngoài được vào vùng NSSA trên R3 các bạn thực hiện Redistribute
    [TABLE="class: outer_border, width: 500"]

    R3(config-router)#redistribute connected subnets
    [/TABLE]

    - Kiểm tra lại bảng định tuyến của R2 các bạn sẽ thấy route ngoại vùng có ký hiệu O N2 được R3 redistribute vào OSPF. Các route ngoại vùng được đưa vào vùng NSSA bằng LSA type 7 và được hiện thị trong bảng định tuyến của các Router nội vùng có ký hiệu là O N1 hoặc O N2

    Code:
    R2(config-router)#do sh ip route
    
    
    Gateway of last resort is not set
    
    
         1.0.0.0/24 is subnetted, 1 subnets
    O       1.1.1.0 [110/11] via 10.1.1.1, 00:09:30, FastEthernet0/0
         2.0.0.0/24 is subnetted, 1 subnets
    C       2.2.2.0 is directly connected, Loopback2
         33.0.0.0/24 is subnetted, 1 subnets
    [COLOR=#ff0000]O N2    33.33.33.0 [110/20] via 10.2.2.3, 00:00:04, FastEthernet0/1[/COLOR]
         3.0.0.0/24 is subnetted, 1 subnets
    O       3.3.3.0 [110/11] via 10.2.2.3, 00:09:30, FastEthernet0/1
    D    4.0.0.0/8 [90/156160] via 10.4.4.4, 00:09:30, FastEthernet1/0
         10.0.0.0/24 is subnetted, 3 subnets
    C       10.4.4.0 is directly connected, FastEthernet1/0
    C       10.2.2.0 is directly connected, FastEthernet0/1
    C       10.1.1.0 is directly connected, FastEthernet0/0
    
    
    

    - Trong bảng định tuyến R2 trên các bạn thấy route ngọai được R3 redistribute có ký hiệu là O N2.
    -
    Nhưng đối với Router R1, các bạn sẽ thấy các route ngoại vùng bây giờ được đánh dấu là O E2. Bởi vì Router ABR R2 đã thực hiện chuyển đổi route này từ LSA type 7 thành LSA type 5 và đưa đi toàn mạng

    Code:
    [B][COLOR=#ff0000]R1#sh ip route[/COLOR][/B]
    
    
    Gateway of last resort is not set
    
    
         1.0.0.0/24 is subnetted, 1 subnets
    C       1.1.1.0 is directly connected, Loopback1
         2.0.0.0/24 is subnetted, 1 subnets
    O       2.2.2.0 [110/11] via 10.1.1.2, 00:14:58, FastEthernet0/0
         33.0.0.0/24 is subnetted, 1 subnets
    [COLOR=#ff0000]O E2    33.33.33.0 [110/20] via 10.1.1.2, 00:02:04, FastEthernet0/0[/COLOR]
         3.0.0.0/24 is subnetted, 1 subnets
    O IA    3.3.3.0 [110/21] via 10.1.1.2, 00:14:58, FastEthernet0/0
    O E2 4.0.0.0/8 [110/20] via 10.1.1.2, 00:07:08, FastEthernet0/0
         10.0.0.0/24 is subnetted, 3 subnets
    O E2    10.4.4.0 [110/20] via 10.1.1.2, 00:07:10, FastEthernet0/0
    O IA    10.2.2.0 [110/20] via 10.1.1.2, 00:15:00, FastEthernet0/0
    C       10.1.1.0 is directly connected, FastEthernet0/0
    
    
    

    - Các bạn cũng có thể biến vùng NSSA thành 1 vùng NSSA totally stubby. Lúc này vùng NSSA totally Stubby sẽ không tiếp nhận LSA type 3.
    - Các Router trong vùng sẽ không thấy các route liên vùng O IA trong bảng định tuyến của nó.
    - Việc cấu hình NSSA totally Stubby hết sức đơn giản chí với câu lệnh sau trên Rouer ABR R2

    [TABLE="class: outer_border, width: 500"]

    R2(config)#router ospf 1
    R2(config-router)#area 23 nssa no-summary
    [/TABLE]

    - Kiểm tra bảng đinh tuyến của R3 các bạn sẽ thấy nó không còn các route có ký hiêu O IA như trên nữa

    Code:
    [B][COLOR=#ff0000]R3(config-router)# do sh ip route[/COLOR][/B]
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    
    Gateway of last resort is 10.2.2.2 to network 0.0.0.0
    
    
         33.0.0.0/24 is subnetted, 1 subnets
    C       33.33.33.0 is directly connected, Loopback33
         3.0.0.0/24 is subnetted, 1 subnets
    C       3.3.3.0 is directly connected, Loopback3
    O N2 4.0.0.0/8 [110/20] via 10.2.2.2, 00:19:24, FastEthernet0/0
         10.0.0.0/24 is subnetted, 2 subnets
    O N2    10.4.4.0 [110/20] via 10.2.2.2, 00:19:24, FastEthernet0/0
    C       10.2.2.0 is directly connected, FastEthernet0/0
    [COLOR=#ff0000]O*IA 0.0.0.0/0 [110/11] via 10.2.2.2, 00:00:40, FastEthernet0/0[/COLOR]
    
    
    
     

Share This Page