CCNA Lab 2.1: Lab mở rộng về Vlan và đường Trunking

Discussion in 'Lab' started by nessiggk, Jun 24, 2018.

  1. nessiggk

    nessiggk New Member

    Joined:
    Feb 25, 2018
    Messages:
    27
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 2.1: Lab mở rộng về Vlan và đường Trunking




    Tiếp tục mở rộng bài lab 2.0 cấu hình cơ bản vlan được thực hiện trên cisco packet tracer.

    Cùng với việc chia Vlan không thể không nhắc đến khái niệm Trunking. Vậy Trunking là gì? Hiểu đơn giản đó là đường dây dẫn nối 2 con switch để các vlan đi qua, các thức hoạt động của nó rất đơn giản để 2 switch nhận ra đó là vlan nào đi qua qua bằng cách gắn số vào gói tin đi qua.


    I. Các yêu cầu của bài lab

    cau hinh vlan va trunking(1)

    1. Tiếp tục thiết lập cấu hình chia vlan ở bên SW HN
    2. Cấu hình đường trunk
    3. Kiểm tra kết nối giữa các pc trong cùng vlan nhưng khác SW
    4. Chặn vlan trên đường Trunk

    I. Cấu hình vlan cho SW HN

    • Đầu tiên việc đặt địa chỉ ip cho các pc đã có hướng dẫn từ lab 2.0 rồi, nên việc đặt ip sẽ tương tự

    • Đổi tên cho SW HCM và SW HN

    • SW HCM
    Code:
    Switch>ena
    
    Switch#
    
    Switch#conf t
    
    Switch(config)#hostname SW-HCM
    
    SW-HCM(config)#
    • SW HN
    Code:
    Switch>ena
    
    Switch#conf t
    
    Switch(config)#hostname SW-HN
    
    SW-HN(config)#

    1. Cấu hình VLAN 10 – KINHDOANH trên SW-HN

    • Tương tự ta thực hiện cấu hình vlan trên SW-HN
    Code:
    SW-HN(config)#vlan 10
    
    SW-HN(config-vlan)#name KINHDOANH
    
    SW-HN(config-vlan)#exit
    
    SW-HN(config)#interface f0/2
    
    SW-HN(config-if)#switchport access vlan 10
    
    SW-HN(config-if)#

    2. Cấu hình VLAN 20 – KETOAN trên SW-HN

    Code:
    SW-HN(config)#vlan 20
    
    SW-HN(config-vlan)#name KETOAN
    
    SW-HN(config-vlan)#exit
    
    SW-HN(config)#interface f0/3
    
    SW-HN(config-if)#switchport access vlan 20
    
    SW-HN(config-if)#
    3. Cấu hình VLAN 30 – ADMIN trên SW-HN

    Code:
    SW-HN(config)#vlan 30
    
    SW-HN(config-vlan)#name ADMIN
    
    SW-HN(config-vlan)#exit
    
    SW-HN(config)#interface f0/4
    
    SW-HN(config-if)#switchport access vlan 30
    
    SW-HN(config-if)#
    • Kiểm tra ta đã tạo vlan thành công hay chưa
    cau hinh vlan va trunking(2)

    4. Thử thực hiện lệnh ping pc1 -> pc10 trong cùng vlan 10 mà ta đã tạo

    cau hinh vlan va trunking(3)

    • Không thể thực hiện lệnh ping từ pc1 -> pc10 mặc dù trong cùng vlan. Đó là lí do ta cần cấu hình đường Trunk

    III. Cấu hình Trunking

    • Việc cấu hình đường trunk ta cần thực hiện trên cổng có kết nối trunk để chuyển đổi sang mode trunk, mặc định là mode vlan. Ở đây ta cần thực hiện thiết lập đường trunk giữa SW-HCM và SW-HN giữa 2 cổng kết nối f0/7 của SW-HCM và f0/1 của SW-HN

    • SW-HCM: Vào interface f/7 để set mode trunk
    Code:
    SW-HCM(config)#interface f0/7
    
    SW-HCM(config-if)#switchport mode trunk
    
    SW-HCM(config-if)#
    • Kiểm tra việc lên đường trunk ở SW-HCM thành công hay chưa?
    Code:
    SW-HCM#show interface trunk
    cau hinh vlan va trunking(4)

    • SW-HN: Vào mode conf của cổng f0/1 set mode trunk
    Code:
    SW-HN(config)#int f0/1
    
    SW-HN(config-if)#sw mode trunk
    
    SW-HN(config-if)#
    • Tương tự kiểm tra đường trunk ở SW-HN
    cau hinh vlan va trunking(5)


    • Việc tạo đường trunk đã hoàn tất, giờ ta sẽ kiểm tra giao tiếp giữa các pc trong cùng vlan nhưng khác SW.

    IV. Kiểm tra giao tiếp giữa các pc trong cùng vlan nhưng khác SW

    1. VLAN 10 - KINHDOANH

    • PC0 -> PC10 : Thành công
    Code:
    Ping 192.168.1.10
    cau hinh vlan va trunking(6)


    2. VLAN 20 – KETOAN

    • Ping PC2 -> PC20: Thành công
    Code:
    Ping 192.168.2.10
    cau hinh vlan va trunking(7)


    3. VLAN 30 – ADMIN

    • Ping PC4 -> PC 30 -> Thành công
    Code:
    Ping 192.168.3.10
    cau hinh vlan va trunking(8)


    • Sau khi đã thiết lập ở 2 SW-HCM và SW-HN thì các PC trong cùng VLAN ở SW riêng biệt đã giao tiếp được với nhau.

    V. Chặn vlan trên đường Trunk
    • Sau khi đã tạo đường trunk việc giao tiếp các máy trong cùng vlan ở 2 SW khác nhau đã dễ dàng hơn, nhưng khi ta cần loại bỏ kết nối giữa 2 vlan ở SW khác thì ta sẽ làm sao?

    • Việc thực hiện loại bỏ vlan trên đường trunk cần thực hiện trên cả 2 con SW (để đồng nhất). Ở SW-HN để loại bỏ Vlan 10. (mặc định đường trunk sẽ chấp nhập tất cả các vlan đi qua). Vào mode configuration của cổng đã thiết lập trunk f0/1.
    Code:
    SW-HN>ena
    
    SW-HN#conf t
    
    SW-HN(config)#interface f0/1
    
    SW-HN(config-if)#switchport trunk allowed vlan 20,30
    
    SW-HN(config-if)#
    • Ở SW-HCM ta cũng cần loại bỏ Vlan 10. Tương tự vào cổng đã thiết lập trunk ở đây là f0/7
    Code:
    SW-HCM>ena
    SW-HCM#conf t
    SW-HCM(config)#interface f0/7
    SW-HCM(config-if)#sw trunk allow vlan remove 10
    SW-HCM(config-if)#^Z
    SW-HCM#
    • Ngoài ra còn một câu lệnh khác như
    Code:
    SW-HN(config-if)#sw trunk allowed vlan remove 10
    • Sau khi loại bỏ vlan đó ra khỏi đường Trunk ta có thêm vào lại
    Code:
    SW-HN(config-if)#switchport trunk allowed vlan add 10
    • Kiểm tra xem việc loại bỏ vlan 10 ra khỏi đường trunk đã thành công hay chưa
    Code:
    SW-HN#show interface trunk
    cau hinh vlan va trunking(9)

    Code:
    SW-HCM#show interface trunk
    Port        Mode         Encapsulation  Status        Native vlan
    Fa0/7       on           802.1q         trunking      1
    
    Port        Vlans allowed on trunk
    Fa0/7       1-9,11-1005
    
    Port        Vlans allowed and active in management domain
    Fa0/7       1,20,30
    
    Port        Vlans in spanning tree forwarding state and not pruned
    Fa0/7       none
    
    SW-HCM#

    • Thực hiện lại lệnh ping từ pc1 -> pc10
    Code:
    Ping 192.168.1.10
    cau hinh vlan va trunking(10)

    OK Xong :););)
     
    Last edited: Jun 24, 2018

Share This Page