CCNA [Lab 15] Cấu hình IPv6 trên Router Cisco

Discussion in 'Lab' started by root, Jan 17, 2014.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    51
    Trophy Points:
    48

    Cấu hình IPv6 trên Router Cisco


    Lab cấu hình IPv6 trên Router Cisco: Trong bài lab này chúng ta sẽ cài đặt IPv6 trên các interface của Router và các PC trong LAN.
    Sau đó chúng ta sẽ cấu hình các giao thức định tuyến động trên các Router trên nền IPv6. Việc cấu hình định tuyến IPv6 không khác gì nhiều với việc cấu hình định tuyến động trên IPv4.


    I. Sơ đồ triển khai lab Cấu hình IPv6 trên Router Cisco


    1. Sơ đồ
    - Đây là mô hình bài lab cấu hình IPv6 trên Router Cisco và cấu hình định tuyến động trên các Router sử dụng IPv6

    cau hinh IPv6 tren Router Cisco(1)

    2. Yêu cầu

    • Thiết lập sơ đồ
    • Kết nối các thiết bị theo mô hình vag gán IPv6 theo mô hình
    • Hội tụ mạng lần lượt với các giao thức:
      • Static route
      • RIPng
      • OSPF
      • EIGRP

    II. Triển khai Lab cấu hình IPv6 trên Router Cisco

    1. Đặt IPv6 theo sơ đồ
    - Cấu hình IPv6 trên Router R1.

    R1(config)#ipv6 unicast-routing //câu lệnh phải có để chạy IPv6 R1(config)#interface gigabitEthernet 0/0
    R1(config-if)#ipv6 address 12::1/64
    R1(config-if)#no shutdown
    R1(config)#interface gigabitEthernet 0/1
    R1(config-if)#ipv6 address 13::1/64
    R1(config-if)#no shutdown
    R1(config)#interface loopback 1
    R1(config-if)#ipv6 address 1:1:1:1::1/64​

    - Tương tự chúng ta cấu hình IPv6 trên Router R2
    Code:
    R2(config)#ipv6 unicast-routing
    R2(config)#interface g0/0
    R2(config-if)#ipv6 address 12::2/64
    R2(config-if)#no shutdown
    R2(config)#interface g0/1
    R2(config-if)#ipv6 address 23::2/64
    R2(config-if)#no shutdown
    R2(config)#interface gigabitEthernet 0/2
    R2(config-if)#ipv6 address 22::254/64
    R2(config-if)#no shutdown
    R2(config)#interface loopback 2
    R2(config-if)#ipv6 address 2:2:2:2::2/64
    - Cấu hình IPv6 trên Router R3
    Code:
    R3(config)#ipv6 unicast-routing
    R3(config)#interface g0/0
    R3(config-if)#ipv6 address 13::3/64
    R3(config-if)#no shutdown
    R3(config)#interface g0/1
    R3(config-if)#ipv6 address 23::1/64
    R3(config-if)#no shutdown
    R3(config)#interface g0/2
    R3(config-if)#ipv6 address 33::3/64
    R3(config)#interface loopback 3
    R3(config-if)#ipv6 address 3:3:3:3::3/64
    - Trên R1 ta ping kiểm tra R2 và R3

    cau hinh IPv6 tren Router Cisco(2)

    2. Cấu hình DHCP IPv6 cấp IP cho Lan của Router R2 và R3

    - Trên R2 ta cấu hình DHCP cấp IPv6 cho pc
    Code:
    R2(config)#ipv6 local pool LAN2 22::/48 64
    R2(config)#ipv6 dhcp pool LAN2
    R2(config-dhcp)#do sh ipv6 dhcp
    This device's DHCPv6 unique identifier (DUID): 000300010030F2829601
    R2(config-dhcp)#prefix-delegation 33::254/64 000300010030F2829601
    R2(config-dhcp)#dns-server 22::254
    R2(config-if)#ipv6 dhcp server LAN2

    - Trên R3 ta cấu hình DHCP cấp IPv6 cho pc
    Code:
    R3(config)#ipv6 local pool LAN3 33::/48 64
    R3(config)#ipv6 local pool LAN3
    R3(config)#ipv6 dhcp pool LAN3
    R3(config-dhcp)#do sh ipv6 dhcp

    This device's DHCPv6 unique identifier (DUID): 0003000100E0A306BE01

    Code:
    R3(config-dhcp)#prefix-delegation 33::254/64 0003000100E0A306BE01
    R3(config-dhcp)#dns-server 33::254
    R3(config-if)#ipv6 dhcp server LAN3
    - Kiểm tra trên PC2 của R3 ta thấy pc đã nhận được DHCP

    cau hinh IPv6 tren Router Cisco(3)

    3. Cấu hình Static Route IPv6

    -
    cấu hình định tuyến static route trên các router R1

    R1(config)#ipv6 route 23::/64 12::2
    R1(config)#ipv6 route 23::/64 13::3
    R1(config)#ipv6 route 2:2:2:2::/64 12::2
    R1(config)#ipv6 route 3:3:3:3::/64 13::3
    R1(config)#ipv6 route 22::/64 12::2
    R1(config)#ipv6 route 33::/64 13::3
    R1(config)#ipv6 route 2:2:2:2::/64 13::3 128 //cấu hình đường dự phòng với AD=128
    R1(config)#ipv6 route 3:3:3:3::/64 12::2 128
    R1(config)#ipv6 route 22::/64 13::3 128
    R1(config)#ipv6 route 33::/64 12::2 128​

    - cấu hình định tuyến static route trên các router R2
    Code:
    R2(config)#ipv6 route 13::/64 12::1
    R2(config)#ipv6 route 13::/64 23::3
    R2(config)#ipv6 route 1:1:1:1::/64 12::1
    R2(config)#ipv6 route 3:3:3:3::/64 23::3
    R2(config)#ipv6 route 33::/64 23::3
    R2(config)#ipv6 route 1:1:1:1::/64 23::3 128
    R2(config)#ipv6 route 3:3:3:3::/64 12::1 128
    R2(config)#ipv6 route 33::/64 12::1 128

    - cấu hình định tuyến static route trên các router R3
    Code:
    R3(config)#ipv6 route 12::/64 13::1
    R3(config)#ipv6 route 12::/64 23::2
    R3(config)#ipv6 route 1:1:1:1::/64 13::1
    R3(config)#ipv6 route 2:2:2:2::/64 23::2
    R3(config)#ipv6 route 22::/64 23::2
    R3(config)#ipv6 route 1:1:1:1::/64 23::2 128
    R3(config)#ipv6 route 2:2:2:2::/64 13::1 128
    R3(config)#ipv6 route 22::/64 13::1 128
    - Kiểm tra bảng định tuyến R1

    cau hinh IPv6 tren Router Cisco(4)

    - Từ R1 ping mạng 23::/64 và Loopback R2

    cau hinh IPv6 tren Router Cisco(5)


    4. Cấu hình RIPng IPv6

    - Cấu hình RIPng IPv6 trên Router R1

    R1(config)#no ipv6 route 2:2:2:2::/64 //tắt đinh tuyến Static Route
    R1(config)#no ipv6 route 3:3:3:3::/64
    R1(config)#no ipv6 route 22::/64
    R1(config)#no ipv6 route 23::/64
    R1(config)#no ipv6 route 33::/64
    R1(config)#ipv6 router rip 1 // bật static route trên router
    R1(config)#int g0/0
    R1(config-if)#ipv6 rip 1 enable // bật static route trên interface
    R1(config)#int g0/1
    R1(config-if)#ipv6 rip 1 enable
    R1(config)#int loopback 1
    R1(config-if)#ipv6 rip 1 enable​

    - Cấu hình RIPng IPv6 trên Router R2
    Code:
    R2(config)#no ipv6 route 1:1:1:1::/64
    R2(config)#no ipv6 route 3:3:3:3::/64
    R2(config)#no ipv6 route 13::/64
    R2(config)#no ipv6 route 33::/64
    R2(config)#ipv6 router rip 1
    R2(config)#int g0/0
    R2(config-if)#ipv6 rip 1 enable
    R2(config)#int g0/1
    R2(config-if)#ipv6 rip 1 enable
    R2(config)#int loopback 2
    R2(config-if)#ipv6 rip 1 enable

    - Cấu hình RIPng IPv6 trên Router R3
    Code:
    R3(config)#no ipv6 route 1:1:1:1::/64
    R3(config)#no ipv6 route 2:2:2:2::/64
    R3(config)#no ipv6 route 12::/64
    R3(config)#no ipv6 route 22::/64
    R3(config)#ipv6 router rip 1
    R3(config)#int g0/0
    R3(config-if)#ipv6 rip 1 enable
    R3(config)#int g0/1
    R3(config-if)#ipv6 rip 1 enable
    R3(config)#int loopback 3
    R3(config-if)#ipv6 rip 1 enable

    - Kiểm tra bảng định tuyến của R1

    cau hinh IPv6 tren Router Cisco(6)

    - Từ pc2 ping R1

    cau hinh IPv6 tren Router Cisco(7)


    5. Cấu hình OSPF IPv6

    - Cấu hình OSPF IPv6 trên R1

    R1(config)#no ipv6 router rip 1
    R1(config)#ipv6 router ospf 10
    R1(config-rtr)#router-id 1.1.1.1 //cần có router-id để chạy OSPF
    R1(config)#interface g0/0
    R1(config-if)#ipv6 ospf 10 area 0
    R1(config-if)#exit
    R1(config)#int g0/1
    R1(config-if)#ipv6 ospf 10 area 0
    R1(config-if)#exit
    R1(config)#int loopback 1
    R1(config-if)#ipv6 ospf 10 area 0​

    - Cấu hình OSPF IPv6 trên R2
    Code:
    R2(config)#ipv6 router ospf 20
    R2(config-rtr)#router-id 2.2.2.2
    R2(config-rtr)#exit
    R2(config)#int g0/0
    R2(config-if)#ipv6 ospf 20 area 0
    R2(config-if)#exit
    R2(config)#int g0/1
    R2(config-if)#ipv6 ospf 20 area 0
    R2(config-if)#exit
    R2(config)#int g0/2
    R2(config-if)#ipv6 ospf 20 area 0
    R2(config-if)#exit
    R2(config)#int loopback 2
    R2(config-if)#ipv6 ospf 20 area 0
    - Cấu hình OSPF IPv6 trên R3
    Code:
    R3(config)#ipv6 router ospf 20
    R3(config-rtr)#router-id 3.3.3.3
    R3(config-rtr)#exit
    R3(config)#int g0/0
    R3(config-if)#ipv6 ospf 20 area 0
    R3(config-if)#exit
    R3(config)#int g0/1
    R3(config-if)#ipv6 ospf 20 area 0
    R3(config-if)#exit
    R3(config)#int g0/2
    R3(config-if)#ipv6 ospf 20 area 0
    R3(config-if)#exit
    R3(config)#int loopback 2
    R3(config-if)#ipv6 ospf 20 area 0
    - Kiểm tra bảng định tuyến R1

    cau hinh IPv6 tren Router Cisco(8)

    6. Cấu hình EIGRP IPv6

    - Cấu hình EIGRP IPv6 trên Router R1

    R1(config)#no ipv6 router ospf 10
    R1(config)#ipv6 router eigrp 1
    R1(config-rtr)#router-id 1.1.1.1
    R2(config-rtr)#no shutdown //Trong EIGRP mặc định là shutdown nên ta cần no shut EIGRP

    Code:
    R1(config-rtr)#exit
    R1(config)#int g0/0
    R1(config-if)#ipv6 eigrp 1
    R1(config-if)#exit
    R1(config)#int g0/1
    R1(config-if)#ipv6 eigrp 1
    R1(config-if)#exit
    R1(config)#int loopback 1
    R1(config-if)#ipv6 eigrp 1
    
    R1(config-rtr)#exit
    R1(config)#int g0/0
    R1(config-if)#ipv6 eigrp 1
    R1(config-if)#exit
    R1(config)#int g0/1
    R1(config-if)#ipv6 eigrp 1
    R1(config-if)#exit
    R1(config)#int loopback 1
    R1(config-if)#ipv6 eigrp 1

    - Cấu hình EIGRP IPv6 trên Router R2
    Code:
    R2(config)#no ipv6 router ospf 10
    R2(config)#ipv6 router eigrp 1
    R2(config-rtr)#router-id 2.2.2.2
    R2(config-rtr)#no shutdown
    R2(config-rtr)#exit
    R2(config)#int g0/0
    R2(config-if)#ipv6 eigrp 1
    R2(config-if)#exit
    R2(config)#int g0/1
    R2(config-if)#ipv6 eigrp 1
    R2(config-if)#exit
    R2(config)#int loopback 1
    R2(config-if)#ipv6 eigrp 1
    - Cấu hình EIGRP IPv6 trên Router R3
    Code:
    R3(config)#no ipv6 router ospf 10
    R3(config)#ipv6 router eigrp 1
    R3(config-rtr)#router-id 3.3.3.3
    R3(config-rtr)#no shutdown
    R3(config-rtr)#exit
    R3(config)#int g0/0
    R3(config-if)#ipv6 eigrp 1
    R3(config-if)#exit
    R3(config)#int g0/1
    R3(config-if)#ipv6 eigrp 1
    R3(config-if)#exit
    R3(config)#int loopback 1
    R3(config-if)#ipv6 eigrp 1
    - Kiểm tra bảng định tuyến

    cau hinh IPv6 tren Router Cisco(9)
     
    Last edited: Jul 25, 2016
  2. khoa.ntk01

    khoa.ntk01 New Member

    Joined:
    Jan 4, 2015
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    mất luôn ảnh rồi, up lại giúp em nha root
     
  3. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    51
    Trophy Points:
    48
    hi bạn,

    Đã upload xong hình bài lab này. CHúc bạn làm lab vui vẻ

    Thanks,
     

Share This Page