CCNA [Lab 14] configuring EtherChannel and 802.1Q Trunking

Discussion in 'Lab' started by root, Mar 14, 2014.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    52
    Trophy Points:
    48

    Configuring Etherchannel and 802.1Q Trunking


    Lab Configuring EtherChannel and 802.1Q Trunking: Trong bài lab này chúng ta sẽ cấu hình Etherchannel để group port trên Switch tạo thành port-channel.
    Sau khi cấu hình EtherChannel trên các Switch chúng ta sẽ cấu hình trunking giữa các Switch thông qua port-channel.
    Ngoài ra chúng ta sẽ dựa trên các bài lab cấu hình Access Control List để xây dựng các chính sách cho hệ thống này.

    I. Sơ đồ và yêu cầu Lab configuring EtherChannel and 802.1Q Trunking


    1. Sơ đồ:
    - Mô hình bài lab cấu hình Etherchannel and 802.1Q trunking giữa các Switch layer 3.

    configuring EtherChannel and 802.1Q Trunking

    2. Yêu cầu:
    - Các thiết bị đóng vai trò làm end user bao gồm: PC1 và PC2
    - Hệ thống VTP được triển khai như sau:

    • Distribute_SW làm transparent
    • Access_SW1 làm Server
    • Access_SW2 làm client
    - Kết nối giữa Core_SW và Distribute_SW là layer 3
    - Cấu hình EtherChannel theo yêu cầu

    • yêu cầu test thử các mode và kiểm tra kết quả
    - PC1 thuộc VLAN 10, PC2 thuộc VLAN 20
    - Đảm bảo hệ thống hội tụ
    - Distribute_SW cấu hình telnet. Kiểm tra kết quả telnet từ các VLAN
    - Điều chỉnh PC1 và PC2 cung VLAN
    - Áp dụng chính sách:

    • cấm PC2 telnet đến Distribute_SW
    • PC1, PC2 không ping được nhau
    • các traffic khác đều bình thường
    - Core_SW cấu hình DHCP cho cả 2 PC và cấu hình SSH

    Lưu ý: Bài lab không thực hiện được trên GNS3 0.86 và Packet tracer vì không hỗ trợ EtherChannel Layer 3

    - tham khảo thêm các bài lab liên quan.

    1. [Lab 9] Cấu hình inter vlan trên Router Cisco
    2. [Lab 9.1] Cấu hình inter vlan switch layer 3
    3. [Lab 11] Cấu hình Access Control List
    4. [Lab 11.1] Cấu hình Access List cho Router
    - Các bài lý thuyết tham khảo:
    1. [Bài 17] Cấu hình VLAN trunking và VTP Cisco
    2. [Bài 18] Cisco Multilayer Switch Network Diagram
    3. [Bài 20] Hướng dẫn cấu hình ACL Router Cisco
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Aug 4, 2016
  2. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    52
    Trophy Points:
    48

    II. Triển khai Lab configuring EtherChannel and 802.1Q Trunking


    1. Access-SW1
    // Cấu hình VTP và VLAN
    Code:
    Access_SW1-SW(config)#hostname Access_SW1
    Access_SW1(config)#vtp mode server
    Access_SW1(config)#vtp domain svuit
    Access_SW1(config)#vtp password 123
    Access_SW1(config)#vlan 10
    Access_SW1(config-vlan)#vlan 20

    // EtherChannel trên layer 2
    Code:
    Access_SW1(config)#interface range f0/5-6
    Access_SW1(config-if-range)#channel-group 1 mode on

    // Cấu hình port-channel layer 2 lên trunk để đồng bộ VLAN
    Code:
    Access_SW1(config-if-range)#interface port-channel 1
    Access_SW1(config-if)#switchport trunk encapsulation dot1q
    Access_SW1(config-if-range)#switchport mode trunk

    // Gán port Switch cho từng VLAN
    Code:
    Access_SW1(config-if-range)#interface range f0/1-4
    Access_SW1(config-if-range)#switchport mode access
    Access_SW1(config-if-range)#switchport access vlan 10
    Access_SW1(config-if-range)#interface range f0/7-15
    Access_SW1(config-if-range)#switchport mode access
    Access_SW1(config-if-range)#switchport access vlan 20
    2. Access-Sw2
    // Cấu hình VTP
    Code:
    Access_Sw2(config)#hostname Access_SW2
    Access_SW2(config)#vtp mode client
    Access_SW2(config)#vtp domain svuit
    Access_SW2(config)#vtp password 123

    // Cấu hình EtherChannel trên layer 2
    Code:
    Access_SW2(config)#interface range f0/9-10
    Access_SW2(config-if-range)#channel-group 2 mode on

    // Lên trunk cho port-channel để đồng bộ VLAN
    Code:
    Access_SW2(config-if-range)#interface port-channel 2
    Access_SW2(config-if)#switchport trunk encapsulation dot1q
    Access_SW2(config-if)#switchport mode trunk

    // Gán port Switch cho từng VLAN
    Code:
    Access_SW2(config-if-range)#interface range f1/0-5
    Access_SW2(config-if-range)#switchport mode access
    Access_SW2(config-if-range)#switchport access vlan 10
    Access_SW2(config-if-range)#interface range f0/-8
    Access_SW2(config-if-range)#switchport mode access
    Access_SW2(config-if-range)#switchport access vlan 20
    3. Distribute_SW
    // Cấu hình VTP
    Code:
    Distribute_SW(config)#hostname Distribute_SW
    Distribute_SW(config)#vtp mode transparent
    Distribute_SW(config)#vtp domain svuit
    Distribute_SW(config)#vtp password 123

    // Cấu hình Etherchannel trên layer 3
    Code:
    Distribute_SW(config)interface range f0/1-2
    Distribute_SW(config-if-range)#no switchport
    Distribute_SW(config-if-range)#channel-group 3 mode on

    // Cấu hình EtherChannel trên Layer 2
    Code:
    Distribute_SW(config-if-range)#interface range f0/5-6
    Distribute_SW(config-if-range)#channel-group 1 mode on
    Distribute_SW(config-if-range)#interface range f0/9-10
    Distribute_SW(config-if-range)#channel-group 2 mode on

    // Cấu hình port-channel layer 2 lên trunk
    Code:
    Distribute_SW(config-if-range)#int port-channel 1
    Distribute_SW(config-if)#switchport trunk encapsulation dot1q
    Distribute_SW(config-if)#switchport mode trunk
    Distribute_SW(config-if)#int port-channel 2
    Distribute_SW(config-if)#switchport trunk encapsulation dot1q
    Distribute_SW(config-if)#switchport mode trunk

    // Cấu hình port-channel layer 3 đặt IP cho port-channel
    Code:
    Distribute_SW(config-if)#int port-channel 3
    Distribute_SW(config-if)#ip address 10.0.0.2 255.255.255.0

    // Cấu hình IP cho các VLAN
    Code:
    Distribute_SW(config-if)#int vlan 10
    Distribute_SW(config-if)#ip address 192.168.10.254 255.255.255.0
    Distribute_SW(config-if)#int vlan 20
    Distribute_SW(config-if)#ip address 192.168.20.254 255.255.255.0

    // Định tuyến OSPF trong LAN
    Code:
    Distribute_SW(config)#ip routing
    Distribute_SW(config)#router ospf 1
    Distribute_SW(config-route)#network 10.0.0.0 0.0.0.255 area 0
    Distribute_SW(config-route)#network 192.168.10.0 0.0.0.255 area 0
    Distribute_SW(config-route)#network 192.168.20.0 0.0.0.255 area 0
    4. Core_SW
    // Cấu hình EtherChannel tạo port-channel trên layer 3
    Code:
    Core_SW(config)#hostname Core_SW
    Core_SW(config)interface range f0/1-2
    Core_SW(config-if-range)#no switchport
    Core_SW(config-if-range)#channel-group 3 mode on
    Core_SW(config-if-range)#interface port-channel 3
    Core_SW(config-if)#ip address 10.0.0.1 255.255.255.0

    // Tạo DHCP cấp cho các VLAN
    Code:
    Core_SW(config)#ip dhcp pool VLAN10
    Core_SW(dhcp-config)#network 192.168.10.0 255.255.255.0
    Core_SW(dhcp-config)#default-router 192.168.10.254
    Core_SW(dhcp-config)#dns-server 8.8.8.8 8.8.4.4
    Core_SW(dhcp-config)#exit
    Core_SW(config)#ip dhcp pool VLAN20
    Core_SW(dhcp-config)#network 192.168.20.0 255.255.255.0
    Core_SW(dhcp-config)#default-router 192.168.20.254
    Core_SW(dhcp-config)#dns-server 8.8.8.8 8.8.4.4

    // Định tuyến OSPF trong LAN
    Code:
    Core_SW(config)#ip routing
    Core_SW(config)#router ospf 1
    Core_SW(config-router)#network 10.0.0.0 0.0.0.255 area 0
     
    Last edited: Jul 25, 2016
    baogum likes this.
  3. tranvoluong

    tranvoluong New Member

    Joined:
    Feb 2, 2016
    Messages:
    4
    Likes Received:
    3
    Trophy Points:
    3
    root làm bài này chưa đạt
     
    root likes this.
  4. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    52
    Trophy Points:
    48
    Cảm ơn bạn đã quan tâm và đánh giá. Nhờ bạn bổ sung thêm nhé.
     
    baogum likes this.

Share This Page