CCNA [Lab 13] Cấu hình HSRP CISCO

Discussion in 'Lab' started by root, Mar 11, 2014.

  1. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38

    Cấu hình HSRP CISCO


    Lab cấu hình HSRP cisco: Trên các Router chúng ta sẽ cấu hình để tạo ra một Router gateway ảo làm gateway cho mạng LAN để dự phòng gateway cho hệ thống. Khi có một Router bị failed thì hệ thống vẫn hoạt động bình thường thông qua các Router còn lại. Chúng ta sẽ chọn giao thức HSRP để triển khai tính năng dự phòng nêu trên. Ngoài ra chúng ta cũng sẽ cấu hình track cho giao thức HSRP.

    I. Mô hình và Yêu cầu lab cấu hình HSRP


    1. Mô hình
    - Mô hình bài lab cấu hình HSRP trên Router Cisco

    cau hinh HSRP Cisco

    2. Yêu cầu:
    - Thiết bị

    • R1, R2, R3 sử dụng dòng 28xx(vì chỉ có dòng 28xx mới hỗ trợ HSRP, VRRP, GLBP). Router 26xx và Cat 3550 chỉ hỗ trợ HSRP
    • Switch 2950
    - Cấu hình
    • IP theo mô hình
    • OSPF để mạng liên thông
    - Cấu hình HSRP giữa 3 Router để
    • Virtual IP : 192.168.123.254
    • R1 là Active Router
    • R2 là Standby Router
    • Cấu hình chứng thực md5 cho 3 Router với password svuit
    • R1,R2,R3 có khả năng trở thành Active Router nếu có độ ưu tiên cao hơn(cấu hình preempt)
    • Đảm bảo khi interface s1/0 của R1 down/down, R2 trở thành Active Router thay cho R1(cấu hình track interface)
    • Đảm bảo khi interface s1/1 của R2 down/down, R3 trở thành Active Router thay cho R2(cấu hình track interface)
    • Đảm bảo khi interface s1/0 của R1 bị mất địa chỉ IP(interface up/up nhưng không có địa chỉ IP), R2 trở thành Active Router thay cho R1(cấu hình track object interface)
    • Đảm bảo khi interface s1/1 của R2 bị mất địa chỉ IP(interface up/up nhưng không có địa chỉ IP), R3 trở thành Active Router thay cho R2(cấu hình track object interface)
    • Đảm bảo khi R1 mất default-route trong routing table, R2 trở thành Active Router thay cho R1(cấu hình track object interface)
    • Đảm bảo khi R2 mất default-route trong routing table, R3 trở thành Active Router thay cho R2(cấu hình track object interface)
    • Sw kết nối với 150 user, cấu hình HSRP để loadbalance giữa R1,R2,R3( Cấu hình 3 group, mỗi Router Active cho 1 Group) Virtual IP cho mỗi group như sau:
      • Group 1: 192.168.123.254
      • Group 2: 192.168.123.253
      • Group 3: 192.168.123.252
    - tham khảo thêm các bài lab liên quan.
    1. [Lab 13.1] Cấu hình HSRP and Spanning tree root
    2. [Lab 14] Cấu hình EtherChannel Layer 2 và Layer 3
    3. [Lab 12] Lab cấu hình NAT cho Router Cisco
    - Các bài lý thuyết tham khảo:
    1. [Bài 22] Tìm hiểu giao thức HSRP
    2. [Bài 23] Hướng dẫn cấu hình EtherChannel
    3. [Bài 21] Tìm hiểu về Network Address Translation
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Aug 4, 2016
  2. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38

    II. Triển khai lab cấu hình HSRP CISCO


    1. Cấu hình IP và Routing
    - Router ISP

    // Đặt IP trên các interface
    Code:
    ISP(config)#interface f0/0
    ISP(config-if)#ip address dhcp
    ISP(config-if)#no shutdown
    ISP(config-if)#interface s1/0
    ISP(config-if)#ip address 192.168.14.2 255.255.255.0
    ISP(config-if)#no shutdown
    ISP(config-if)#interface s1/1
    ISP(config-if)#ip address 192.168.24.2 255.255.255.0
    ISP(config-if)#no shutdown
    ISP(config-if)#interface s1/2
    ISP(config-if)#ip address 192.168.34.2 255.255.255.0
    ISP(config-if)#no shutdown

    // Routing OSPF

    Code:
    ISP(config)#router ospf 1
    ISP(config-router)#network 192.168.14.0 0.0.0.255 area 0
    ISP(config-router)#network 192.168.24.0 0.0.0.255 area 0
    ISP(config-router)#network 192.168.34.0 0.0.0.255 area 0
    ISP(config-router)#default-information originate

    // NAT để LAN có thể ra internet

    Code:
    ISP(config)#access-list 1 permit any
    ISP(config)#ip nat inside source list 1 interface f0/0 overload
    ISP(config)#interface f0/0
    ISP(config-if)#ip nat outside
    ISP(config-if)#interface s1/0
    ISP(config-if)#ip nat inside
    ISP(config-if)#interface s1/1
    ISP(config-if)#ip nat inside
    ISP(config-if)#interface s1/2
    ISP(config-if)#ip nat inside

    - Router R1
    Code:
    R1(config)#interface s1/0
    R1(config-if)#ip address 192.168.14.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#interface f0/0
    R1(config-if)#ip address 192.168.123.1 255.255.255.0
    R1(config-if)#no shutdown
    
    R1(config-if)#router ospf 1
    R1(config-router)#network 192.168.14.0 0.0.0.255 area 0
    R1(config-router)#network 192.168.123.0 0.0.0.255 area 0
    - Router R2
    Code:
    R2(config)#interface s1/1
    R2(config-if)#ip address 192.168.24.1 255.255.255.0
    R2(config-if)#no shutdown
    R2(config-if)#interface f0/0
    R2(config-if)#ip address 192.168.123.2 255.255.255.0
    R2(config-if)#no shutdown
    
    R2(config-if)#router ospf 1
    R2(config-router)#network 192.168.24.0 0.0.0.255 area 0
    R2(config-router)#network 192.168.123.0 0.0.0.255 area 0

    - Router R3
    Code:
    R3(config)#interface s1/2
    R3(config-if)#ip address 192.168.34.1 255.255.255.0
    R3(config-if)#no shutdown
    R3(config-if)#interface f0/0
    R3(config-if)#ip address 192.168.123.3 255.255.255.0
    R3(config-if)#no shutdown
    
    R3(config-if)#router ospf 1
    R3(config-router)#network 192.168.34.0 0.0.0.255 area 0
    R3(config-router)#network 192.168.123.0 0.0.0.255 area 0
    Hệ thống mạng LAN đã ra được Internet

    2. Cấu hình HSRP
    - Virtual IP : 192.168.123.254


    // Trên Router R1
    Code:
    R1(config)#interface f0/0
    R1(config-if)#standby 1 priority 150

    // Trên Router R2

    Code:
    R2(config)#interface f0/0
    R2(config-if)#standby 1 priority 120

    // Trên Router R3

    Code:
    R3(config)#interface f0/0
    R3(config-if)#standby 1 ip 192.168.123.254

    - R1 là Active Router
    // R1 là Active Router nên có priority cao nhât
    Code:
    R1(config)#interface f0/0
    R1(config-if)#standby 1 priority 150

    - R2,R3 là Standby Router
    // R2 là Standby Router nên có priority thấp hơn R1
    Code:
    R2(config)#interface f0/0
    R2(config-if)#standby 1 priority 120

    // R3 là standby router mặc định priority =100 < R1 nên ko cần sửa cũng được

    - R1,R2,R3 có khả năng trở thành Active Router nếu có độ ưu tiên cao hơn(cấu hình preempt)
    • Ở đây nếu ta không cấu hình tính năng "preempt" cho các Router thì khi R1 chết, R2 lên làm Active thì khi R1 sống lại cũng không thể là Active nữa mặc dù R1 có priority cao hơn R2.
    • Vì mặc định HSRP chạy trên các Router là "non-preempt" nghĩa là không cho chiếm quyền
    • Nên ta cần cấu hình "preempt" nếu mạng của bạn có nhu cầu đường đi internet luôn là đường có priority cao nhất
    //Cấu hình preempt trên R1
    Code:
    R1(config)#interface f0/0
    R1(config-if)#standby 1 preempt

    //Cấu hình preempt trên R2

    Code:
    R2(config)#interface f0/0
    R2(config-if)#standby 1 preempt

    //Cấu hình preempt trên R3

    Code:
    R3(config)#interface f0/0
    R3(config-if)#standby 1 preempt

    * Kiểm tra kết quả
    - Sau khi cấu hình xong HSRP thì R1 sẽ là Active Router nên PC sẽ ra internet thông qua R1

    cau hinh HSRP Cisco(1)


    - Khi R1 chết, R2 sẽ lên làm Active Router vì có prioprity cao nhất

    cau hinh HSRP Cisco(2)

    - Lúc này PC sẽ ra internet thông qua R2

    cau hinh HSRP Cisco(3)
     
    Last edited: Jul 25, 2016
  3. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38

    2. Cấu hình HSRP CISCO


    - Đảm bảo khi interface s1/0 của R1 down/down, R2 trở thành Active Router thay cho R1(cấu hình track interface)
    • Cấu hình track interface s1/0 của R1, trừ priority của R1 < R2,R3 để R2,R3 lên làm Active khi s1/0 của R1 bị down/down
    // khi s1/0 down/down thì priority R1 = 150 -70 = 80
    R1(config-if)#standby 1 track s1/0 70!

    // khi s1/1 down/down thì priority R2 = 120 -50 = 70
    R2(config-if)#standby 1 track s1/1 50!

    • Lúc này khi R1 down thì R1 sẽ có priority là: 150-70 = 80 nên lúc này R1 sẽ không còn là Active router nữa
    cau hinh HSRP Cisco(4)

    - Đảm bảo khi interface s1/1 của R2 down/down, R3 trở thành Active Router thay cho R2(cấu hình track interface)
    • Cấu hình tương tự câu trên
    Code:
    R2(config-if)#standby 1 track s1/1 50!

    - Đảm bảo khi interface s1/0 của R1 bị mất địa chỉ IP(interface up/up nhưng không có địa chỉ IP), R2 trở thành Active Router thay cho R1(cấu hình track object interface)
    • Thực hiện cấu hình track object để giám sát IP trên interface của Router. Khi s1/0 của R1 up/up mà không có IP thì sẽ bị trừ priority đi 70
    Code:
    R1(config)#track 10 interface s1/0 ip routing
    R1(config-track)#interface f0/0
    R1(config-if)#standby 1 track 10 decrement 70
    • Khi s1/0 ko có IP thì tự động priority bị giảm xuống còn 80 nên lúc này R2 sẽ lên thay thế cho R1 làm Active Router
    cau hinh HSRP Cisco(5)

    - Đảm bảo khi interface s1/1 của R2 bị mất địa chỉ IP(interface up/up nhưng không có địa chỉ IP), R3 trở thành Active Router thay cho R2(cấu hình track object interface)
    • Cấu hình tương tự như trên
    Code:
    R2(config)#track 10 interface s1/1 ip routing
    R2(config-track)#interface f0/0
    R2(config-if)#standby 1 track 10 decrement 50
    - Đảm bảo khi R1 mất default-route trong routing table, R2 trở thành Active Router thay cho R1(cấu hình track object interface)
    • Thực hiện cấu hình track object để giám sát default-route trong routing-table của Router R1.
    • Khi mất default-route thì R1 sẽ bị trừ priority đi 70
    Code:
    R1(config)#track 11 ip route 0.0.0.0/0 reachability
    R1(config-if)#int f0/0
    R1(config-if)#standby 1 track 11 decrement 70
    • Khi R1 mất default-route thì tự động priority bị giảm xuống còn 80 nên lúc này R2 sẽ lên thay thế cho R1 làm Active Router
    cau hinh HSRP Cisco(6)
     
    Last edited: Jul 25, 2016
  4. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38
    - Sw kết nối với 150 user, cấu hình HSRP để loadbalance giữa R1,R2,R3( Cấu hình 3 group, mỗi Router Active cho 1 Group) Virtual IP cho mỗi group như sau:

    • Group 1: 192.168.123.254
    • Group 2: 192.168.123.253
    • Group 3: 192.168.123.252
    // R1 sẽ là Standby cho Group 2 và Group 3
    Code:
    R1(config)#interface f0/0
    R1(config-if)#standby 2 ip 192.168.123.252
    R1(config-if)#standby 2 preempt
    R1(config)#interface f0/0
    R1(config-if)#standby 3 ip 192.168.123.253
    R1(config-if)#standby 3 preempt
    // R2 sẽ là ACtive cho Group 2 và Standby cho Group 3
    Code:
    R2(config)#interface f0/0
    R2(config-if)#standby 2 ip 192.168.123.252
    R2(config-if)#standby 2 priority 150
    R2(config-if)#standby 2 preempt
    R2(config)#interface f0/0
    R2(config-if)#standby 3 ip 192.168.123.253
    R2(config-if)#standby 3 preempt
    // R3 sẽ là Active cho Group 3 và Standby cho Group 2
    Code:
    R3(config)#interface f0/0
    R3(config-if)#standby 2 ip 192.168.123.252
    R3(config-if)#standby 2 preempt
    R3(config)#interface f0/0
    R3(config-if)#standby 3 ip 192.168.123.253
    R3(config-if)#standby 3 priority 150
    R3(config-if)#standby 3 preempt
    
     
    Last edited: Jul 25, 2016
  5. khoa.ntk01

    khoa.ntk01 New Member

    Joined:
    Jan 4, 2015
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    bài này cũng mất ảnh, hix, up lại nha, root
     
  6. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38
    hi bạn,

    Đã upload hình cho bài lab này xong nhé.

    Chúc bạn làm lab vui vẻ. Thanks
     
  7. upload

    upload New Member

    Joined:
    Nov 22, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    ad cho e hỏi về cái priority là s 150-70=80? cái này e không hiểu
    cám ơn ad
     
  8. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38
    hi bạn,

    - 150 là giá trị priority của Router R1 mà mình đã Set.
    - 70 là giá trị priority của Router R1 bị trừ đi khi cái Track đặt trên R1 bị down. Ví dụ khi interface S1/0 của Router R1 bị down thì Track sẽ chuyển từ trạng thái UP -> down. Lúc này Priority của R1 sẽ bị trừ đi 70. Tức là 150-70 = 80.
    - Bây giờ Router R1 sẽ có priority = 80 khi interface S1/0 của Router R1 bị down.
     

Share This Page