CCNA [Lab 13.1] Cấu hình HSRP and Spanning tree root

Discussion in 'Lab' started by root, Mar 13, 2014.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    52
    Trophy Points:
    48

    Cấu hình HSRP and Spanning tree root


    Lab HSRP and Spanning tree root: Bài lab này chúng ta sẽ kết hợp tính năng điều khiển traffic layer 2 bằng giao thức Spanning tree và cơ chế dự phòng gateway bằng giao thức HSRP.
    Dựa vào giao thức Spanning tree để chọn ra switch làm Root Bridge đảm nhiệm vai trò xử lý toàn bộ traffic layer 2 từ bên trong ra bên ngoài.
    Ngoài ra chúng ta sẽ cấu hình HSRP trên các Distributed Switch để tạo ra 1 gateway ảo cho các PC trong mạng LAN. Đảm bảo khả năng dự phòng cho hệ thống mạng LAN khi 1 Distributed switch bị lỗi.

    I. Sơ đồ và yêu cầu lab cấu hình HSRP and Spanning tree Root


    1. Sơ đồ:
    - Sơ đồ lab cấu hình HSRP and Spanning tree root trên 2 distrubuted switch.

    Cấu hình HSRP and Spanning tree root


    2. yêu cầu
    - Cable theo mô hình
    - SW1, SW2 làm VTP server và tạo 2 VLAN 10,20. Còn lại làm client
    - Cấu hình STP server sao cho:

    • SW3 dùng uplink là SW1
    • SW4 dùng uplink là SW2
    - Cấu hình HSRP sao cho
    • PC thuộc VLAN 10 qua SW1 ra internet
    • PC thuộc VLAN 20 qua SW2 ra internet
    - NAT R1, R2 ra internet
    - Nếu uplink giữa SW1 và SW3 hoặc SW2 và SW4 đứt thì PC phải chuyển qua đường còn lại

    - tham khảo thêm các bài lab liên quan.
    1. [Lab 13] Cấu hình HSRP CISCO
    2. [Lab 14] Cấu hình EtherChannel Layer 2 và Layer 3
    3. [Lab 12] Lab cấu hình NAT cho Router Cisco
    - Các bài lý thuyết tham khảo:
    1. [Bài 22] Tìm hiểu giao thức HSRP
    2. [Bài 23] Hướng dẫn cấu hình EtherChannel
    3. [Bài 21] Tìm hiểu về Network Address Translation
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Aug 4, 2016
  2. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    52
    Trophy Points:
    48

    II. Triển khai Lab cấu hình HSRP and Spanning tree root


    1. Cấu hình VLAN và định tuyến ra internet
    - Router R1

    Code:
    R1(config)#int f0/0
    R1(config-if)#ip address dhcp
    R1(config-if)#no shutdown
    R1(config-if)#int f0/1
    R1(config-if)#ip address 10.1.1.1 255.255.255.0
    R1(config-if)#no shut
    R1(config-if)#exit

    //Cấu hình NAT cho LAN ra internet

    Code:
    R1(config)#access-list 1 permit any
    R1(config)#ip nat inside source list 1 interface f0/0 overload
    R1(config)#int f0/0
    R1(config-if)#ip nat outside
    R1(config-if)#int f0/1
    R1(config-if)#ip nat inside
    R1(config-if)#exit

    // Định tuyến OSPF cho mạng LAN

    Code:
    R1(config)#router ospf 1
    R1(config-router)#network 10.1.1.0 0.0.0.255 area 0
    R1(config-router)#default-information originate

    - Router R2
    Code:
    R2(config)#int f0/0
    R2(config-if)#ip address dhcp
    R2(config-if)#no shutdown
    R2(config-if)#int f0/1
    R2(config-if)#ip address 10.2.2.1 255.255.255.0
    R2(config-if)#no shutdown

    // đinh tuyến OSPF trong LAN

    Code:
    R2(config)#router ospf 1
    R2(config-router)#network 10.2.2.0 0.0.0.255 area 0
    R2(config-router)#default-information originate
    R2(config-router)#exit

    // NAT cho LAN đi internet

    Code:
    R2(config)#access-list 1 permit any
    R2(config)#ip nat inside source list 1 interface f0/0 overload
    R2(config)#int f0/0
    R2(config-if)#ip nat outside
    R2(config-if)#int f0/1
    R2(config-if)#ip nat inside

    - Switch SW1
    Code:
    SW1-SW(config)#hostname SW1
    SW1(config)#int f1/0
    SW1(config-if)#no switchport
    SW1(config-if)#ip address 10.1.1.2 255.255.255.0
    SW1(config-if)#no shutdown
    SW1(config-if)#int f1/15
    SW1(config-if)#no switchport
    SW1(config-if)#ip address 10.3.3.1 255.255.255.0
    SW1(config-if)#no shutdown
    SW1(config-if)#int f1/14
    SW1(config-if)#switchport trunk encapsulation dot1q
    SW1(config-if)#switchport mode trunk
    SW1(config-if)#int f1/13
    SW1(config-if)#switchport trunk encapsulation dot1q
    SW1(config-if)#switchport mode trunk
    SW1(config-if)#end

    // VTP mode server và tạo VLAN

    Code:
    SW1#vlan database
    SW1(vlan)#vtp server
    SW1(vlan)#vtp domain svuit
    SW1(vlan)#vtp password 123
    SW1(vlan)#vlan 10
    SW1(vlan)#vlan 20
    SW1(vlan)#exit

    // định tuyến OSPF

    Code:
    SW1(config)#ip routing
    SW1(config)#router ospf 1
    SW1(config-router)#network 10.1.1.0 0.0.0.255 area 0
    SW1(config-router)#network 10.3.3.0 0.0.0.255 area 0
    SW1(config-router)#network 192.168.10.0 0.0.0.255 area 0
    SW1(config-router)#network 192.168.20.0 0.0.0.255 area 0
    - SW2
    Code:
    SW2-SW(config)#hostname SW2
    SW2(config)#int f1/0
    SW2(config-if)#no switchport
    SW2(config-if)#ip address 10.2.2.2 255.255.255.0
    SW2(config-if)#int f1/15
    SW2(config-if)#no switchport
    SW2(config-if)#ip address 10.3.3.2 255.255.255.0
    SW2(config-if)#int f1/14
    SW2(config-if)#switchport trunk encapsulation dot1q
    SW2(config-if)#switchport mode trunk
    SW2(config-if)#int f1/13
    SW2(config-if)#switchport trunk encapsulation dot1q
    SW2(config-if)#switchport mode trunk
    SW2(config-if)#end

    // Cấu hình VTP và tạo VLAN

    Code:
    SW2#vlan database
    SW2(vlan)#vtp server
    SW2(vlan)#vtp domain svuit
    SW2(vlan)#vtp password 123
    SW1(vlan)#vlan 10
    SW1(vlan)#vlan 20

    // Định tuyến OSPF

    Code:
    SW2(config)#ip routing
    SW2(config)#router ospf 1
    SW2(config-router)#network 10.2.2.0 0.0.0.255 area 0
    SW2(config-router)#network 10.3.3.0 0.0.0.255 area 0
    SW2(config-router)#network 192.168.10.0 0.0.0.255 area 0
    SW2(config-router)#network 192.168.20.0 0.0.0.255 area 0

    - Switch SW3
    // Cấu hình VLAN, VTP và lên trunk các port cần thiết để đồng bộ VLAN
    Code:
    SW3-SW#vlan database
    SW3-SW(vlan)#vtp client
    SW3-SW(vlan)#vtp domain svuit
    SW3-SW(vlan)#vtp password 123
    SW3-SW(vlan)#exit
    SW3-SW(config)#int f1/15
    SW3-SW(config-if)#switchport trunk encapsulation dot1q
    SW3-SW(config-if)#switchport mode trunk
    SW3-SW(config-if)#int f1/14
    SW3-SW(config-if)#switchport trunk encapsulation dot1q
    SW3-SW(config-if)#switchport mode trunk
    SW3-SW(config-if)#int f1/13
    SW3-SW(config-if)#switchport trunk encapsulation dot1q
    SW3-SW(config-if)#switchport mode trunk
    SW3-SW(config-if)#int f1/1
    SW3-SW(config-if)#switchport mode access
    SW3-SW(config-if)#switchport access vlan 10


    - Switch SW4
    // Cấu hình VLAN, VTP và lên trunk các port cần thiết để đồng bộ VLAN
    Code:
    SW4#vlan database
    SW4(vlan)#vtp client
    SW4(vlan)#vtp domain svuit
    SW4(vlan)#vtp password 123
    SW4(vlan)#exit
    SW4(config)#int f1/15
    SW4(config-if)#switchport trunk encapsulation dot1q
    SW4(config-if)#switchport mode trunk
    SW4(config-if)#int f1/14
    SW4(config-if)#switchport trunk encapsulation dot1q
    SW4(config-if)#switchport mode trunk
    SW4(config-if)#int f1/13
    SW4(config-if)#switchport trunk encapsulation dot1q
    SW4(config-if)#switchport mode trunk
     
    Last edited: Jul 25, 2016
  3. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    52
    Trophy Points:
    48
    - Để SW3 dùng uplink là SW1 thì SW1 phải là Root-Bright của VLAN 10
    Code:
    SW1(config)#spanning-tree vlan 10 root primary
    - Để SW4 dùng uplink là SW3 thì SW3 phải là Root-Bright của VLAN 30
    Code:
    SW3(config)#spanning-tree vlan 30 root primary

    - Nếu uplink giữa SW1 và SW3 đứt thì PC phải chuyển qua SW2
    • Khi đường uplink giữa SW1 và SW3 bị đứt và để chuyển hướng traffic của PC qua SW2 thì ta phải cấu hình HSRP sao cho SW2 làm Active
    • Lúc này ta có thể dùng track interface f1/14 để theo dõi nếu đường này bị đứt thì priority của SW1 sẽ bị trừ 70
    Code:
    SW1(config)#interface vlan 10
    SW1(config-if)#standby 10 track f1/14 70

    - Cấu hình tương tự cho đường uplink giữa SW2 và SW4
    Code:
    SW2(config)#interface vlan 20
    SW2(config-if)#standby 20 track f1/14 70
     
    Last edited: Jul 25, 2016
  4. khoa.ntk01

    khoa.ntk01 New Member

    Joined:
    Jan 4, 2015
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    sao nhiều bài mất ành vậy root. root up lại giúp nha
     
  5. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    52
    Trophy Points:
    48
    hi bạn,
    Đã upload lại hình xong cho bài này

    Thanks bạn đã quan tâm
     
  6. Trần Hữu Lâm

    Trần Hữu Lâm New Member

    Joined:
    Sep 10, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    ha noi
    cấu hình hsrp là trong các interface vlan ạ?
    sao lại cấu hình track theo dõi cổng f1/14 để dự phòng trong khi đã có spanning tree?
     

Share This Page