CCNA [Lab 10] Cấu hình Spanning tree protocol

Discussion in 'Lab' started by root, Feb 19, 2014.

  1. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38

    Cấu hình spanning tree protocol


    Bài lab cấu hình Spanning tree protocol hôm nay sẽ nói về vấn đề giao thức chống loop spannning tree trong hệ thống mạng switch layer 2. Như trong phần lý thuyết về giao thức spanning tree các bạn đã biết spanning tree là giao thức chống loop layer 2 khi bạn nối vòng nhiều switch layer 2 lại với nhau để tăng tính dự phòng hoặc chia tải giữa các switch...
    Bài lab cấu hình spanning tree protocol này sẽ hướng dẫn các bạn điều khiển traffic ở layer 2 chạy theo đúng hướng mình cần bằng cách sử dụng giao thức Spanning tree để chọn Root bridge và block port trong đấu nối vòng của Switch

    I. Sơ đồ và yêu cầu lab cấu hình spannning tree protocol


    1. Sơ đồ:
    - Bài lab cấu hình Spannning tree protocol này chúng ta sẽ sử dụng 3 switch layer 2 đấu nối vòng với nhau và chúng ta sẽ điều khiển traffic layer 2 đi theo hướng tối ưu nhất bằng giao thức spanning tree protocol.

    Cau hinh spanning tree protocol

    2. yêu cầu:
    - Thiết lập sơ đồ
    - Cấu hình cơ bản
    - Tạo VLAN và STP như sau:

    • SW1-Server, SW2-Client, SW3-Client
    • VTP Domain: svuit.com
    • VTP Password: 123
    - VLAN 1: default, Network: 172.16.1.0/24
    - VLAN 2: CCNA, Network: 172.16.2.0/24
    - VLAN 3: CCNP, Network: 172.16.3.0/24

    - Spanning-Tree Protocol

    • Show spanning-tree kiểm tra
    • Hiệu chỉnh STP đảm bảo
      • SW1 làm Root-SW cho VLAN 1
      • SW2 làm Root-SW cho VLAN 2
      • SW3 làm Root-SW cho VLAN 3
    • Cấu hình portfast cho các cổng kết nối với PC
    - Router cấp ip cho cả 3 VLAN
    - Router định tuyến cho các VLAN
    - Đảm bảo mọi VLAN đi internet.

    - tham khảo thêm các bài lab liên quan.

    1. [Lab 13.1] Cấu hình HSRP and Spanning tree root
    2. [Lab 14] Cấu hình EtherChannel Layer 2 và Layer 3
    3. [Lab 9.1] Cấu hình inter vlan switch layer 3
    - Các bài lý thuyết tham khảo:
    1. [Bài 19] Tìm hiểu giao thức Spanning tree Protocol
    2. [Bài 20] Hướng dẫn cấu hình ACL Router Cisco
    3. [Bài 21] Tìm hiểu về Network Address Translation
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.
     
    Last edited: Aug 4, 2016
  2. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38

    II. Triển khai lab cấu hình spanning tree layer 2


    1. Switch 1
    - Cấu hình VLAN và VTP trên Switch 1

    Code:
    SW1-Server(config)#vtp mode server
    SW1-Server(config)#vtp domain svuit.com
    SW1-Server(config)#vtp password 123
    SW1-Server(config)#vlan 2
    SW1-Server(config-vlan)#name CCNA
    SW1-Server(config-vlan)#vlan 3
    SW1-Server(config-vlan)#name CCNP
    
    SW1-Server(config)#interface range f0/2-8
    SW1-Server(config-if-range)#switchport mode access
    SW1-Server(config-if-range)#switchport access vlan 1
    SW1-Server(config-if-range)#interface range f0/9-11
    SW1-Server(config-if-range)#switchport mode access
    SW1-Server(config-if-range)#switch access vlan 2
    SW1-Server(config-if-range)#interface range f0/13-16
    SW1-Server(config-if-range)#switchport mode access
    SW1-Server(config-if-range)#switchport access vlan 3
    
    SW1-Server(config-if-range)#interface f0/1
    SW1-Server(config-if)#switchport mode trunk
    SW1-Server(config-if)#interface f0/12
    SW1-Server(config-if)#switchport mode trunk
    SW1-Server(config-if)#interface f0/24
    SW1-Server(config-if)#switchport mode trunk

    - Các VLAN đã được tạo trên Switch 1

    cau hinh spanning tree protocol(1)

    - Show spanning-tree trên switch 1

    cau hinh spanning tree protocol(2)

    - Cấu hình SW1 làm Root-SW cho VLAN1

    Code:
    SW1-Client(config)#spanning-tree vlan 1 root primary


    cau hinh spanning tree protocol(3)

    - Cấu hình portfast cho các cổng kết nối với PC

    Code:
    SW1-Server(config)#spanning-tree portfast default

    2. Switch 2
    - Cấu hình tương tự như Switch 1
    - Cấu hình VLAN và VTP

    Code:
    SW2-Client(config)#vtp domain svuit.com
    SW2-Client(config)#vtp password 123
    
    SW2-Client(config)#interface range f0/2-8
    SW2-Client(config-if-range)#switchport mode access
    SW2-Client(config-if-range)#switchport access vlan 1
    SW2-Client(config-if-range)#interface range f0/9-11
    SW2-Client(config-if-range)#switchport mode access
    SW2-Client(config-if-range)#switch access vlan 2
    SW2-Client(config-if-range)#interface range f0/13-16
    SW2-Client(config-if-range)#switchport mode access
    SW2-Client(config-if-range)#switchport access vlan 3
    
    SW2-Client(config-if-range)#interface f0/1
    SW2-Client(config-if)#switchport mode trunk
    SW2-Client(config-if)#interface f0/24
    SW2-Client(config-if)#switchport mode trunk

    - Cầu hình Switch 2 làm Root-Sw cho VLAN 2 và cấu hình portfast trên Switch 1
    Code:
    SW2-Client(config)#spanning-tree vlan 3 root primary
    SW2-Client(config)#spanning-tree portfast default

    - Show VLAN, trunk và spanning-tree trên Switch 2 để kiểm tra
    - Kiểm tra VLAN đã tạo và các port nào được gán vào các VLAN nào trên Switch 2


    cau hinh spanning tree protocol(4)
    - Kiểm tra port trunk trên Switch 2

    cau hinh spanning tree protocol(5)
    - Kiểm tra spanning tree protocol trên Switch 2

    cau hinh spanning tree protocol(6)
    - Thông tin "show spanning-tree" cho biết switch 2 đang làm root switch cho vlan 2.

    cau hinh spanning tree protocol(7)

    3. Switch 3

    - Thực hiện cấu hình tương tự trên Switch 3

    Code:
    SW3-Client(config)#vtp domain svuit.com
    SW3-Client(config)#vtp password 123
    
    SW3-Client(config)#interface range f0/2-8
    SW3-Client(config-if-range)#switchport mode access
    SW3-Client(config-if-range)#switchport access vlan 1
    SW3-Client(config-if-range)#interface range f0/9-12
    SW3-Client(config-if-range)#switchport mode access
    SW3-Client(config-if-range)#switchport access vlan 2
    SW3-Client(config-if-range)#interface range f0/13-16
    SW3-Client(config-if-range)#switchport mode access
    SW3-Client(config-if-range)#switchport access vlan 3
    
    SW3-Client(config-if-range)#interface f0/24
    SW3-Client(config-if)#switchport mode trunk
    SW3-Client(config-if)#interface f0/1
    SW3-Client(config-if)#switchport mode trunk
    
    SW3-Client(config)#spanning-tree vlan 3 root primary
    SW3-Client(config)#spanning-tree portfast default

    4. Router ISP
    Code:
    ISP(config)#ip dhcp pool ISP
    ISP(dhcp-config)#network 123.123.0.0 255.255.0.0
    ISP(dhcp-config)#default-router 123.123.123.123
    ISP(dhcp-config)#dns-server 8.8.8.8
    ISP(dhcp-config)#exit
    
    ISP(config)#interface f0/0
    ISP(config-if)#ip address 8.8.8.254 255.0.0.0
    ISP(config-if)#no shutdown
    ISP(config-if)#interface f0/1
    ISP(config-if)#ip address 123.123.123.123 255.255.0.0
    ISP(config-if)#no shutdown

    5. Router mạng LAN

    Code:
    Router(config)#interface f0/1
    Router(config-if)#ip address dhcp
    Router(config-if)#no shutdown
    
    Router(config)#interface f0/0
    Router(config-if)#no shutdown
    Router(config-if)#interface f0/0.1
    Router(config-subif)#encapsulation dot1Q 1
    Router(config-subif)#ip address 172.16.1.254 255.255.255.0
    Router(config-subif)#interface f0/0.2
    Router(config-subif)#encapsulation dot1Q 2
    Router(config-subif)#ip address 172.16.2.254 255.255.255.0
    Router(config-subif)#interface f0/0.3
    Router(config-subif)#encapsulation dot1Q 3
    Router(config-subif)#ip address 172.16.3.254 255.255.255.0
    
    Router(config)#access-list 1 permit any
    Router(config)#ip nat inside source list 1 interface f0/1 overload
    Router(config)#interface f0/1
    Router(config-if)#ip nat outside
    Router(config-if)#interface f0/0.1
    Router(config-subif)#ip nat inside
    Router(config-subif)#interface f0/0.2
    Router(config-subif)#ip nat inside
    Router(config-subif)#interface f0/0.3
    Router(config-subif)#ip nat inside
    
    Router(config)#ip dhcp pool VLAN1
    Router(dhcp-config)#network 172.16.1.0 255.255.255.0
    Router(dhcp-config)#default-route 172.16.1.254
    Router(dhcp-config)#dns-server 8.8.8.8
    Router(dhcp-config)#exit
    Router(config)#ip dhcp pool VLAN2
    Router(dhcp-config)#network 172.16.2.0 255.255.255.0
    Router(dhcp-config)#default-route 172.16.2.254
    Router(dhcp-config)#dns-server 8.8.8.8
    Router(dhcp-config)#exit
    Router(config)#ip dhcp pool VLAN3
    Router(dhcp-config)#network 172.16.3.0 255.255.255.0
    Router(dhcp-config)#default-route 172.16.3.254
    Router(dhcp-config)#dns-server 8.8.8.8

    6. Kiểm tra cấp DHCP cho các PC trong các VLAN và ra internet
    - Cắm PC vào các port của Sw để kiểm tra. Khi cắm PC vào các portfast thì trên Sw nó sẽ chuyển sang màu xanh luôn, thay vì chờ 30s đê port của Switch đổi từ mau cam -> xanh.

    cau hinh spanning tree protocol(8)
     
    Last edited: Jul 25, 2016
  3. khoa.ntk01

    khoa.ntk01 New Member

    Joined:
    Jan 4, 2015
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    mất ảnh rồi, root ơi, up lại nha. thanks root
     
  4. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38
    HI bạn,

    Mình đã upload lại hình bài lab này rồi nhé!

    Thanks bạn đã quan tâm!
     

Share This Page