CCNA Lab 1.2: Cấu hình Static Route

Discussion in 'Lab' started by nessiggk, Jun 23, 2018.

  1. nessiggk

    nessiggk New Member

    Joined:
    Feb 25, 2018
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 1.2: Cấu hình Static Route




    Bài viết lab cấu hình Static Route thứ hai, viết theo một mô hình khác, nhưng vẫn sử dụng phần mềm giả lập là Cisco Packet Tracer

    I. Chuẩn bị
    • Cấu hình ip gán cho các cổng interfaces như mô hình dưới
    cau hinh static route (2)


    1. Cấu hình cơ bản cho Router 1

    Code:
    Router>ena
    
    Router#conf t
    
    Router(config)#hostname R1
    
    R1(config)#interface f0/0
    
    R1(config-if)#ip address 10.1.1.1 255.255.255.0
    
    R1(config-if)#no shutdown
    
    R1(config-if)#exit
    
    R1(config)#interface f0/1
    
    R1(config-if)#ip address 12.5.10.1 255.255.255.0
    
    R1(config-if)#no shutdown
    
    R1(config-if)#exit
    2. Cấu hình cơ bản cho Router 2

    Code:
    Router>ena
    
    Router#conf t
    
    Router(config)#hostname R2
    
    R2(config)#interface f0/0
    
    R2(config-if)#ip address 10.1.1.2 255.255.255.0
    
    R2(config-if)#no shutdown
    
    R2(config-if)#exit
    3. Cấu hình cơ bản cho Router 3

    Code:
    Router>ena
    
    Router#conf t
    
    Router(config)#hostname R3
    
    R3(config)#interface f0/0
    
    R3(config-if)#ip address 12.5.10.2 255.255.255.0
    
    R3(config-if)#no shutdown
    
    R3(config-if)#exit
    II. Kiểm tra kết nối và cấu hình Static Route

    1. Sử dụng lệnh ping để kiểm tra rằng các router được kết nối trực tiếp với nhau thì có thể liên lạc được với nhau. Tức là khi mình đang ở Router1 thì có thể ping tới cổng F0/0 của Router 2 và Router 3
    Router1 -> Router 2

    cau hinh static route (3)


    Router1 -> Router3


    cau hinh static route (4)


    Tương tự như vậy thì Router2 có thể ping tới Router1, và Router3 có thể ping tới Router1 bởi chúng được kết nối trực tiếp với nhau và đã học hỏi các địa chỉ ip và mac lẫn nhau được ghi trong bảng định tuyến.

    Tuy nhiên khi ta ping thử từ Router 2-> Router3 thì không được bởi trong bảng định tuyến của 2 router này không có thông tin của nhau nên sẽ không thể ping được tới nhau.

    => Do đó theo như bài học ta phải cấu hình Static Route cho chúng.


    2. Cấu hình static route trên R3. Từ R3 ta cần đi tới R2, mà R2 thuộc mạng 10.1.1.0 vậy trường hợp này ta cần một static route cho mạng 10.1.1.0 thông qua next hop là 12.5.10.1 tức là khi nào một gói tin được gửi cho mạng 10.1.1.0 thì sẽ gửi tới router có địa chỉ IP là 12.5.10.1 cụ thể đây là Router1.

    Code:
    R3(config)#ip route 10.1.1.0 255.255.255.0 12.5.10.1
    3. Sau khi đã cấu hình static route cho R3 ở trên ta thử ping từ Router 3 tới cổng f0/0 của Router 1,Router 2, tới cổng f0/1 Router 1.

    Code:
    R3#ping 12.5.10.1
    
    R3#ping 10.1.1.1
    
    R3#ping 10.1.1.2
    cau hinh static route (5)

    • Qua kết quả của 3 lệnh ping mà ta thấy bên trên, chỉ có duy nhất lệnh ping tới địa chỉ IP 10.1.1.2 của R2 thì bị lỗi. Nguyên nhân do:
      • Khi gói tin đi từ R3 đến R2 ( source IP: R3, des IP: R1) theo bảng định tuyến trên R3 nó sẽ chuyển gói tin ra cổng f0/0 → Router R1→ Router R2.

      • Khi Router R2 đã nhận được gói tin thì nó sẽ gửi trả lại cho Router R3 trong đó gói tin sẽ có Source IP: R2, Des IP: R3

      • Nhưng lúc này bảng định tuyến của Router R2 chưa có thông tin định tuyến của Router R3 nên sẽ không thể trả lời lại được cho Router 3, drop bỏ gói tin này.

      • Lúc này lệnh ping sẽ bị lỗi.
    4. Cấu hình static route cho Router2. Để hoàn tất việc cấu hình static route nhằm đảm bảo 3 router đều liên lạc được với nhau thì ta cần kết nối tới R2 và tạo một static route cho mạng 12.5.10.0 (mạng mà R4 kết nối trực tiếp tới).
    Code:
    R2(config)#ip route 12.5.10.0 255.255.255.0 10.1.1.1
    Điều này có nghĩa rằng bất cứ gói tin nào R2 gửi tới mạng 12.5.10.0 sẽ phải đi qua 10.1.1.1 (cổng f0/0 của R1) trước.

    5. Giờ quay trở lại việc ping ở Router3 qua Router1 để chắc chắn rằng ta đã thành công trong static route trên các Router.

    cau hinh static route (6)



    Vậy là chúng ta đã cấu hình Static Route cơ bản cho mô hình ở trên thành công.
     
    Last edited: Jun 24, 2018

Share This Page