Lab 1.1 Redistribute

Discussion in 'Lab' started by root, Jul 12, 2014.

  1. root

    root Active Member

    Joined:
    Dec 31, 2012
    Messages:
    1,163
    Likes Received:
    18
    Trophy Points:
    38
    I. Mô hình và yêu cầu
    1. Mô hình
    [​IMG]

    2. Yêu cầu
    - Cấu hình NAT để các Router bên trong ra internet
    - Cấu hình Redistribute sao cho Router và PC bên trong ra được internet
    - Sơ đồ IP:

    [TABLE="class: grid, width: 800"]

    R4
    f0/0
    f0/1
    dhcp
    IP: 10.4.4.4/24

    R3
    f0/0
    f0/1
    IP: 10.4.4.3/24
    IP: 10.3.3.3/24

    R2
    f0/0
    f0/1
    IP: 10.3.3.2/24
    IP: 10.2.2.2/24

    R1
    f0/0
    f0/1
    IP: 10.2.2.1/24
    IP: 10.1.1.1/24

    R5
    f0/0
    f0/1
    IP: 10.1.1.5/24
    IP: 192.168.1.1/24

    PC

    IP: 192.168.1.10/24
    Gateway: 192.168.1.1
    [/TABLE]

    II. Triển khai
    1. Trên R1
    - Cấu hình IP, NAT overload và lan truyền default-route vào bên trong

    [TABLE="class: outer_border, width: 500"]

    R4(config)#int f0/0
    R4(config-if)#ip address dhcp
    R4(config-if)#no shut
    R4(config-if)#int f0/1
    R4(config-if)#ip address 10.4.4.4 255.255.255.0
    R4(config-if)#no shutdown

    R4(config)#access-list 1 permit any
    R4(config)#ip nat inside source list 1 interface f0/0 overload

    R4(config)#int f0/0
    R4(config-if)#ip nat outside
    R4(config-if)#int f0/1
    R4(config-if)#ip nat inside

    R4(config)#router ospf 1
    R4(config-router)#network 10.4.4.4 0.0.0.0 area 0
    R4(config-router)#default-information originate
    [/TABLE]

    2. Trên R3
    - Cấu hình IP, Routing(OSPF và RIP), lan truyền default-route và redistribute để phân phối các lớp mạng trong vùng OSPF và RIP với nhau.

    [TABLE="class: outer_border, width: 500"]

    R3(config)#int f0/0
    R3(config-if)#ip address 10.4.4.3 255.255.255.0
    R3(config-if)#no shutdown
    R3(config-if)#int f0/1
    R3(config-if)#ip address 10.3.3.3 255.255.255.0
    R3(config-if)#no shutdown

    R3(config)#router ospf 1
    R3(config-router)#network 10.4.4.3 0.0.0.0 area 0
    R3(config-router)#redistribute rip subnets

    R3(config)#router rip
    R3(config-router)#network 10.3.3.3
    R3(config-router)#default-information originate
    R3(config-router)#redistribute ospf 1 metric 5
    [/TABLE]

    3. Trên R2
    - Cấu hình IP, Routing( RIP và EIGRP), lan truyền default-route và redistribute để phần phối các lớp mạng trong vùng định tuyến EIGRP và RIP với nhau.

    [TABLE="class: outer_border, width: 500"]

    R2(config-if)#int f0/0
    R2(config-if)#ip address 10.3.3.2 255.255.255.0
    R2(config-if)#no shutdown
    R2(config-if)#int f0/1
    R2(config-if)#ip address 10.2.2.2 255.255.255.0
    R2(config-if)#no shutdown

    R2(config)#router rip
    R2(config-router)#network 10.3.3.2
    R2(config-router)#redistribute eigrp 1 metric 5

    R2(config)#router eigrp 1
    R2(config-router)#network 10.2.2.2 0.0.0.0
    R2(config-router)#redistribute static
    R2(config-router)#redistribute rip metric 100000 100 255 1 1500
    [/TABLE]

    4. Trên R1
    - Cấu hình IP, Routing: EIGRP và static route và thực hiện redistribute static.

    [TABLE="class: outer_border, width: 500"]

    R1(config)#int f0/0
    R1(config-if)#ip address 10.2.2.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#int f0/1
    R1(config-if)#ip address 10.1.1.1 255.255.255.0
    R1(config-if)#no shutdown

    R1(config)#router eigrp 1
    R1(config-router)#network 10.2.2.1 0.0.0.0
    R1(config-router)#redistribute static metric 100000 100 255 1 1500

    R1(config)#ip route 192.168.1.0 255.255.255.0 10.1.1.5
    [/TABLE]

    5. Trên R5
    - Cấu hình IP và trỏ default-route về R1

    [TABLE="class: outer_border, width: 500"]

    R5(config)#int f0/0
    R5(config-if)#ip address 10.1.1.5 255.255.255.0
    R5(config-if)#no shutdown
    R5(config-if)#int f0/1
    R5(config-if)#ip address 192.168.1.254 255.255.255.0
    R5(config-if)#no shutdown
    R5(config)#int loopback 0
    R5(config-if)#ip address 1.1.1.1 255.255.255.0

    R5(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.1
    [/TABLE]

    III. Kết quả
    - PC ping ra internet thành công

    [​IMG]

    - Show route các Router
    - R4

    - R3
    - R2


    - R1

    - R5
     

Share This Page