CCNA Lab 1.0: Cấu hình Static Route

Discussion in 'Lab' started by nessiggk, Jun 22, 2018.

  1. nessiggk

    nessiggk New Member

    Joined:
    Feb 25, 2018
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    HOCHIMINH CITY
    Home Page:

    Lab 1.0: Cấu hình Static Route




    Ở phần lý thuyết đã tìm hiểu cấu hình định tuyến tĩnh Static Route. Static Routing là phương thức định tuyến tĩnh do người quản trị nhập thông tin về đường đi cho Router. Vì vậy, khi cấu trúc định tuyến của hệ thống thay đổi thì người quản trị cũng phải cập nhập bằng tay các đường đi mới (xoá, thêm mới,…) cho Router.

    Đây là bài lab về cấu hình Static Route để hiểu rõ hơn về Static Route trên Router Cisco và đường thực nghiệm trên phần mềm giả lập Cisco Packer Tracer.


    I. Mô hình lab Static Route


    • Mô hình bài lab cấu hình Static route trên Cisco ( phần mềm Cisco Packet Tracer)
    cau hinh static route (1)

    • Mô hình gồm 3 con Router Cisco được bố trí và cấu hình như hình trên

    • Thêm phần interface loopback 0 của mỗi router đại diện cho các end-user

    II. Cấu hình Router Cisco

    1. Cấu hình cơ bản cho router 1

    • Đặt hostname và IP cho cổng Fast Ethernet F0/0 trên Router 1
    Code:
    Router>enable
    
    Router#configure terminal
    
    R1(config)#interface f0/0
    
    R1(config-if)#ip address 192.168.12.1 255.255.255.0
    
    R1(config-if)#no shutdown
    • Cấu hình interface loopback 0
    Code:
    R1(config)#interface loopback 0
    
    R1(config-if)#ip address 192.168.1.1 255.255.255.0
    • Quan sát kết quả vừa tạo
    Code:
    R1#show ip interface brief
    
    Interface IP-Address OK? Method Status Protocol
    
    FastEthernet0/0 192.168.12.1 YES manual up down
    
    Loopback0 192.168.1.1 YES manual up up

    2. Cấu hình cơ bản cho router 2

    • Đặt hostname, IP cho cổng F0/0 và F0/1 trên Router 2, interface loopback 0
    Code:
    Router(config)#hostname R2
    
    R2(config)#interface f0/0
    
    R2(config-if)#ip address 192.168.12.2 255.255.255.0
    
    R2(config-if)#no shutdown
    
    
    R2(config)#interface f0/1
    
    R2(config-if)#ip address 192.168.23.2 255.255.255.0
    
    R2(config-if)#no shutdown
    
    
    R2(config)#interface loopback 0
    
    R2(config-if)#ip address 192.168.2.1 255.255.255.0

    • Quan sát kết quả vừa tạo
    Code:
    R2#show ip interface brief
    
    Interface IP-Address OK? Method Status Protocol
    
    FastEthernet0/0 192.168.12.2 YES manual up up
    
    FastEthernet0/1 192.168.23.2 YES manual up up
    
    Loopback0 192.168.2.1 YES manual up up

    3. Cấu hình cơ bản trên Router 3

    • Đặt hostname, IP cho cổng F0/0 và F0/1 trên Router 3, interface loopback 0
    Code:
    Router(config)#hostname R3
    
    R3(config)#interface f0/0
    
    R3(config-if)#ip address 192.168.23.3 255.255.255.0
    
    R3(config-if)#no shutdown
    
    
    R3(config)#interface loopback 0
    
    R3(config-if)#ip address 192.168.3.1 255.255.255.0

    • Quan sát kết quả vừa tạo
    Code:
    R3#show ip interface brief
    
    Interface IP-Address OK? Method Status Protocol
    
    FastEthernet0/0 192.168.23.3 YES manual up up
    
    FastEthernet0/1 unassigned YES unset administratively down down
    
    Loopback0 192.168.3.1 YES manual up up

    III. Cấu hình static route


    1. Cấu hình static route trên Router 2

    • Câu lệnh để cho Router 2 kết nối được với lớp mạng 192.168.1.0/24 thông qua mạng loopback 0 của router 1 192.168.12.1 hay là cổng f0/0 và kết nối được với mạng loopback 0 của router 3 192.168.3.0/24 thông qua mạng 192.168.23.3 hay là cổng f0/1.
    Code:
    R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.12.1
    
    R2(config)#ip route 192.168.3.0 255.255.255.0 192.168.23.3

    • Kiểm tra bảng định tuyến của Router 2 xem ta đã cấu hình route được chưa:
    Code:
    R2#show ip route
    S 192.168.1.0/24 [1/0] via 192.168.12.1
    
    C 192.168.2.0/24 is directly connected, Loopback0
    
    S 192.168.3.0/24 [1/0] via 192.168.23.3
    
    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    
    C 192.168.23.0/24 is directly connected, FastEthernet0/1
    • Ta có thể dùng lệnh show ip route static để chỉ hiện những cấu hình static route
    Code:
    R2#show ip route static
    S    192.168.1.0/24 [1/0] via 192.168.12.1
    S    192.168.3.0/24 [1/0] via 192.168.23.3
    
    • Khi đã cấu hình Static Route cho Router 2 thì chắc chắn đã ping thành công tới 2 mạng loopback 0 của R1 à R3, vì khi này trong bảng định tuyến của R2 đã có 2 mạng trên, chỉ ra được đường đi cho nó.
    2. Cấu hình static route trên Router 1

    • Câu lệnh Static Route để thêm thông tin định tuyến vào bảng định tuyến để Router R1 có thể đi đến được các mạng loopback 0 của R2 và R3, hay là đến được R2 và R3
    Code:
    R1(config)#ip route 192.168.2.0 255.255.255.0 192.168.12.2
    
    R1(config)#ip route 192.168.23.0 255.255.255.0 192.168.12.2
    
    R1(config)#ip route 192.168.3.0 255.255.255.0 192.168.12.2

    • Kiểm tra bảng định tuyến của Router 1 xem ta đã cấu hình route được chưa:
    Code:
    R1#show ip route
    C 192.168.1.0/24 is directly connected, Loopback0
    
    S 192.168.2.0/24 [1/0] via 192.168.12.2
    
    S 192.168.3.0/24 [1/0] via 192.168.12.2
    
    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    
    S 192.168.23.0/24 [1/0] via 192.168.12.2

    • Khi này ta ping thử từ R1 đến 192.168.12.2 của R2 thì được, do đây là kiểu kết nối trực tiếp nên sẽ có trong bảng định tuyến của R1, tuy nhiên khi ping tiếp tới loopback 0 R2,192.168.23.2, hay là R3 thì sẽ không được mạng dù đã cấu hình thành công Static Route trên R1. Nguyên nhân do:
      • Khi gói tin đi từ R1 đến R3 ( source IP: R1, des IP: R3) theo bảng định tuyến trên R1 nó sẽ chuyển gói tin ra cổng f0/0 → Router R2 → Router R3.

      • Khi Router R3 đã nhận được gói tin thì nó sẽ gửi trả lại cho Router R1 trong đó gói tin sẽ có Source IP: R3, Des IP: R1

      • Nhưng lúc này bảng định tuyến của Router R3 chưa có định tuyến cho lớp mạng của Router R1 nên sẽ không trả lời lại được cho Router B

      • Lúc này lệnh ping sẽ bị lỗi.

    3. Cấu hình static route trên Router R3
    • Câu lệnh Static Route cho Router R3 để kết nối được với các mạng 192.168.2.0/24, 192.168.12.0/24, 192.168.1.0/24.
    Code:
    R3(config)#ip route 192.168.2.0 255.255.255.0 192.168.23.2
    
    R3(config)#ip route 192.168.12.0 255.255.255.0 192.168.23.2
    
    R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.23.2

    • Kiểm tra bảng định tuyến của Router 3 xem ta đã cấu hình route được chưa:
    Code:
    R3#show ip route
    
    S 192.168.1.0/24 [1/0] via 192.168.23.2
    
    S 192.168.2.0/24 [1/0] via 192.168.23.2
    
    C 192.168.3.0/24 is directly connected, Loopback0
    
    S 192.168.12.0/24 [1/0] via 192.168.23.2
    
    C 192.168.23.0/24 is directly connected, FastEthernet0/0

    • Bây giờ sau khi cấu hình Static Route đầy đủ trên cả 3 con Router R1, R2, R3 thì đã có thể thực hiện lệnh ping từ một mạng đến bất kỳ mạng còn lại.

    • Ví dụ ping từ R1 → R3
    Code:
    R1>ping 192.168.23.3
    
    Type escape sequence to abort.
    
    Sending 5, 100-byte ICMP Echos to 192.168.23.3, timeout is 2 seconds:
    
    !!!!!
    
    Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms
    • Ping từ R1 → loopback 0 R3
    Code:
    R1>ping 192.168.3.1
    
    Type escape sequence to abort.
    
    Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:
    
    !!!!!
    
    Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
    • Hoặc có thể ping từ source ip là loopback 0 R1 đến R3
    Code:
    R1>ping 192.168.23.3 source 192.168.1.1
    Vậy là chúng ta đã cấu hình Static Route cơ bản cho mô hình ở trên thành công.
     
    Last edited: Jun 24, 2018

Share This Page