[Lab 03] Routing Voip - part 1

Discussion in 'Lab Cisco Voice' started by root, Nov 19, 2015.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48
    I. Sơ đồ triển khai
    - Sơ đồ triển khai
    [​IMG]
    - yêu cầu:
    • Cấu hình đấu nối thiết bị theo mô hình
    • Cấu hình để Router CME cấp DHCP cho các IP Phone và PC
    • Cấu hình telephony, cấp extension cho các Ip Phone
    • Cấu hình routing network và VOIP để các IP Phone trong LAN của CME01 và CME02 gọi được cho nhau
    • Cấu hình tính năng Speed Dial hay Line Button
    • Cấu hình tính năng Forward-Busy Call
    • Cấu hình tính năng PickUp và group PickUp
    • Cấu hình tính năng Hunt Group
    II. Triển khai
    2.1 Cấu hình trên Router CME 01
    - Cấu hình IP và DHCP cho Router CME 01
    [TABLE="class: outer_border, width: 700"]

    CME01(config-if)#int f0/0
    CME01(config-if)#ip address 172.16.16.1 255.255.255.252
    CME01(config-if)#no shut

    CME01(config)#int f0/1
    CME01(config-if)#ip add
    CME01(config-if)#ip address 10.10.10.254 255.255.255.0
    CME01(config-if)#no shut

    CME01(config-if)#ip dhcp pool DHCP
    CME01(dhcp-config)#network 10.10.10.0 255.255.255.0
    CME01(dhcp-config)#default-router 10.10.10.254
    CME01(dhcp-config)#option 150 ip 10.10.10.254
    CME01(dhcp-config)#exit

    [/TABLE]


    - Kích hoạt tính năng Telephony trên Router CME 01 và khai các thông số trên CME 01
    [TABLE="class: outer_border, width: 700"]

    CME01(config)#telephony-service
    CME01(config-telephony)#max-dn 48
    CME01(config-telephony)#max-ephones 24
    CME01(config-telephony)#ip source-address 10.10.10.254 port 2000

    [/TABLE]


    - Tạo các số điện thoại extension trong các ephone-dn
    [TABLE="class: outer_border, width: 700"]

    CME01(config-telephony)#ephone-dn 1
    CME01(config-ephone-dn)#number 1001
    CME01(config-ephone-dn)#ephone-dn 2
    CME01(config-ephone-dn)#number 1002
    CME01(config-ephone-dn)#ephone-dn 3
    CME01(config-ephone-dn)#number 1003
    CME01(config-ephone-dn)#ephone-dn 4
    CME01(config-ephone-dn)#number 1004
    CME01(config-ephone-dn)#ephone-dn 5
    CME01(config-ephone-dn)#number 1005

    [/TABLE]


    - Gán các số điện thoại Extension mà chúng ta đã khai báo ở trên vào các Line Button tương ứng trên điện thoại
    [TABLE="class: outer_border, width: 700"]

    CME01(config)#ephone 1
    CME01(config-ephone)#mac-address 000c.29fa.55a8
    CME01(config-ephone)#button 1:1 2:2 3:3
    CME01(config-ephone)#restart

    CME01(config)#ephone 2
    CME01(config-ephone)#mac-address 000c.29a3.f6a5
    CME01(config-ephone)#button 1:4 2:5
    CME01(config-ephone)#restart

    [/TABLE]


    - Sau khi chúng ta gõ lệnh restart ở trên thì IP Phone sẽ tiến hành restart để đăng ký với CME01 và lấy các cấu hình của nó trên CME01 mà chúng ta đã cấu hình ở trên
    [​IMG]

    - Và đăng ký thành công các Line button 1,2,3 của Ip Phone 01 sẽ nhận các EXT lần lượt 1001, 1002, 1003
    [​IMG]


    2.2 Cấu hình CME 02

    - Chúng ta thực hiện cấu hình tương tự cho CME 02
    [TABLE="class: outer_border, width: 700"]

    CME02(config-if)#int f0/0
    CME02(config-if)#ip address 172.16.16.2 255.255.255.252
    CME02(config-if)#no shut

    CME02(config-if)#interface f0/1
    CME02(config-if)#ip address 10.20.20.254 255.255.255.0
    CME02(config-if)#no shut

    CME02(config)#ip dhcp pool DHCP
    CME02(dhcp-config)#network 10.20.20.0 255.255.255.0
    CME02(dhcp-config)#default-router 10.20.20.254
    CME02(dhcp-config)#option 150 ip 10.20.20.254
    CME01(dhcp-config)#exit

    CME02(config)#telephony-service
    CME02(config-telephony)#max-dn 48
    CME02(config-telephony)#max-ephones 24
    CME02(config-telephony)#ip source-address 10.20.20.254 port 2000

    CME02(config-telephony)#ephone-dn 1
    CME02(config-ephone-dn)#number 2001

    CME02(config-ephone-dn)#ephone-dn 2
    CME02(config-ephone-dn)#number 2002

    CME02(config-ephone-dn)#ephone-dn 3
    CME02(config-ephone-dn)#number 2003

    CME02(config-ephone-dn)#ephone-dn 4
    CME02(config-ephone-dn)#number 2004

    CME02(config-ephone-dn)#ephone-dn 5
    CME02(config-ephone-dn)#number 2005

    CME02(config-ephone-dn)#ephone 1
    CME02(config-ephone)#mac-address 000c.295f.cbbd
    CME02(config-ephone)#button 1:1 2:2 3:3
    CME02(config-ephone)#restart

    [/TABLE]


    2.3 Cấu hình Routing Voip giữa 2 CME
    - Bây giờ chúng ta sẽ tiến hành cấu hình On-net Dial Plan voip giữa 2 tổng đài CME01 và CME02 để các IP Phone thuộc 2 CME này có thể gọi điện thoại được cho nhau
    - Trước khi cấu hình Routing Voip cho 2 tổng đài CME thì chúng ta cần cấu hình Routing để 2 mạng LAN của 2 Router CME thấy nhau.
    [TABLE="class: outer_border, width: 700"]

    //Router CME01 sẽ trỏ default route tới CME 02
    CME01(config)#ip route 0.0.0.0 0.0.0.0 172.16.16.2

    //Router CME02 sẽ trỏ default route tới CME 01
    CME02(config)#ip route 0.0.0.0 0.0.0.0 172.16.16.1

    [/TABLE]

    - Tiếp theo chúng ta sẽ cấu hình On-Net Dial Plan giữa 2 CME

    • Dial-Peer: Là cấu trúc phần mềm mà kết hợp chuỗi số được quay với một cổng (port) voice hay một địa chỉ IP của gateway đích. Có thể tồn tại nhiều dial-peer trên mỗi thiết bị chuyển đổi công nghệ đấu nối thoại (router gateway) và để thiết lập một cuộc gọi thì trên một router có ít nhất hai “dial-peer”, một được gán cho đầu xuất phát cuộc gọi và một cho xác định đầu kết thúc cuộc gọi . Trong VoIP có hai loại dial-peer POTS và VoIP.
    • Destination Pattern: Là sự kết hợp một số với một thiết bị điên thoại. Nó được cấu hình trong dial-peer bằng dòng lệnh destination-pattern. Nếu số được quay khớp với destination pattern, cuộc gọi sẽ được gửi đến cổng POTS, hay session target qua mạng IP để đến thiết bi đích.
    • Session Target: Là địa chỉ IP của thiết bị gateway đầu xa mà cuộc gọi sẽ được gửi đến qua môi trường IP
    [TABLE="class: outer_border, width: 700"]

    CME01(config)#dial-peer voice 2000 voip
    CME01(config-dial-peer)#destination-pattern 2...
    CME01(config-dial-peer)#session target ipv4:10.20.20.254

    [/TABLE]


    - Tương tự chúng ta cấu hình Dial-Peer cho Router CME 02
    [TABLE="class: outer_border, width: 700"]

    CME02(config)#dial-peer voice 2000 voip
    CME02(config-dial-peer)#destination-pattern 1...
    CME02(config-dial-peer)#session target ipv4:10.10.10.254

    [/TABLE]


    - Trên IP Phone 02 thuộc LAN của Router CME02 bạn sẽ thực hiện ping tới lớp mạng LAN của Router CME01 thành công

    [​IMG]

    - Sử dụng IP Phone 01 và Line button 1 có số EXT 1001 gọi đến số điện thoại 2001 của IP Phone 02 thành công

    [​IMG]

    - Và trên IP Phone 2 các bạn sẽ thấy có 1 cuộc gọi từ số EXT 1001 gọi đến

    [​IMG]




     
  2. bokepid

    bokepid New Member

    Joined:
    Mar 14, 2018
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Female
    Location:
    Ninh Bình
    terima kasih
     

Share This Page