[Lab 02] proxy arp và classless, classfull

Discussion in 'Lab' started by root, Nov 17, 2015.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    52
    Trophy Points:
    48
    I. Chuẩn bị
    - Mô hình triển khai
    [​IMG]
    - yêu cầu:

    • Cấu hình IP cho các thiết bị như trong sơ đồ ở trên
    • Cấu hình default route với next-hop là int f0/0 của Router
    • Thực hiện tắt tính năng Proxy ARP
    • Tắt tính năng ip classless

    II. Proxy ARP

    1. Cấu hình Router R1
    - Cấu hình IP, Default route… trên Router R1


    [TABLE="class: outer_border, width: 700"]

    R1(config)#int f0/0
    R1(config-if)#ip add 172.16.12.1 255.255.255.0
    R1(config-if)#no shut

    R1(config-if)#int f0/1
    R1(config-if)#ip add 10.2.2.1 255.255.255.0
    R1(config-if)#no shut
    R1(config-if)#exit

    R1(config)#ip route 0.0.0.0 0.0.0.0 f0/0

    [/TABLE]


    2. Cấu hình Router R2
    - Tương tự chúng ta thực hiện cấu hình cho Router R2

    [TABLE="class: outer_border, width: 700"]

    R2(config)#int f0/0
    R2(config-if)#ip add 172.16.12.2 255.255.255.0
    R2(config-if)#no shut

    R2(config-if)#int f0/1
    R2(config-if)#ip add 10.0.0.2 255.255.255.240
    R2(config-if)#no shut
    R2(config-if)#exit

    R2(config)#ip route 0.0.0.0 0.0.0.0 f0/0

    [/TABLE]


    - bây giờ chúng ta sử dụng PC 1 ping tới Router R2 và PC 2 thành công
    [​IMG]
    Kiểm tra bảng ARP trên Router R1 chúng ta sẽ thấy cùng 1 MAC address trên interface f0/0 của Router R2 có đến 2 IP được sử dụng cho internet. Đây là do cơ chế Proxy ARP của Router
    [​IMG]
    - Bởi vì trên Interface f0/0 của Router R1 đang bật tính năng Proxy Arp nên các địa chỉ IP bên ngoại Router R1 sẽ có cùng 1 địa chỉ MAC đó chính là MAC của next-hop int f0/0 của Router R2.
    - Để kiểm chứng chúng ta có thể tạo thêm 1 interface loopback 0 trên Router R2 và dùng PC1 ping đến IP card Loopback này nó cũng đều cho ra 1 địa chỉ Mac

    [TABLE="class: outer_border, width: 700"]

    R2(config)#int loopback 0
    R2(config-if)#ip address 10.3.3.3 255.255.255.0

    [/TABLE]


    - Dùng PC 1 để ping tới IP loopback 0 và int f0/1 của Router R2, PC2
    [​IMG]
    - Bạn có thể nhìn thấy trong bảng ARP của Router R1 các IP internet: 172.16.12.2, 10.0.0.2, 10.0.0.12, 10.3.3.3 đều có chung 1 địa chỉ MAC của interface f0/0 trên Router R2
    [​IMG]
    Địa chỉ Mac của interface f0/0 trên Router R2
    [​IMG]

    - Bây giờ chúng ta thử vào Router R2 và tắt Proxy Arp trên interface f0/0. interface đó

    [TABLE="class: outer_border, width: 700"]

    R1(config-if)#no ip proxy-arp
    [/TABLE]

    - Kiểm tra lại xem trên int f0/0 của R1 đã tắt tính năng Proxy Arp chưa
    [​IMG]
    - Sau khi tắt Proxy Arp trên cổng f0/0 của Router R2 thì chúng ta cần clear xlate (xóa bảng ARP) để nhanh thì chúng ta có thể shutdown và no shut cổng f0/0 của Router R1.

    [TABLE="class: outer_border, width: 700"]

    R1(config)#int f0/0
    R1(config-if)#shutdown
    R1(config-if)#no shutdown

    [/TABLE]

    - Bây giờ PC1 sẽ không ping được đến Router R2 và PC2 vì chúng ta đã tắt cơ chế Proxy-Arp trên int f0/0 của Router
    [​IMG]
    - Router R1 có thể ping tới int f0/0 của Router R2 nhưng cũng không thể ping tới PC2. Kiểm tra lại bảng ARP của Router R1 bạn sẽ thấy nó sẽ không có MAC của IP 10.0.0.12 như bảng ARP lúc trước khi chúng ta tắt chức năng Proxy ARP
    [​IMG]

    III. Classfull & classless
    - Trên Router R1 cấu hình telnet để cho phép telnet

    [TABLE="class: outer_border, width: 700"]

    R2(config)#line vty 0 4
    R2(config-line)#no login

    [/TABLE]

    - Trên Router R1 thực hiên ping và telnet tới 10.0.0.2 trên Router R2 thành công
    [​IMG]
    - Bây giờ trên Router R1 chúng ta sẽ tắt tính năng IP Classless

    [TABLE="class: outer_border, width: 700"]

    R1(config)#no ip classless
    [/TABLE]

    - Lúc này chúng ta dùng Router R1 thử ping và telnet lại IP 10.0.0.2 của Router R2 thì thấy ping thành công nhưng telnet không được.
    [​IMG]
    - Tương tự chúng ta lấy PC2 telnet và ping tới 10.2.2.1 của Router R1 thì thấy ping được nhưng telnet không được.
    [​IMG]
    [​IMG]


     

Share This Page