[Lab 02] Cấu hình VLAN Voice, Trunking, CME

Discussion in 'Lab Cisco Voice' started by root, Nov 19, 2015.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,133
    Likes Received:
    60
    Trophy Points:
    48
    I. Yêu cầu
    1. Sơ đồ

    [​IMG]

    2. Yêu cầu

    - Cấu hình IP và đấu nối thiết bị theo mô hình trên
    - Cấu hình Router CME cấp DHCP cho các IP Phone thuộc VLAN 22 và PC thuộc VLAN 12
    - Cấu hình VLAN và trunking trên Switch Poe và Router CME
    - Cấu hình Router làm CME và tạo các extension cấp cho các IP Phone

    II. Triển khai
    2.1. Cấu hình Router CME
    Cấu hình IP và DHCP trên Router CME
    [TABLE="class: outer_border, width: 700"]

    CME(config)#int f0/1
    CME(config-if)#no shutdown

    // Chia Subinterface cho vlan 12 chạy traffic DATA
    CME(config)#interface f0/1.12
    CME(config-subif)#encapsulation dot1Q 12
    CME(config-subif)#ip address 10.86.12.254 255.255.255.0

    // Chia Subinterface cho vlan 20 chạy traffic VOICE
    CME(config-if)#int f0/1.22
    CME(config-subif)#encapsulation dot1Q 22
    CME(config-subif)#ip address 10.86.22.254 255.255.255.0

    // DHCP cấp IP cho VLAN DATA gồm các PC
    CME(config)#ip dhcp pool DATA
    CME(dhcp-config)#network 10.86.12.0 255.255.255.0
    CME(dhcp-config)#default-router 10.86.12.254
    CME(dhcp-config)#exit

    // DHCP cấp IP cho VLAN VOICE, gồm các IP Phone Cisco
    CME(config)#ip dhcp pool VOICE
    CME(dhcp-config)#network 10.86.22.0 255.255.255.0
    CME(dhcp-config)#default-router 10.86.22.254
    CME(dhcp-config)#option 150 ip 10.86.22.254
    CME(dhcp-config)#exit

    [/TABLE]


    - Cấu hình dịch vụ Telephony trên Router CME
    [TABLE="class: outer_border, width: 700"]

    // Kích hoạt tính năng telephony trên Router CME
    CME(config)#telephony-service
    CME(config-telephony)#max-dn 48
    CME(config-telephony)#max-ephones 24

    // Khai báo các DN và tạo các số extension cho các IP Phone
    CME(config)#ephone-dn 1
    CME(config-ephone-dn)#number 3001
    CME(config-ephone-dn)#ephone-dn 2
    CME(config-ephone-dn)#number 3002

    // Khai báo thông số cho IP Phone 01 như Mac address của IP Phone 01, gán các line button 1,2,3 lần lượt cho các Ext 1001, 1002, 1003.
    CME(config)#ephone 1
    CME(config-ephone)#mac-address 000c.29fa.55a8
    CME(config-ephone)#button 1:1 2:3 3:3
    CME(config-ephone)#restart

    // Khai báo thông số cho IP Phone 02 như Mac address của IP Phone 02, gán các line button 1,2 lần lượt cho các Ext 1004,1005
    CME(config-ephone)#ephone 2
    CME(config-ephone)#mac-address B000.B4D9.A892
    CME(config-ephone)#button 1:2
    CME(config-ephone)#type 7965
    CME(config-ephone)#restart

    [/TABLE]

    2.2. Cấu hình Switch PoE
    Cấu hình trên Switch POE
    [TABLE="class: outer_border, width: 700"]

    //Tạo các VLAN 10 và 20 cho DATA và VOICE tương ứng
    Switch_Poe(config)#vlan 12
    Switch_Poe(config-vlan)# name DATA
    Switch_Poe(config-vlan)#vlan 22
    Switch_Poe(config-vlan)# name VOICE

    // Cấu hình trunking với Router CME
    Switch_Poe (config)#int f0/0
    Switch_Poe(config-if)#switchport mode trunk
    Switch_Poe(config-if)#switchport trunk encapsulation dot1q

    // Cấu hình để các port f0/1 đến f0/4 cho VLAN 10 và voice VLAN 20
    Switch_Poe (config)#interface range fastEthernet 0/1 - 4
    Switch_Poe (config-if-range)#switchport mode access
    Switch_Poe (config-if-range)#switchport access vlan 12
    Switch_Poe (config-if-range)#switchport voice vlan 22

    [/TABLE]


    III. Kiểm tra
    - Lấy 1 IP Phone Cisco 7965 gắn vào Switch POE với dây màu vàng là gắn với switch POE và dây màu xanh dùng để gắn cho máy tính, PC…
    [​IMG]

    - đợi xói để IP Phone khởi động lên và sau khi khởi động sau IP Phone này sẽ được cấp số extension 3002
    [​IMG]

    - Kiểm tra Network của IP Phone này xem nó có được cấp đúng VLan và IP không
    - Ở đây bạn có thể thấy địa chỉ Mac của Ip Phone này. Các bạn tiếp phần “IPv4 configuration” để kiểm tra IPv4 của Ip Phone
    [​IMG]

    - như các bạn thấy Ip Phone này sử dụng DHCP và dược cấp IP 10.86.22.1 thuộc VLAN VOICE 22
    [​IMG]

    - Các bạn ấn nút mũi tên đi xuống để xem VLAN mà IP Phone này được cấp nhé. Nó là VLAN 22
    [​IMG]

    - Quay lại PC được gắn dây với IP kiểm tra IP bạn sẽ thấy PC được cấp IP 10.86.12.4 nó là IP thuộc vlan 12 – vlan DATA
    [​IMG]

     

Share This Page