[Lab 01] Routing table

Discussion in 'Lab' started by root, Nov 11, 2015.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48
    Bài lab này nhằm mục đích chứng minh và kiểm tra lại phần lý thuyết mà chúng ta đã đọc ở đây http://svuit.vn/ly-thuyet-75/ly-thuyet-01-routing-table-1033.html

    I. yêu cầu

    - Mô hình:
    [​IMG]
    - Sơ đồ IP
    [TABLE="class: grid, width: 900"]

    [TD="bgcolor: #00b050"]
    Device Name
    [/TD]
    [TD="bgcolor: #00b050"]
    Interface
    [/TD]
    [TD="bgcolor: #00b050"]
    IP address
    [/TD]
    [TD="bgcolor: #00b050"]
    Gateway
    [/TD]

    Router R1

    f0/0

    172.16.12.1/24



    f0/1

    172.16.1.0/24

    f1/0

    172.17.1.0/24

    f2/0

    172.16.100.0/25

    PC 1



    172.16.1.10/24
    172.16.1.1

    PC 2



    172.17.1.10/24
    172.17.1.1

    PC 3



    172.16.100.10/25
    172.16.100.1

    Router R2

    f0/0

    172.16.12.2/24



    f0/1

    172.17.2.2/24

    PC 4



    172.17.2.20/24
    172.17.2.2
    [/TABLE]


    II. Triển khai

    2.1. Cấu hình trên Router R1

    - Tiến hành đặt IP cho các interface của Router và cấu hình định tuyến cho Router
    [TABLE="class: outer_border, width: 800"]

    // Cấu hình IP cho interface f0/0
    R1(config)#int f0/0
    R1(config-if)#ip add 172.16.12.1 255.255.255.0
    R1(config-if)#no shut

    // Cấu hình IP cho interface f0/1
    R1(config-if)#int f0/1
    R1(config-if)#ip add 172.16.1.1 255.255.255.0
    R1(config-if)#no shut

    // Cấu hình IP cho interface f1/0
    R1(config-if)#int f1/0
    R1(config-if)#ip add 172.17.1.1 255.255.255.0
    R1(config-if)#no shut

    // Cấu hình IP cho interface f2/0
    R1(config-if)#int f2/0
    R1(config-if)#ip add 172.16.100.1 255.255.255.0
    R1(config-if)#no shut

    // Cấu hình định tuyến Rip version 1 cho Router
    R1(config)#router rip
    R1(config-router)#version 1
    R1(config-router)#network 172.16.12.0
    R1(config-router)#network 172.16.1.0
    R1(config-router)#network 172.17.1.0
    R1(config-router)#network 172.16.100.0


    [/TABLE]

    2.2. Cấu hình Router R2
    - Tiến hành cấu hình IP cho các interface và định tuyến cho Router R2
    [TABLE="class: grid, width: 800"]

    // Cấu hình IP cho interface f0/0
    R2(config)#int f0/0
    R2(config-if)#ip add 172.16.12.2 255.255.255.0
    R2(config-if)#no shut

    // Cấu hình IP cho interface f0/1
    R2(config-if)#int f0/1
    R2(config-if)#ip add 172.17.2.2 255.255.255.0
    R2(config-if)#no shut

    // Cấu hình định tuyến Rip version 1 cho Router
    R2(config-if)#router rip
    R2(config-router)#version 1
    R2(config-router)#network 172.16.12.0


    [/TABLE]

    III. Kiểm tra
    3.1. Xét bảng định tuyến của Router R1
    - Xét route 172.17.2.0/24

    Kiểm tra bảng định tuyến của Router R1 chúng ta sẽ thấy route 172.17.2.0/24 sẽ không được update vào bảng định tuyến của Router R1 vì:

    • Xét route gửi ra (172.17.0.0) có cùng major network với cổng gửi ra không (172.16.0.0). Nếu không cùng thì nó sẽ trả về class chuẩn (172.17.0.0) và gửi route này qua cho Router R1.
    • Lúc này Router R1 nhận được route (172.17.0.0) nó sẽ xét route nhận vào có cùng major network với cổng nhận vào không (172.16.0.0).
      • Nếu khác nó sẽ xét tiếp xem nó có route nào của nó(int f0/1: 172.16.0.0, int f1/0: 172.17.0.0, int f2/0: 172.16.0.0) thuộc major network của route nhận không (172.17.0.0).
      • Như chúng ta thấy thì trên Router R1 có route connected 172.17.1.0 là có cùng major network với route nhận vào từ Router R2 (172.17.2.0). Vì vầy route nhận này sẽ bị Ignore (mạng gián đoạn).
      • Vì vậy route 172.17.2.0/24 trên Router R2 sẽ không được update trên bảng định tuyến của Router R1.
    [​IMG]

    - Vì Rip version 1 không hỗ trợ mạng gián đoạn nên Router R1 không có route 172.17.2.0/24 trong bảng định tuyến. Vì vậy các Router R1 không thể ping thấy PC 4.
    [​IMG]

    - Bây giờ chúng ta thử vào Router R1 và shutdown interface f1/0

    [TABLE="class: outer_border, width: 500"]

    R1(config)#int f1/0
    R1(config-if)#shutdown

    [/TABLE]

    • Để route nhận vào 172.17.2.0/24 không bị trùng với route connected 172.17.1.0/24.
    • Lúc này route nhận vào từ Router R2 172.17.2.0 sẽ được cập nhập vào bảng định tuyến của Router R1 với subnet mask là class tương ứng. Vì vậy route sẽ cập nhập vào bảng định tuyến của Router R1 là 172.17.0.0/16
    [​IMG]
    Lúc này Router R1 có thể ping tới PC 4
    [​IMG]

    3.2. Xét bảng định tuyến update của Router R2

    - Bây giờ chúng ta tiến hành kiểm tra bảng định tuyến của Router R2 nó chỉ cập nhâp 1 route 172.16.1.0 từ bảng định tuyến của Router R1 vào bảng định tuyến của nó.
    [​IMG]

    3.2.1. Xét route 172.16.1.0/24

    - Đầu tiên chúng ta xét route 172.16.1.0/24 trên Router R1 gửi qua cho Router R2.

    • Router R1 xét thấy route 172.16.1.0 có cùng major network với cổng gửi ra 172.16.12.0 là 172.16.0.0
    • Nó xét tiếp thấy route 172.16.1.0/24 có cùng subnet mask với cổng gửi ra 172.16.12.0/24 là 225.255.0.0
    • Lúc này Router R1 sẽ gửi route 172.16.1.0/24 qua cho Router R2 dưới dạng không có subnet mask là 172.16.1.0
    • Router R2 nhận vào route 172.16.1.0 nó sẽ xét route này có cùng major network với cổng nhận vào là 172.16.0.0 nên nó sẽ cập nhập route này vào bảng định tuyến của nó và lấy subnet mask là subnet mask trên cổng nhận vào của nó 172.16.1.0/24
    • Vì vậy Router R2 có thể ping thấy PC1
    [​IMG]
    - Bây giờ chúng ta sẽ thử đổi subnet mask của cổng nhận vào trên Router R2 thành /27 để xem route nhận vào 172.16.1.0/24 có cập nhập bảng định tuyến của nó với route nhận vào là 172.16.1.0 và subnet là của cổng nhận vào là /27 không.
    [TABLE="class: outer_border, width: 500"]

    R2(config)#int f0/0
    R2(config-if)#ip address 172.16.12.2 255.255.255.224

    [/TABLE]

    - Bạn đợi khoảng 30s để Router R2 cập nhập lại bảng định tuyến của nó. Bạn sẽ thấy route nhận vào 172.16.1.0/24 đã nhận đúng subnet của cổng nhận vào Router R2 là /27
    [​IMG]

    3.2.2. Xét route 172.17.1.0

    - Khi Router R1 đẩy route 172.17.1.0/24 ra nó sẽ xét

    • Route 172.17.1.0 khác major network của cổng gửi ra 172.16.12.0 nên route này sẽ được gửi ra dưới dạng class chuẩn 172.17.1.0
    • Router R2 nhận vào route 172.17.1.0 nó sẽ xét xem có cùng major network của cổng nhận vào không 172.16.0.0. Ở đây chúng ta thấy nó không cùng major network với cổng nhận nên nó sẽ xét tiếp
    • Trong bảng định tuyến của nó có route nào có major network thuộc major network của route nhận vào (172.17.0.0) không. Ở đây chúng ta thấy route connected 172.17.2.0/24 có cùng major network với route nhận vào 172.17.1.0 nên nó sẽ thực hiện Ignore (mạng bị gián đoạn).
    • Vì vậy route 172.17.1.0/24 trên bảng định tuyến của Router R1 không được cập nhập trên Router R2 nên Router R2 không thể ping thấy PC 2
    [​IMG]
    3.2.3. Xét Route 172.16.100.0/25
    - Tương tự route 172.16.100.0/25 khi đẩy ra sẽ được xét

    • route 172.16.100.0/25 có cùng major network của cổng nhận ra không 172.16.12.0/24. Ở đây là cùng major network 172.16.0.0 nên nó sẽ xét qua bước tiếp theo
    • Xét route 172.16.100.0/25 có cùng subnet mask của cổng nhận ra không. Thì ta thấy route 172.16.100.0/25 có subnet mask là mạng con của cổng gửi ra 172.16.12.0/24 nên route 172.16.100.0/25 sẽ bị drop (mạng VLSM).
    • Vì vậy route 172.16.100.0/25 không được cập nhập trong bảng định tuyến của Router R2. Vì vậy Router R2 không thể ping thấy PC3
    [​IMG]
     

Share This Page