Cisco ASA [Chapter 4.5] Dynamic Routing protocols

Discussion in 'Lý Thuyết' started by root, May 14, 2014.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48

    Firewall ASA: Dynamic Routing


    1. Gói tin Helo dùng để:
    - Etablish: Thiết lập mối quan hệ Neighber và nó được gửi theo chu kì.

    Vd: EIGRP: 5s/1 lần, OSPF 10s/1 lần.
    - Để duy trì Neighber. Nếu quá thời gian mà Router ko trả lời thì nó sẽ xóa Neighber thì thời gian này gọi là: hole time(EIGRP) hay Dead interval(OSPF)

    1.1. Hole time trong EIGRP

    :

    - Nếu trong vòng 15s mà Router (là router ban đầu gửi gói helo) ko gửi gói helo cho neighber thì neighber sẽ bị mất(hole time là do mình quyết định)
    - Vd: Khi các bạn “show ip eighrp neighber” thì sẽ thấy hole time và nếu bạn show liên tục thì thấy nó đếm ngược từ 15, 14, 13, … rồi khi đến giây thứ 10 nó sẽ lại tiếp tục quay lại 15s( vì chu kì gói tin helo là 5s)
    - Nhưng nếu bên kia ko helo lại thì hole time sẽ tiếp tục giảm 15,14…1, 0. Đến khi hết mà ko thấy bên kia trả lời thì nó sẽ thực hiện xóa neighber ra khỏi bảng định tuyến
    - Trong EIGRP chỉ có khai niệm neighber khác với OSPF

    1.2. Dead interval OSPF

    :

    - Trong OSPF nó phải trải qua nhiều trạng thái khác nhau. OSPF phân chia các trạng thái của neighber rất kỹ:

    • Down: chưa ai nói chuyện
    • Init: Khi router gửi gói tin Helo ra thì Router sẽ lên trạng thái Init
    • 2-way: Router lên 2-way khi Router nhận được gói tin helo trả lời nhưng trong đó phải có Router-ID của nó thì mới lên được 2-way.
    • Ví dụ:
      • Khi router 1 gửi gói tin helo (224.0.0.5 với router-id: 1.1.1.1 mục đich là để giởi thiệu với mọi người tôi là Router có tên 1.1.1.1).
      • Tương tự như vậy Router 2 cũng gửi gói tin helo ra với địa chỉ 224.0.0.5, Router-ID 2.2.2.2. Vậy khi R1 nhận được gói helo của R2 thì có lên được trạng thái 2-way ko?
      • Trả lời: không. Vì trong gói helo của R2 ko có Router-ID của R1 (R1 phải nhận lời chào từ R2 mà trong đó phải có tên của R1 mới lên 2-way được).
      • Để lên 2-way thì R1 phải nhận được gói từ R2 có địa chỉ 224.0.0.5 và nội dung xin chào R1(Router-ID 1.1.1.1) tôi là R2(Router-ID: 2.2.2.2)
    • Establish: Đang trong quá trình bầu chọn DR, BDR. Việc bầu chọn dựa trên thông số:
      • Priority
      • Router ID: Router ID ko được bằng nhau. Nếu bằng nhau => thiết kế mạng sai.
      • Exchange: Các Router đang trang đổi gói DBD(database description).
      • OSPF hoạt động dựa theo cơ chế link-state nghĩa 1 Router phải tái hiện lại được bản đồ trong khu vực của nó. Nghĩa là bản đồ(database topology) 2 Router trong cùng 1 khu vực phải giống nhau. Để bản đồ 2 bên giống nhau thì 2 Router phải đưa bản đồ của chúng ra so sánh với nhau để đưa ra 1 bản đồ chung.
      • Gói tin DBD là 1 bản đồ tổng quản dùng để trao đổi bản đồ giữa các Router.
      • Ví dụ:
        • R1 có sanh sách lớp học A có các học viên a1,a2,a3… R2 có danh sách lớp học B có các học viên b1,b2,b3…
        • R1 gửi DBD có chứa bản đồ tổng quan qua cho R2. Nó là bản danh sách tổng quan của của lớp học A.
        • Khi R2 nhìn vào danh sách tổng quan thấy trong danh sách của nó ko có a1. Thì nói mới thực hiện gửi gói:
        • LSR(link state request): Để xin thông tin chi tiết a1 là ai…
        • LSU(link state update): Lúc này R1 sẽ trả lời lại thông tin chi tiết a1 là ai chi R2 thì gói tin trả lời này gọi là LSU. Trong LSU có chứa các gói
        • LSA(Link state Acknowledgement) để mô tả chi tiết các lớp mạng
        • Load: Đang trong giai đoạn xin và cho. LSR và LSU
        • Full: Khi cả bên đều nhận được nhưng gì mình muốn và cho những gì người ta muốn . Nếu bên nào nhận được thì sẽ gửi về gói ACK. Lúc này cả 2 Router lên trạng thái FULL.
          • Khi lên full thì bản đồ 2 Router phải giống nhau, 2 Router lên được trạng thái FULL thì người ta gọi đó là adjacency.
          • Còn nếu chỉ lên được 2-way thì người ta gọi là neighber.
    - Tình huống neighber và adjacency xảy ra khi nào:
    • Khi có DR, BDR. Tất cả Router chỉ cần giống DR, còn những other Router bên giữa là các neighber của nhau.

    neighber and adjacency EIGRP

    • Khi R1(là Router DR) nói chuyện với R2 và R3 bằng trạng thái Full thì lúc này chúng lên adjacency.
    • Riêng với R2 và R3 chỉ dừng lại ở trạng thái 2-way(Neighber) vì bản đồ của 2 Router này đều được trao đổi (so sanh chung) với R1 nên đương nhiên R2 và R3 sẽ có cùng bản đồ giống nhau. Vì vầy mà OSPF đã lược bỏ việc trao đổi bản đồ giữa R2 và R3 nên chúng chỉ dừng lại ở mức 2-way ( chỉ trao đổi gói helo với nhau)
    2. Authentication
    2.1. EIGRP: chỉ hỗ trợ authentication dạng MD5
    Các bước authentication:
    - Bước 1: Tạo thùng

    Code:
    (config)# key-chain abc
    - Bước 2: Bỏ key vào cái thùng
    Code:
    (config-keychain)#key 1
    - Bước 3: Đặt pass cho key
    Code:
    (config-keychain-key)#key-string 123456
    - Bước 4: Mang thùng đặt lên Interface
    Code:
    (config-if)# ip authentication mode eigrp 1 md5
    - Bước 5: Yêu cầu Hash md5 thùng đó
    Code:
    (config-if)# ip authentication key-chain eigrp 1 abc
    - Chú ý:
    • Nguyên liệu đầu vào của thuật toán Hash là số thứ tự key và key string.
    • Key và key string giữa 2 Router phải giống nhau mới lên Neighber được.
    • Nếu trong thùng có nhiều key mà ko định thời hạn sử dụng thì sẽ sử dụng key có số thứ tự nhỏ nhất.
    • Tùy từng thời điểm mà sử dụng từng key khác nhau
    • Khi lộ password muốn đổi password nhưng ko làm ảnh hưởng neighber.
      • 5/10/2014 passwold: 123. Bạn muốn thay đổi thành 1234, khi thay đổi password thì neighber sẽ bị down vì bạn sẽ ko kịp chỉnh password của cả 2 Router cùng 1 lúc.
      • Để giải quyết vấn đề trên bạn vào Router khai báo thêm 1 password mới 1234 và định thời gian cho nó là 6/10/2014 là được sử dụng. Tương tự bạn làm cho Router bên kia, khi đến thời điểm đó thì cả 2 Router sẽ tráo key 2 lên để sử dụng vì key 1 đã hết thời hạn.
      • Nhưng để làm được điều này các bạn đồng bộ thời gian bằng cách sử dụng NTP.
    2.2. OSPF
    - Cho phép authentication theo kiểu: Clear Text và Md5
    - Cấu hình:

    • Kích hoạt thực chứng năng kích hoạt bằng md5
      Code:
      (config-if)#ip ospf authentication message-digest
      (config-if)#ip ospf authentication message-digest –key 1 md5 123
    • 1: số thứ tự key
    • 123: password key
    - Đổi password trên OSPF
    • Bằng cách gõ thêm câu lệnh
      Code:
      R1(config-if)#ip ospf authentication message-digest –key 1 md5 123456
    • Lúc này trên Router nó sẽ thực hiện Hash 2 key cùng 1 lúc, nếu 1 trong 2 key trùng thì nó sẽ dùng
    • Bây giờ các bạn qua Router bên kia các bạn gõ thêm câu lệnh như trên:
      Code:
      R2(config-if)#ip ospf authentication message-digest –key 1 md5 123456
    • Thì lúc này bên R1 sẽ Hash đồng thời 2 key và gửi qua cho R2. Thằng R2 so sánh thấy trùng cả 2 key thì nó sẽ loại bỏ key cũ đi (key:123).
    • Cách xóa cũ lấy key mới trên được gọi là “youngest key” trong OSPF
    2.3. Không khuyến cáo sử dụng authentication vì:
    - Chậm, phức tạp
    -Việc capture giữa 2 Router khó xảy ra
    - Ngoài ra còn có các giao thức an toàn khác như VPN, Ip sec…


    Các bài lý thuyết trong
    Module 4: Configuring IP Connectivity and Routing

    1. [Chapter 4.1] Cơ chế hoạt động của DHCP Server
    2. [Chapter 4.2] Static route in ASA Firewall
    3. [Chapter 4.3] Dynamic Routing in Firewall ASA
    4. [Chapter 4.4] Dynamic Routing Protocols
    5. [Chapter 4.5] Dynamic Routing protocols
    - Tham khảo thêm các bài lab trong phần Module 4 này
    1. [Lab 4.1] Configure PPPoE on ASA 5525
    2. [Lab 4.2] Configure redistribute on Cisco ASA
    - Tham khảo các bài lý thuyết và lab về Cisco ASA được update tại mục
    - Các bài lab về (Authentication - Authorization - Accounting) AAA on Cisco ASA.
     
    Last edited: Aug 13, 2016
  2. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48

    3. STUB EIGRP


    3.1. EIGRP:
    - EIGRP sử dụng thuật toán DUAL.
    - Ý tưởng của thuật DUAL:
    • Successor: Nếu có 2 đường đi mà đường nào có giá trị FD(hay là metric) tốt hơn thì gọi là đường Successor
    • Khi đường Successor chết. Trong giao thức dynamic routing thì khi có sự thay đổi về mạng thì các Router phải nói chuyện lại với nhau.
    • Nhưng EIGRP cho rằng việc này gây mất thời gian, với EIGRP nếu successor chết thì dữ liệu lập tức đổ qua đường Feasible successor(đường phụ) đi liền. Để tăng tốc độ hội tụ.
    DUAL on EIGRP (1)


    - Theo sơ đồ để R1 đi tới lớp mạng A thì ta có 2 đường:
    • Đường 1: Đi từ R1 - > R2 - > R3 - > R6 có FD1= 3.
    • Đường 2: Đi từ R1 - > R4 - > R5 - > R6 có FD2= 10.
    • Vì FD1 có bandwith min nên đường 1 là successor. Giả sử đường 2 là Feasible Successor.
      • Giả sử R2 đứt thì dữ liệu sẽ tự động đổ xuống đường 2(đường dự bị). Dữ liệu lúc này sẽ từ R1 sẽ đi xuống R4.
      • Lúc này R4 sẽ làm gì? Nó sẽ gửi ngược về cho R1 vì từ R5 đến R6 sẽ đi qua R1 vì FD=4, còn qua R5 sẽ có FD=10.
    = > Hiện tượng Loop xảy ra, nên lúc này để đường R1 – >R4 –> R5 -> R6

    • Muốn trở thành đường Feasible successor phải thỏa điều kiện:
    AD < FD(successor).
    • AD chính là FD của Neighber = 10, FD(successor)=3. Mà 10 < 3 vô lý nên đường 2 ko thể là đường Feasible Successor
    - Nếu AD của R4 -> R5 -> R6 = 2 <3 thì đường 2 sẽ là đường Feasible Successor. Khi R2 đứt nó sẽ chuyển dữ liệu qua R4 và R4 sẽ ko gửi lại cho R1 vì đoạn đường từ R4 –> R5 –> R6 ngắn hơn đường R4-> R1 -> R2 -> R3 -> R6 ( FD=2 < FD=4)
    - Trong trường hợp R2 bị đứt mà đường 2 ko phải là Feasible Successor thì các Router sẽ bắt đầu nói chuyện với nhau bằng cách R1 gửi ra gói Query để hỏi R4 mạng A ở đâu? Lúc này R4 tự hiểu và nó sẽ ko gửi ngược lại cho R1 mà nó sẽ đi hỏi R5 để tìm mạng A ở đâu? Khi tìm được nó sẽ trở lời lại bằng gói Reply.
    • khi ko có đường Feasible Successor và nhờ vào gói tin Query và Reply để tìm ra được đường đi tới mạng A.
    Cisco ASA EIGRP Dynamic Routing (1)

    - Giả sử khi Core 2 bị mất đường Successor mà ko có đường Feasible Successor.
    - Lúc này Core 2 sẽ gửi ra các gói Query để tìm đường. Các Router láng giềng sẽ nhận được gói Query như Core 1,3 và R4,R5,R6.
    - Trong khi các R4,R5,R6 là các Router chi nhánh nhỏ nó chỉ có 1 đường, 1 mặt nhìn về Core
    - Khi đó R4,R5,R6 sẽ lập tức hỏi ngược về Core 3. Như vầy là câu hỏi bị Delay. Mà đường từ Core 2 sang R4 là đường WAN nên cần phải tiets kiệm Bandwidth.
    • Bỏ R4,R5,R6 vào vùng Stub để khi Core 2 ko query đến R4,R5,R6.
    • Stub trong EIGRP là giới hạn nhận gói tin Query.
    - Trong trường hợp đường Core 2 sang Core 3 đứt, Core 2 với Core 1 đứt thì Core 2 có nên Query xuống R4, rồi R4 Query lên Core 3 ?
    • Trong thực tế thì người ta cho đứt luôn nghĩa là R4 sẽ cho vào vùng Stub vì dữ liệu từ tầng Core mà đổ về R4 thì nó sẽ chịu ko nổi mà đường Core 2 – R4 là đường WAN nữa.
    3.2. OSPF
    - Stub trong OSPF thì khác hoàn toàn với EIGRP.
    - LSA là 1 thông điệp mô tả các lớp mạng bên trong.

    3.2.1. Các loại LSA OSPF


    - LSA type 1:
    • Do Router sinh ra
    • Dùng để vẽ topology trong area của mình
    • Không đi xuyên qua ABR (Router 1 mặt nhìn về area 0, một mặt nhìn về area # 0). Nếu LSA type 1 mà xuyên qua ABR thì nó sẽ vẽ được hết toàn bộ các area, nên người ta mới ko cho nó đi xuyên qua ABR.
    - LSA type 2:
    • Tương tự như LSA type 1, nhưng nó do router DR sinh ra.
    • Chứa IP của DR.
    - LSA type 3:
    Cisco ASA LSA OSPF (1)

    • Do ABR sinh ra
    • Phân phối lớp mạng qua lại giữa 2 area.
      • R1 ping được tới Lo 0 vì R2 đã phân phối lớp mạng qua lại. Nhưng R1 không biết lớp mạng Lo 0 Là của ai mà nó chỉ biết muốn ping tới Lo 0 thì phải gửi đến R2
      • R1 chỉ vẽ bản đồ trong khu vực của nó. Router trong cùng 1 khu vực thì nó mới vẽ bản đồ và nó biết chính xác lớp mạng đó của ai, có bao nhiêu Router để đến đó...
      • Còn khác khu vực thì nó phải thông qua LSA type 3(chỉ là 1 lớp mạng thuần túy) do ABR sinh ra
    • Làm việc theo cơ chế Regenerate
      • R2 có lớp mạng A là do LSA type 1. R2 muốn tới lớp mạng A thì đi tìm Router-ID 1.1.1.1. R2 đủ sức biết Router-ID 1.1.1.1 nằm ở đâu có bao nhiêu lớp mạng… vì nó chung 1 vùng
      • R3 có thông lớp mạng A do LSA type 3 do Router-ID 2.2.2.2 sinh ra. R3 muốn tới lớp mạng A thì thông qua Router-ID 2.2.2.2
      • R4 cũng có thông tin lớp mạng A do LSA type 3 do Router 3.3.3.3 sinh ra. R4 muốn đi đến lớp mạng A thì đi tìm Router-ID 3.3.3.3
    => Cơ chế thay đổi sở hữu gói tin trên gọi là cơ chế Regenerate.
    Cisco ASA LSA OSPF (2)
    - LSA type 5:
    • Do ASBR (autonomous system boder Router: là Router có 1 mặt nhìn về OSPF, 1 mặt nhìn về phía định tuyến khác) sinh ra
    • Làm theo cơ chế Flood
    • Thay vì Regenerate thì ta Redistribute lớp A vào R2 luôn. Thì việc Redistribute là do LSA type 5 do ASBR sinh ra
      • R2 có lớp mạng A nhờ LSA type 5 do R1 sinh ra vì nó Redistribute từ ngoài vào.
      • R3 có lớp mạng A nhờ R2 chuyển tiếp LSA type 5 do R1 sinh ra. R3 muốn đi đến lớp mạng A thì phải đi tìm Router-ID 1.1.1.1. R4 có lớp mạng A nhờ R3 chuyển tiếp LSA type 5 do R1 sinh ra. R3 muốn đi đến lớp mạng A thì phải đi tìm Router-ID 1.1.1.1
    => Sở hữu gói tin không thay đổi từ lúc nguyên thủy đến lúc chạy xuyên suốt lớp mạng.
    • R2 đủ sức biết Router-ID 1.1.1.1 là ai vì chung area
    • R3 có đủ sức biết Router-ID 1.1.1.1 là ai ko? Không, khi R3 tra trong database thì ko thấy tên Router-ID 1.1.1.1 là ai (theo cách làm việc OSPF thì nó sẽ tìm tên trước rồi từ tên mới tra ra IP phù hợp để gửi ra). Nên nó ko gửi ra được.
    => Phát sinh LSA type 4


    Cisco ASA LSA type 5 OSPF (1)

    - LSA type 4:
    • Do ABR sinh ra
    • Dùng để chỉ cách đi tìm ASBR.
      • R2 biết Router-ID 1.1.1.1 nằm ở đâu nên ko cần hướng dẫn
      • Trong lúc forward LSA type 5 cho R3 thì nó kèm thêm LSA type 4 để hướng dẫn R3 rằng: muốn đi tìm Router-ID 1.1.1.1 thì đi tìm Router-ID 2.2.2.
      • Tương tự, R3 đẩy tiếp LSA type 5 vào cho R4 và nó kèm them LSA type 4 để hướng dẫn: muốn đi tìm Router-ID 1.1.1.1 thì đi tìm Router-ID 3.3.3.3
    => R3 muốn ping lớp mạng A thì
    • Muốn tìm lớp mạng A thì đi tìm Router-ID 1.1.1.1. Đầu tiên nó sẽ lookup LSA type 5.
    • Mà muốn tìm Router-ID 1.1.1.1 thì phải để tìm Router-ID 2.2.2.2 là LSA type 4.
    • Mà muốn gặp Router-ID 2.2.2.2 là phải gặp IP 10.0.0.2 là LSA type 1 vì chung area nên có next-hop.

    3.2.2. STUB OSPF



    Cisco ASA Stub OSPF (1)

    - Theo mô hình mạng trên thì R3 thấy toàn bộ các lớp mạng: area 0, area 2… Mà R3 chỉ là 1 Router ở chi nhánh và chỉ có 1 next-hop. Nên R3 ko cần học quá nhiều lớp mạng làm gì.
    - Trong trường này R3 chỉ cần 1 default-route trỏ về R1 là đủ vì biết nhiều đường cũng ko có tác dụng trong khi chỉ có 1 next-hop duy nhất.
    - Để ko nhận các thông tin từ area khác người ta đưa area đó vào vùng gọi STUB.
    - Có 4 loại STUB(nhưng chỉ xài có 1)
    • Stub: ko nhận type 5
    • Totally stubby: ko nhận type 5&3
    • NSSA: ko nhận type 5
    • NSSA totally: ko nhận 5&3
    - Giả sử đưa area 1 vào vùng Stub để giới hạn bớt thông tin định tuyến bên trong. Khi Reddistribute… thì nó ko quan tâm
    - Nếu đưa area 1 vào totally stub thì lúc này nó sẽ ko nhận type 5&3. Nghĩa là nó vừa ko nhận thông tin Redistribute, ko nhận thông lớp mạng từ area khác vì đã có default-route.
    • Stub là giới hạn thông tin LSA mà vùng đó muốn nhận.
    • Stub áp trên area nên để cấu hình bạn phải cấu hình trên tất cả các Router thuộc vùng đó.
    - Vùng nào có chữ Totally là do Cisco chế thêm vào
    - Giả sử lúc này có khách hàng muốn đấu nối vào R3 và thực hiện Redistribute vào:
    Cisco ASA Stub OSPF (2)

    • Router-Client redistribute vào R3 sử dụng LSA type5, lúc này R3 đóng vai trò làm ABR.
    • Mà R3 nằm trong vùng stub ko nhận LSA type 5.
    • Lúc này, các bạn mới sử dụng đến NSSA. Lúc này R3 Redistribute sẽ sử dụng LSA 7 thay vì là LSA type 5 nên nó đi qua được vùng Stub
    • Sau này R1 mới thực hiện convert LSA type 7 thành type 5.
      • Khác biệt giữa NSSA và stub thường là khi Redistribute thì NSSA sử dụng type 7 còn Stub dùng type 5.
      • Khi cấu hình nên chọn NSSA để dự phòng cho sau này.
    • Các loại Stub 1,2,4 thì default-route tự động sẽ được thêm vào, riêng loại stub 3 bạn cần thêm câu lệnh “default-route information originate”.
    - Giả sử lúc này R3 chỉ muốn học 1 mạng 10.0.0.0 từ R4. Để làm được bạn phải có 1 ACL permit mạng 10.0.0.0, còn lại thì deny. Sau đó các bạn dùng Filter-list để áp ACL lên R1. Mặc định R1 quang hết LSA type 3 của các lớp mạng, nên khi Filter-list nó sẽ kiểm tra trong ACL chỉ cho LSA type 3 có mạng 10.0.0.0 đi qua còn lại deny
    - Hoặc sử dụng suppess trong summary để filter.
    • Area rang suppess : type 3
    • Summary address suppess: type 5
    VD: sum mạng 192.168.1.0/24 và 192.168.2.0/24 thành 192.168.1.0/23. Nếu có từ khóa “suppess” thì sau khi sum xong nó giữ lại, nó ko quăng vào bên trong.
     
    Last edited: Aug 13, 2016
  3. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48
    4. Redistribute(kéo về)
    - Bước 1: Xác định vị trị Reddistribute.
    - Bước 2:
    • Xác định lớp mạng mà nó sở hữu. Bạn muốn phân phối lớp mạng A vào EIGRP mà bản thân Router ko có lớp mạng A(do filter,acl…) thì làm sao phân phối được.
    • Kéo về nghĩa là kèo lớp mạng A vào trong EIGRP thì bạn phải đứng ở mode Router-EIGRP
    - Bước 3: Seek Metric(metric ban đầu)
    • Khi Redistribute thì Metric phải ở lại vì quan điểm tính Metric của 2 giao thức khác nhau. Như kéo EIGRP có Metric=64 mà kéo vào trong RIP thì lỗi. Vì Rip Metric max=16
    • Nên phải có Metric mới
      Bất kỳ ----- > RIP & EIGRP: default = Infinity
      Bất kỳ ----- > OSPF: default = 20

    Redistribute từ EIGRP sang OSPF


    Code:
    (config)#router ospf 1
    (config-route)#redistribute eigrp 10 subnet
    • Subnet: Nếu ko có subnet thì nó chỉ kéo các major-network.
    • Nên có từ khóa subnet

    Redistribute từ EIGRP sang RIP


    Code:
    (config)#router rip
    (config-route)#redistribute eigrp 10 metric 5
    • Phải có Metric vì bất kỳ --> Rip thì infinity

    Redistribute từ OSPF sang EIGRP


    Code:
    (config)#router eigrp 1
    (config-route)#redistribute ospf 1 metric 100000 100 255 1 1500
    • 100000: bandwith
    • 100: delay
    • 255: release
    • 1: load
    • 1500: MTU
    Các thông số này do K-value quyết định. EIGRP chỉ sử dụng Bandwith và Delay

    5. AD(Administrative distance)


    - Dùng để thể hiện độ ưu tiên giữa các giao thức định tuyến
    Redistributed in Cisco ASA
    - Giả sử trên Router có 2 đường chạy 2 giao thức OSPF và RIP. Mặc định Router sẽ chọn đường OSPF vì có AD nhỏ hơn. Nhưng ở đây mình muốn Route dùng đường RiP để đi thì sao?
    - Lúc này bạn cần chỉnh AD của OSPF cao hơn hay Ad của RIP xuống thấp hơn.
    - Để chỉnh AD có 2 cách

    5.1. Cách 1: Chỉnh tổng quát
    - Là chỉnh giá trị mặc định. VD: OSPF = 90 mình sẽ chỉnh OSPF =120. Lúc này trên bảng định tuyến các đường đi nào là OSPF đều có AD=120
    - EIGRP
    Code:
    (config)#router eigrp 1(config-route)# distance eigrp X Y

    • X: internal (default =90)
    • Y: External ( default AD =170)
    - OSPF
    Code:
    (config)#router ospf 1
    (config-route)# distance ospf X Y Z
    • X: intra area (default = 110)
    • Y: inter area (default = 110)
    • Z: External (default = 110)
    VD: Trong bảng định tuyến OSPF có chữ
    • O: lớp mạng này học từ LSA type 1
    • OIA: lớp mạng này học từ LSA type 3
    • OE (External): lớp mạng này học từ LSA type 5
    • ON (NSSA): lớp mạng này học từ LSA type 7
    - 3 biến số X, Y, Z để chỉnh tất cả các loại chữ O, OIA, OE, ON ở trên

    5.2. Cách 2: Chỉnh chi tiết:

    - Là chỉnh 1 đường nào đó. VD: có 2 đường đi OSPF bạn chỉ chỉnh 1 đường của OSPF lên AD cao hơn.
    - EIGRP
    Code:
    (config)#router eigrp 1
    (config-route)# distance X Y Z

    • X: số AD muốn chỉnh
    • Y: địa chỉ next-hop của lớp mạng muốn chỉnh
    • Z: là số ACL mô tả lớp mạng muốn chỉnh
    - OSPF
    Code:
    (config)#router ospf 1
    (config-route)# distance X t Z

    • X, Z như EIGRP
    • t: là Router-ID của Router sở hữu lớp mạng đó.
    [/UIMG][/INDENT]
     
    Last edited: Aug 13, 2016
  4. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48
    Summary
    1. Packet Helo
    - Gói tin Helo dùng để làm gì ?
    - ý nghĩa thời gian Hole time trong EIGRP và dead interval trong OSPF ?

    2. Authentication
    - Cấu hình chứng thực trong OSPF và EIGRP ?
    - Cách đổi key trong OSPF và EIGRP mà ko làm neighber bị down?

    3. Stub
    - Khái niệm Stub trong EIGRP
    - Các loại LSA trong OSPF?
    - Các trạng thái trong OSPF ? phân biệt adjacency và neighber ?
    - Chức năng của Stub trong OSPF ? Có bao nhiêu loại Stub ? sự khác biệt giữa stub và NSSA?

    4. Redistribute
    - Redistribute dùng để làm gì ?
    - Cấu hình Redistribute ?

    5. Administrative Distance
    - Ad là gì ? chức năng ?
    - Cách thức chỉnh AD ?
     
    Last edited: Jul 4, 2016
  5. cuongpm

    cuongpm New Member

    Joined:
    Oct 26, 2015
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Bài nãy cũng mất ảnh nhé Admin
     
  6. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48

    Đã upload lại hình cho bài viết. Thanks bạn.
     

Share This Page