Cấu hình PPPoE thực tế trên Router Cisco

Discussion in 'Lab' started by phanphong, Aug 21, 2014.

  1. phanphong

    phanphong Super Moderator

    Joined:
    Jun 24, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I. Mô hình
    1. Mô hình
    - Mô hình cấu hình pppoe trên Router thực tế .

    [​IMG]


    2. Ý tưởng:

    - Trong công ty của khách hàng họ sài đường truyền cáp quang 32M với con Linksys cùi bắp nên mạng lúc rất hay bị lag khi có khoảng 20 user cùng đi ra internet một lượt ( vì phần cứng của linksys chỉ chủ yếu sài cho hộ gia đình nhỏ ) Họ nhờ mình qua thay cho con router cisco (nhưng cấu hình router cisco thì mấy tay ngang ít khả năng làm một vì ngại cấu hình, 2 vì toàn lệnh với lệnh )
    - Có 2 cách để cấu hình :
    • Cách thứ I : khi cấu hình con router cisco bạn phải gọi điện lên nhà mạng internet để xin người ta reset địa chỉ Mac của con router Linksys đi thay vào địa chỉ Mac con router cisco ( vì ISP người ta quản lý địa chỉ MAC để dễ quản lý thiết bị )
    • Cách thứ II: bạn chỉ cần láy địa chỉ MAC của con router Linksys gán vào cổng của con Cisco thế là khỏi phải ý a í ới gọi điện cho mắc công

    II. Triển khai

    - Sau đây mình sẽ giải quyết bài toán này cho máy bạn
    - Trước tiên vào địa chỉ http://192.168.1.1 theo đường link sau
    [​IMG]


    - Copy MAC ghi ra Notepad
    - Bây giờ mới là công đoạn cực nhọc đây
    - Tạo cổng Dailer0 và gán Mac address vào
    - Để negotiated để thương lượng địa chỉ IP được cấp động từ ISP
    Code:
    interface Dialer0
    mac-address [COLOR=#ff0000]90f6.52b0.295f [/COLOR]
    mtu 1492 
    ip address negotiated
    ip nat outside 
    ip virtual-reassembly
    encapsulation ppp 
    ip tcp adjust-mss 1452 
    dialer pool 1 
    ppp pap sent-username svuit.com_ftth_hcm password 0 vbdcbbde 
    ppp ipcp dns accept
    - Tiếp tục làm việc trên cổng interface chính
    Code:
    interface FastEthernet0/0 
    description Connect to Internet
     mac-address [COLOR=#ff0000]90f6.52b0.295f [/COLOR]
    no ip address 
    duplex auto 
    speed auto 
    pppoe enable group global 
    pppoe-client dial-pool-number 1
    !
    interface FastEthernet0/1 
    description Connect to LAN 
    ip address 192.168.1.0 255.255.255.0 
    ip nat inside 
    ip virtual-reassembly 
    duplex auto 
    speed auto
    - Đừng quên defaul route cho cổng dialer0 nhé
    Code:
    ip route 0.0.0.0 0.0.0.0 Dialer0
    Như vậy là finish rồi chúc các bạn thành công
     

    Attached Files:

    • 2.jpg
      2.jpg
      File size:
      30.7 KB
      Views:
      31
    Last edited: Aug 21, 2014
  2. vo duc trung

    vo duc trung New Member

    Joined:
    Feb 24, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Viet Nam
    Nếu như từ convecter cắm trực tiếp vào router 1841 , vào cổng F0/0 , thì cấu hình như thế nào bạn
    (cấu hình PPoE trên con 1841). thanks các bạn
     
  3. redhat

    redhat New Member

    Joined:
    Feb 13, 2018
    Messages:
    14
    Likes Received:
    4
    Trophy Points:
    3
    Gender:
    Male
    Nếu là PPoE thì cấu hình tương tự như trên bạn nhé
     
  4. vo duc trung

    vo duc trung New Member

    Joined:
    Feb 24, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Viet Nam

Share This Page