[BGP] Lab 01- Cấu hình BGP cơ bản -part 1

Discussion in 'Lab' started by root, Feb 24, 2016.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48
    Đây là bài lab hướng dẫn cấu hình BGP cơ bản
    - Cấu hình eBGP sử dụng loopback và physical interface sử dụng update-source và ebgp-multihop
    - Cấu hình iBGP ở dạng full mesh và cấu hình next-hop-self cho các Router biên
    Đây là file cấu hình của bài lab: DOWNLOAD
    Đây là file hướng dẫn cấu hình bài LAB BGP bằng file word: DOWNLOAD

    I. Chuẩn bị
    1. Sơ đồ triển khai

    1.1. Sơ đồ triển khai bài Lab.
    [​IMG]

    1.2. Sơ đồ IP

    Sơ đồ phân bố IP cho các Router.

    [TABLE="class: grid, width: 800"]

    Router
    Interface
    IP address

    R1
    f0/0
    f0/1
    loopback 0

    192.168.14.1/24
    192.168.12.1/24
    1.1.1.1/24


    R2
    f0/0
    f0/1
    loopback 0

    192.168.12.2/24
    192.168.23.2/24
    2.2.2.2/24


    R3
    f0/0
    f0/1
    loopback 0

    192.168.23.3/24
    192.168.35.3/24
    3.3.3.3/24


    R4
    f0/0
    loopback 0
    loopback 1

    192.168.14.4/24
    4.4.4.4/24
    44.44.44.44/32


    R5
    f0/0
    loopback 0
    loopback 1

    192.168.35.5/24
    5.5.5.5/24
    55.55.55.55/32

    [/TABLE]


    1.3. yêu cầu:

    • Cấu hình R1, R2, R3 tham gia định tuyến OSPF với Area 0. (tất cả các interface loopback0 cũng tham gia định tuyến OSPF).
    • Cấu hình R1 và R4 tham gia định tuyến BGP sử dụng card loopback để tham gia neighbor. R4 sẽ quảng bá network 44.44.44.44/43
    • Cấu hình R3 và R5 tham gia định tuyến BGP sử dụng interface physical để tham gia neighbor. R5 sẽ quảng bá network 55.55.55.55/43

    II. Cấu hình

    2.1. Cấu hình cơ bản

    Cấu hình IP cho các Router

    [TABLE="class: outer_border, width: 800"]

    //Config Router R1
    R1(config)# interface f0/0
    R1(config-if)# ip address 192.168.14.1 255.255.255.0
    R1(config-if)# interface f0/1
    R1(config-if)# ip address 192.168.12.1 255.255.255.0
    R1(config-if)# interface loopback0
    R1(config-if)# ip address 1.1.1.1 255.255.255.0

    //Config Router R2
    R2(config)# interface f0/0
    R2(config-if)# ip address 192.168.12.2 255.255.255.0
    R2(config-if)# interface f0/1
    R2(config-if)# ip address 192.168.23.2 255.255.255.0
    R2(config-if)# interface loopback0
    R2(config-if)# ip address 2.2.2.2 255.255.255.0

    //Config Router R3
    R3(config)# interface f0/0
    R3(config-if)# ip address 192.168.23.3 255.255.255.0
    R3(config-if)# interface f0/1
    R3(config-if)# ip address 192.168.35.3 255.255.255.0
    R3(config-if)# interface loopback0
    R3(config-if)# ip address 3.3.3.3 255.255.255.0

    //Config Router R4
    R4(config)# interface f0/0
    R4(config-if)# ip address 192.168.14.4 255.255.255.0
    R4(config-if)# interface loopback0
    R4(config-if)# ip address 4.4.4.4 255.255.255.0
    R4(config-if)# interface loopback1
    R4(config-if)# ip address 44.44.44.44 255.255.255.255

    //Config Router R5
    R5(config)# interface f0/0
    R5(config-if)# ip address 192.168.35.5 255.255.255.0
    R5(config-if)# interface loopback0
    R5(config-if)# ip address 5.5.5.5 255.255.255.0
    R5(config-if)# interface loopback1
    R5(config-if)# ip address 55.55.55.55 255.255.255.255

    [/TABLE]


    2.2. Cấu hình định tuyến OSPF
    - Cấu hình định tuyến OSPF cho các Router R1, R2 và R3.
    [TABLE="class: outer_border, width: 800"]

    R1(config)#router ospf 1
    R1(config-router)#router-id 1.1.1.1
    R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
    R1(config-router)#network 192.168.12.1 0.0.0.0 area 0

    R2(config)#router ospf 1
    R2(config-router)#router-id 2.2.2.2
    R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
    R2(config-router)#network 192.168.12.2 0.0.0.0 area 0
    R2(config-router)#network 192.168.23.2 0.0.0.0 area 0

    R3(config)#router ospf 1
    R3(config-router)#router-id 3.3.3.3
    R3(config-router)# network 3.3.3.3 0.0.0.0 area 0
    R3(config-router)# network 192.168.23.3 0.0.0.0 area 0

    [/TABLE]


    - Kiểm tra bảng định tuyến của Router R1 sẽ có các route của các Router tham gia định tuyến OSPF.
    [​IMG]

    - Tương tự chúng ta kiểm tra bảng định tuyến của Router R2.

    [​IMG]

    - Bảng định tuyến của Router R3

    [​IMG]
     
  2. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,186
    Likes Received:
    48
    Trophy Points:
    48
    2.3. Cấu hình định tuyến BGP sử dụng card loopback

    - Cấu hình định tuyến BGP giữa Router R1 và R4 sử dụng card loopback để thiết lập Neighbor.
    [TABLE="class: outer_border, width: 800"]

    R1(config)#router bgp 123
    R1(config-router)# neighbor 4.4.4.4 update-source Loopback0
    R1(config-router)# neighbor 4.4.4.4 remote-as 65004
    // vì chúng ta sử dụng card loopback để thiết lập neighbor nên cần phải “update-source” cho card loopback0
    R1(config-router)# neighbor 4.4.4.4 update-source Loopback0
    // Vì sử dụng card loopback để thiết lập neighbor nên TTL phải >=2
    R1(config-router)# neighbor 4.4.4.4 ebgp-multihop 255
    // Để R1 thiết lập Neighbor được với R4 thì R1 phải nhìn thấy loopback của R4.
    R1(config)# ip route 4.4.4.4 255.255.255.255 14.14.14.4


    // Cấu hình BGP trên Router R4
    R4(config)# router bgp 65004
    R4(config-router)# network 44.44.44.44 mask 255.255.255.255
    R4(config-router)# neighbor 1.1.1.1 remote-as 123
    R4(config-router)# neighbor 1.1.1.1 ebgp-multihop 5
    R4(config-router)# neighbor 1.1.1.1 update-source Loopback1
    R4(config)# ip route 1.1.1.1 255.255.255.255 14.14.14.1

    [/TABLE]


    - Kiểm tra Router R1 xem đã thiết lập BGP neighbor với Router R4 chưa
    [​IMG]

    - Kiểm tra bảng routing BGP trên Router R1 chúng ta sẽ thấy network 44.44.44.44 được R4 quảng bá cho.
    [​IMG]

    [​IMG]

    - Tương tự chúng ta kiểm tra bảng Neighbor BGP trên Router R4 xem nó đã thiết lập Neighbor với Router R1 chưa.
    [​IMG]

    - Kiểm tra bảng định tuyến của R4
    [​IMG]


    2.4. Cấu hình định tuyến BGP sử dụng interface physical

    - Cấu hình định tuyến BGP giữa Router R3 và R5.
    [TABLE="class: outer_border, width: 800"]

    R3(config)#router bgp 123
    R3(config-router)# neighbor 35.35.35.5 remote-as 65005

    R5(config)# router bgp 65005
    R5(config-router)# network 55.55.55.55 mask 255.255.255.255
    R5(config-router)# neighbor 35.35.35.3 remote-as 123

    [/TABLE]


    - Kiểm tra bảng neighbor BGP trên Router R3 xem nó đã thiết lập neighbor BPG với R5 chưa.
    [​IMG]

    - Kiểm tra bảng định tuyến trên Router R3

    [​IMG]

    [​IMG]

    - Tương tự chúng ta kiểm tra bảng Neighbor BGP trên Router R5
    [​IMG]

    - Kiểm tra bảng định tuyến trên Router R5
    [​IMG]
     

Share This Page