CCNA [Bài 23] Hướng dẫn cấu hình EtherChannel

Discussion in 'Lý thuyết' started by root, Mar 13, 2014.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,133
    Likes Received:
    60
    Trophy Points:
    48

    Hướng dẫn cấu hình Etherchannel


    Etherchannel được sử dụng để group các port vật lý dựa trên giao thức LACP(IEEE) và PAgP (cisco).
    Ehterchannel là giao thức độc quyền của Cisco dùng để ghép nhiều đường link ethernet lại thành một đường truyền logical để tăng băng thông đường truyền lên.

    - Các viết lý thuyết tiếp theo trong chương trình CCNA
    1. [Bài 24] Tìm hiểu về IPv6
    2. [Bài 24.1] Cấu hình IPv6 và định truyến trên IPv6
    3. [Bài 25] Cấu hình PPP authentication PAP và CHAP
    - Các bài lab về Cấu hình Etherchannel

    1. [Lab 14] Cấu hình EtherChannel Layer 2 và Layer 3
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.

    I. Tại sao phải dùng Etherchannel ?


    - Khi có nhiều kết nối giữa 2 Switch mà Bandwidth của bạn bị hạn chế thì bạn phải tăng Bandwidth của bạn lên bằng cách gắn thêm 1 sợi dây giữa 2 SW
    - Lúc này sẽ nảy sinh Spanning-tree vì STP luôn tồn tại trong Switch nên giải pháp này không được

    tim hieu Etherchannel


    II. EtherChannel là gì


    - Lúc này người ta đưa ra 1 công nghệ Etherchannel để bó 2 cổng vật lý thành 1 cổng logic gọi là Port-channel

    1. Đặc điểm Etherchannel:
    - bandwitdh là tổng bandwidth của các cổng vật lý
    - Loadbancing tốt
    - STP không có tính dự phòng cao như EtherChannel. Khi 1 dây đứt thì vẫn còn 1 dây chạy EtherChannel mạng không bị đứt nên EtherChannel mang tính Redundacy cao
    - Port-channel có thể hỗ trợ cả layer 2 và layer 3.

    • khi port-channel ở layer 2 thì cần lưu ý cost của port channel trong Spanning-tree.
    • port-channel ở layer 3 thì giống như SVI

    cau hinh Etherchannel

    2. Giao thức chạy trong EtherChannel
    - EtherChannel có 2 loại

    • PAgP: độc quyền của Cisco
    • LACP: IEEE
    • Static EtherChannel: Lúc này không cần phải chọn PagP hay LACP mà chúng sẽ tự thương lượng chọn PagP hay LACP
    - Các mode trên PAgP
    • mode on: không cần chọn protocol, chúng sẽ tự thương lượng với nhau.
      //mode active là của LACP protocol

    Code:
    switch(config)# interface fastethernet 0/23
    switch(config-if)# channel-group 1 mode active
    switch(config)# interface fastethernet 0/24
    switch(config-if)# channel-group 1 mode active
    switch(config)# interface port-channel 1

    - Hoặc thay vì vào từng interface thì bạn có thể vào 1 range để bó cho nhanh

    switch(config)# interface range f 0/23-24
    switch(config-range-if)# channel-group 1 mode active

    - Config port-channel
    • Lúc này “show ip int brief” sẽ thấy xuất hiện thêm 1 interface là port-channel 1
    • Bạn có thể sử dụng port-channel 1 này như là 1 cổng vật lý(có thể đặt IP, routing, …)

    switch(config)# interface port-channel 1
    switch(config-if)# switchport mode trunk
    switch(config-if)# switchport trunk native vlan 99
    switch(config-if)# switchport trunk allowed vlan 2,3,99

    - Để xem 1 cổng trong 1 EtherChannel



    - Xác định Port-channel layer nào

    • Po1(SU): S là nó đang thuộc layer 3


    5. Load balancing trong etherchannel

    - Mặc định EtherChannel load balancing theo Source và Des IP
    - Khi cần load balancing theo kiểu MAC ta có thể thay đổi. Nhưng điều này rất hiếm và không nên


    Code:
    switch(config)# port-channel load-balance type
    switch# show etherchannel load-balance
    Etherchannel Load-Balancing Configuration:
    src-dst-ip
    * Lưu ý:
    - Nên bó số lượng interface là chẵn vì không phải khi bó là nó share đều Bandwidth theo kiểu lấy tổng bandwidth chia cho số cổng mà nó tính dựa vào loadbancing Source hay Des IP.

    • Lúc này nó sẽ Hash Source hay Des IP này thành 1 bit cuối cùng bit số 0 đi đường số 1, bit 1 đi đường số 2
    • Khi chọn 3 cổng thì nó Hash 2 bit cuối thì tương đương với 4 giá trị 0,1,2,3. Bit 0 đi đường số 1, Bit 1 đi đường số 2, Bit 2 đi đường số 3 và bit 3 nó phải quay vòng lại dây số 1
    => Lúc này nó load EtherChannel sẽ không đều
    => Nên dùng số Port chẵn thường là dùng 2 và 4 port
     
    Last edited: Jul 25, 2016
  2. huy8114644

    huy8114644 New Member

    Joined:
    Jul 30, 2014
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    cảm ơn bài của anh root. Theo em được biết thì EtherChannel bó tối đa được 8 đường ( cùng hoạt động ) còn nếu có đường thứ 9 trở đi thì các đường đó sẽ thành đường dự phòng, khi 1 đường bị đứt thì các đường đó lên thay, cơ chế bầu chọn đường chính phụ cũng dựa vào system-priority và port- priority. Có vần đề gì thì anh root sửa giúp em :D
     
  3. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,133
    Likes Received:
    60
    Trophy Points:
    48
    hi huy8114644,

    Theo mình thì PagP supports 8 ports max và LACP supports 16 ports max (Nó sử dụng 8 port và 8 ports còn lại là standby (backup ports).
     
  4. khoa.ntk01

    khoa.ntk01 New Member

    Joined:
    Jan 4, 2015
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    mất hình ảnh nha root.....^_^
     
  5. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,133
    Likes Received:
    60
    Trophy Points:
    48
    hi bạn,

    mình đã upload lại hình cho bài này rồi nhé.

    Thanks bạn nhé!
     
  6. nontakjaba

    nontakjaba Member

    Joined:
    Dec 10, 2017
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    16
    Gender:
    Male
    Cam on ban da chia se
     

Share This Page