CCNA [Bài 17] Cấu hình VLAN trunking và VTP Cisco

Discussion in 'Lý thuyết' started by root, Feb 11, 2014.

  1. root

    root Well-Known Member

    Joined:
    Dec 31, 2012
    Messages:
    1,133
    Likes Received:
    59
    Trophy Points:
    48

    Tìm hiểu VLAN, VLAN trunking và giao thức VTP trên Cisco


    VLAN là gì, hướng dẫn cấu hình VLAN. Tìm hiểu và cấu hình VLAN trunking. Cấu hình VTP VLAN trên switch cisco. Tìm hiểu Revision number Cisco switch và cách thay đổi Revision number Cisco switch.
    Bài này chúng ta sẽ kết hợp với bài cấu hình subinterface trên Router. Sau đó sẽ cấu hình trunking vlan giữa Sub interface trên Router với VLAN trên Switch

    - Các viết lý thuyết tiếp theo trong chương trình CCNA

    1. [Bài 18] Cisco Multilayer Switch Network Diagram
    2. [Bài 19] Tìm hiểu giao thức Spanning tree Protocol
    3. [Bài 20] Hướng dẫn cấu hình ACL Router Cisco
    Tổng hợp các bài viết lý thuyết và LAB chương trình CCNA của CISCO.

    I. VLAN là gì ?

    1. VLAN
    : là kỹ thuật chuyển mạch lớp 2 và định tuyến của lớp 3 để giới hạn miền đụng độ và miền quảng bá.
    - Phân nhóm user theo từng phòng ban( mỗi VLAN là một subnet riêng biệt)
    Ví dụ: 1 switch có 24 port ta chia

    • port 1-8 là phòng sale
    • port 9-16 là phòng kinh doanh
    - VLAN đáp ứng chất lượng dịch vụ QoS.
    Ví dụ: trong mạng có nhiều traffic như : Voice, management, data mà ta cần ưu tiên traffic voice đi trước sau đó tới management, data … thì ta phải gán từng traffic cho từng VLAN(vì SW sử dụng công nghệ share bandwith) và set độ ưu tiên cho từng VLAN

    2. Cấu hình VLAN
    - Tạo VLAN bằng lệnh


    SW(config)#vlan n
    • n thuộc 0 – 4095
    • VLAN 0 và 4095: không được sử dụng(đã fix vào IOS ko được sử dụng)
    • VLAN 1 : VLAN default
    • VLAN 2 – 1001: Normal range(có thể sử dụng được)
    • VLAN 1002 đến 1005 : VLAN default, dùng để kết nối với các hệ thống mạng khác như : FDDI, token Ring …(không kết nối được system Ethernet)
    • VLAN 1006 – 4094 : VLAN extended range( dùng cho các Switch Transparent)
    - Gán port vào VLAN
    Code:
    Switch(config)#interface f0/1
    • Chuyển SW về mode access(mode access dùng để kết nối các end user)
    Code:
    Switch(config-if)#switchport mode access
    • Gán các port vào VLAN của mình
    Code:
    Switch(config-if)#switchport access vlan n
    - Gán 1 range port vào VLAN
    Code:
    Switch(config)#interface range f0/1-8
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan n
    - Các dòng 12.1 về sau cho phép đặt tên cho VLAN(các VLAN default thì ko đặt tên được)
    Code:
    Switch(config)#vlan 2
    Switch(config-vlan)#name sale

    3. Cấu hình subinterface trên Cisco

    - Hướng dẫn cấu hình subinterface trên Router và Switch Cisco.

    cau hinh subinterface Cisco


    - Lệnh để chia 1 interface vật lý thành các interface luận lý

    Code:
    Router(config-if)#interface f0/1.n
    • ta có thể tạo 2 tỷ cổng luận lý. Thông thường ta tạo khoảng 3-4 cổng luận lý cho mỗi VLAN(khi tạo nhiều thì mạng sẽ chậm vì nó chia bandwith cho từng cổng luận lý tương ứng với mỗi VLAN)
    • vào mode sub-interface để tạo default-gateway cho VLAN
    Router(config-subif)#encapsulation dot1Q n
    Router(config-subif)#ip address 192.168.1.254 255.255.255.0
    Router(config-subif)#no shutdown
    - Lưu ý: "no shutdown" hoạt động khi cổng vật lý phải "no shutdown"
    • Kỹ thuật chia sub interface trên được gọi là kỹ thuật InterVLAN routing(kỹ thuật định tuyến giữa các VLAN)
    • Việc định tuyến giữa các VLAN bằng thiết bị VLAN được gọi là Router on a sticky
    • Việc định tuyến giữa các VLAN bằng thiết bị Switch layer 3(multil layer sw) gọi là kỹ thuật Multi layer Switch

    II. Cấu hình VLAN Trunking

    - Để các VLAN truy cập được lẫn nhau
    - Dùng để định tuyến các VLAN

    cau hinh VLAN trunking

    - Có 2 chuẩn Trunking:

    • IEEE: 802.1q(dot1q)
    chuan 802.1q (dot1q)
    • Cisco: ISL(inter switch link)
    - Nên dùng chuẩn quốc tế vì system dễ dàng thêm các thiết bị mới mà không phải đồ của Cisco vẫn hoạt động tốt( Cisco cũng đang loại bỏ dần ISL ra khỏi thiết bị)
    - Chọn chuẩn 802.1q hay ISL(Các dòng Sw 2900 thì ko cần đánh vì mặc định là dot1q ko hỗ trợ ISL, nhưng các dòng 3500 cần vì nó hỗ trợ cả 2 chuẩn)


    Switch(config-if)#switchport trunk encapsulation {dot1q/ISL}
    - Chuyển mode cho lên trunk hay ko

    Switch(config-if)#switchport mode {access/trunk/desiable/auto}
    - mode phân ra 2 dạng
    • Static: access, trunk
    • Dynamic: desiable,auto(Dynamic thì 2 port sẽ tự động thương lượng với nhau bằng giao thức DTP: Dynamic Trunking Protocol)
      • Desiable: chủ động gửi gói tin DTP
      • Auto: bị động, ko gửi gói tin DTP
    cac mode trunk vlan


    - Để kiểm tra bảng VLAN

    Code:
    Switch#show vlan
    - giả sử port f0/24 không có trên bảng VLAN(do port đó đã chết hoặc đã lên trunk khi lên trunk thì port đó sẽ không thuộc VLAN nào cả)
    - Kiểm tra port trunk

    Code:
    Switch#show interface trunk

    III. VTP Protocol ( VLAN trunking protocol)
    1 VTP và các mode VTP
    - Giúp đồng bộ thông tin các VLAN trên tất cả các Switch(Chỉ có trên Cisco) với nhau
    - Không đồng bộ port vì các switch có số port khác nhau
    - Điều Kiện để có VTP:

    • các đường dây nối giữa các Sw với nhau phải là đường trunk
    • Các Sw phải tổ chức chung 1 domain
    - VTP chia làm các mode

    cac vtp mode cisco

    - Send VLAN bằng gói tin VTP aclver lesment định kỳ là 5 phút/1 lần. Để duy trì đồng bộ thông tin VLAN của nó
    - Mode transparent giúp:

    • Tránh các bất cẩn về Revision number
    • sử dụng được các VLAN từ 1006-4094
    • các pc trong cùng 1 VLAN cùng 1 subnet không nhìn thấy nhau là kỹ thuật Private VLAN(CCNP) thường dùng ở các ISP để tiết kiệm IP.

    2. Revision number Cisco Switch

    - Phản ánh độ cập nhập thông tin VLAN mới nhất trên Switch
    - Chỉ số càng càng cao thì thông tin càng mới
    - Thằng có chỉ số thấp sẽ học của thằng cao
    - Revision bắt đầu = 0, khi ta tác động vào Sw(tạo, thêm, xóa, sửa …) thì nó sẽ tặng lên 1 và không thể giảm. Tăng tối đa đến 2[SUP]32[/SUP]
    - Khắc phục viêc down system khi thêm Switch mới

    Revision number tren switch cisco

    - Giả sử sw1 và sw2 cùng 1 VTP domain và đã có đường trunk.
    - Khi ta cắm thêm 1 sw3 vào hệ thống thì toàn bộ system mạng die
    - nguyên nhận:

    • Lúc này Sw2 sẽ thương lượng(mode dynamic) với sw3 để sw3 lên được trunk
    • Sau khi sw3 và sw2 có kết nối trunk thì sw2 sẽ gửi thông tin domain cho sw3 để sw3 học
    • sau khi sw3 có đường kết nối trunk và domain thì nó sẽ tiến hành đồng bộ VLAN. Giả sử lúc này Sw3 có chỉ số Revision number là cao nhất và có vlan 1 default
    • Lúc này các sw còn lại trong mạng sẽ đồng bộ Vlan sw3 ==> các sw2 chỉ còn một vlan 1 và sw1 còn một vlan 1 ==> hậu quả là các Vlan khác bị mất ==> dẫn đến system die khi gắn thêm 1 sw mới
    - Khắc phục
    • Cách tốt nhất không để Sw ở mode server, nên chuyển hết các Sw thành mode Transparent
    • Tắt chế độ thương lượng VTP trên Sw(các dòng 2950,2960, 3550 và 3560 default tất cả các port là mode auto)

    Để tắt việc thương lượng ta dùng lệnh
    Code:
    Switch(config-if)#switchport nonegotiate
    - Khi 2 Sw có cùng chỉ số Revision number thì không ai học của ai

    3. Reset số Revision number Cisco switch

    - Có 2 cách để reset số revision number Cisco switch

    • Khi Sw đang ở mode Server thì ta chuyển nó về mode Transparent
    • Đổi tên domain: đặt 1 tên domain khác với domain ban đầu của hệ thống sw sau đó đổi lại domain của system(Revision number=0)
    - Lệnh chuyển mode của Switch
    Code:
    Switch(config)#vtp mode {server,client,transparent}
    Switch(config)#vtp doamin tên
    Switch(config)#vtp password pass
    Tên domain và pass phải giống nhau trên các VLAN
    - Để kiểm tra trạng thái Domain giữa các Sw giống nhau chưa, xem được cả chỉ số Revision nuber

    Code:
    Switch#show vtp status
    - Nếu vẫn chưa học VLAN thì ta kiểm tra xem đường nối giưa Sw đã lên trunk chưa
    Code:
    Switch#show interface trunk
    - chờ 5 phút để đồng bộ
    - Nếu vẫn chưa đồng bộ thì ta tạo 1 VLAN bất kỳ để triger nó gửi lại để đồng bộ(Có thể do đường truyền kém)
     
    Last edited: Jul 25, 2016
    RPT000 likes this.
  2. RPT000

    RPT000 New Member

    Joined:
    Jun 9, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Cảm ơn bạn nhiều :D
     

Share This Page